8 Replies Latest reply on Apr 20, 2017 7:09 PM by Fabrizzio N

    How to fix file association for .swf

    d0brin Level 1

      So after updating to CS5 i have this problem that the .swf files lost their file association to open the .swf localy... in the program list i dont have anywhere flash player and i dont know what to do to make the .swf open like they did before? any ideas?

        • 1. Re: How to fix file association for .swf

          After not being able to find any information on fixing this, I tried some of my own solutions, and this one works.


          To fix broken swf file association


          Open Windows Explorer...Tools...Folder Options...File Types


          Scroll to swf and delete it


          Try to open an swf and select IE and click ALWAYS USE THIS PROGRAM


          IE will try to open the file, click CANCEL


          Go back to File Types and scroll down to the new swf entry


          Click Advanced


          Click Open under the actions box and click EDIT


          In the Application used to perform this action: box type the following


          "C:\Program Files\Adobe\Adobe Flash CS5\Players\FlashPlayer.exe" %1

          (assuming you installed flash in the default location)


          In the Application: box chance IEXPLORE to FlashPlayer


          Click OK...OK...Close


          SWF's will now open with the flash player!



          3 people found this helpful
          • 2. Re: How to fix file association for .swf
            d0brin Level 1

            OMG thanks that TOTALY fixed it... thanks a lot just small problem the icons changed... they are not with the swf icon :X can you tell me some trick about that too?

            • 3. Re: How to fix file association for .swf
              kglad Adobe Community Professional & MVP

              (you should mark his answer as correctly answering your thread, not just mark your thread as answered.  now, at least, mark it helpful.)

              • 4. Re: How to fix file association for .swf
                jricci9 Level 1

                If you go back into the TOOLS...OPTIONS...SWF etc etc...above the open under the actions box there should be a CHANGE ICON button, use that and navigate to the FlashPlayer.exe file and in that file there are icons to use.


                Now today I rebooted my computer and it forgot the swf association, if this happens, go back to the TOOLS...OPTIONS etc etc and when you click the swf entry in the list, there should be a RESTORE button, click that and it should say using Adobe Flash Player 10.1.r52


                You should be all set.

                1 person found this helpful
                • 5. Re: How to fix file association for .swf
                  d0brin Level 1

                  THANKS A LOT it totaly fixed my problem

                  • 6. Re: How to fix file association for .swf

                    I'm on windows 7 and don't have the option to delete file association. Where is flash player 11 installed to so I can refer to it?

                    • 7. Re: How to fix file association for .swf
                      htbasaran Level 1

                      Hello there,


                      I know this post is very old, but the problem is current. I had the same problem yesterday and I was able to manage it to work as usual again. Here's how i got it working again:


                      1. Open regedit.

                      2. Find HKEY_CLASSES_ROOT/.swf (if you have Adobe flash pro CSx, just right click and delete it, else, make sure the key data is like: name:(default), type: REG_SZ, value: ShockwaveFlash.ShockwaveFlash)

                      3. Find HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/FileExts/.swf ((if you have Adobe flash pro CSx, just right click and delete it, then go to step 5)

                      4. Expand .swf file extension folder, if you have UserChoice folder, simply delete it. Locate OpenWithProgids folder (if you can not find it, create a key named "OpenWithProgids" by right clicking the .swf folder. And in the right-hand-side panel, make sure there is a binary value like: name ShockwaveFlash.ShockwaveFlash, type: REG_NONE, value: (empty binary value), if not, create it by yourself by right clicking in the panel and selecting New > Binary Value)

                      5. Close regedit.

                      6. If you have Adobe flash pro CSx installed on your win 7, reinstall it.

                      7. Reboot your system.


                      Thats all, It was worked for me, i hope it works for you too.

                      2 people found this helpful
                      • 8. Re: How to fix file association for .swf
                        Fabrizzio N

                        It worked for me, thanks!