2 Replies Latest reply on May 19, 2010 12:19 PM by Crovaxon

    Why cannot uninstall AIR

    roy_chen

      I was testing my air app, I install and uninstall AIR several times in XP sp3. After that I cannot uninstall or install AIR any more. When I click the 'Remove' button in "Add or Remove Programs" window, a Error message show:

       

      error.JPG

      All the air applications cannot run too, show the same window(except the icon and name.)

       

      I reinstall my system, and did the same thing(install and uninstall AIR serval times), the Error show again.

       

      Does anyone know how to recover from this, I don't want to reinstall my system any more.

       

      Very Very sorry for my poor English!

        • 1. Re: Why cannot uninstall AIR
          roy_chen Level 1

          The same problem show in Windows Server 2008 R2 too.

          • 2. Re: Why cannot uninstall AIR
            Crovaxon

            Hello.
            I, too, have a problem with uninstalling AIR showing similar errors.

            I had Adobe AIR installed for Balsamiq Mockups and for League of Legends, a game that uses it in its menues apparently. After the latest patch of League of Legends I tried to run the game but my PC froze and I had to do a cold shutdown. Afterwards the game was not working anymore, upon launching it I got a typical Windows Error (blablabla has encountered a problem blah).
            AppName: lolclient.exe     AppVer: 1.5.0.7220     ModName: adobe air.dll
            ModVer: 1.5.3.9130     Offset: 000cf515

             

            I wanted to uninstall Adobe AIR and reinstalling it anew, but trying to unistall it in the Software Menu brings up another Error of that kind. So much for deinstalling...

             

            I downloaded Adobe AIR setup again and tried it per -uninstall from the command window but it produces the same error. All of these errors are pointing to the same ModName: adobe air.dll.

             

            I would absolutely dislike to set up my Computer from scratch because of this, so could anyone tell me if there is a way to get rid of Adobe AIR manually so I can at least try to reinstall/overwrite?

             

            All happened on Windows XP Sp3.

             

            Thanks a lot for any help.