6 Replies Latest reply on Jun 21, 2011 10:39 AM by roc524

    FDF file not opening in IE 8 with Adobe reader 9 or Adobe pro 9

    ravishguru

      Hi

       

      I have a fdf file that is  working fine with IE 7 when I am using adode reader 9 or pro. But the  same fdf is not working fine if my browser is IE 8 . The target element   for the fdf is a file that is there in our web server. The same FDF is also working fine in IE 8 if the version is reader used is 8 or lower

       

      can any one help me to fix  this.

       

       

      Thanks in Advance

      RAVISH G

        • 2. Re: FDF file not opening in IE 8 with Adobe reader 9 or Adobe pro 9
          pwillener Level 8

          Do you have the add-on enabled in Internet Explorer?

           

          Also, when it is "not working" - what happens when you try it?

          • 3. Re: FDF file not opening in IE 8 with Adobe reader 9 or Adobe pro 9
            ravishguru Level 1

            hi ,

             

             

            I tried it with all the add on disabled but the same result.

             

            The PDF is opening but the data from the FDF is not present in the the PDF.

             

            thanks

            • 4. Re: FDF file not opening in IE 8 with Adobe reader 9 or Adobe pro 9
              Bilange

              I will add a "Me too" onto this thread. I have to use a third-party site which sends an FDF document (over Internet Explorer), however Adobe Reader doesn't load inside this browser window, but rather launches itself *outside* of this browser window (in standalone mode, more or less)...

               

              In fact, when Adobe Reader is loading outside the browser window the only thing I have here is the original PDF document where the data should be added on. The PDF file is actually a form but I have it displayed "blank", that is without any user-provided data. On Internet Explorer's point of view, I only have the "PDF File" icon in the center of my window, but nothing else (all white)

               

              Here are the specs:

               

              • Toshiba Satellite laptop
              • Windows Vista Home Premium, all patched
              • Latest Adobe Reader available when typing this reply (9.3)

               

              I have: 

               

              • Uninstalled, reinstalled Adobe Reader, but nothing better happens (Adobe Reader just pops out of the browser to display the original PDF file)
              • Upgraded to Internet Explorer 8 (as I was running IE7 on this PC), also added the URL of the intranet site in question in my "trusted sites" in IE
                • Speaking of Internet Explorer, I also did a "reset to default values" many times over this process
              • Double-checked the values in the Windows Registry in HKEY_CLASSES_ROOT to see that both FDF and PDFs are gonna be executed on Adobe Reader (I have no other PDF readers or writers installed anyway)
              • Double-checked that the Activex control that is needed to be run so Adobe Reader can start is actually whitelisted in Microsoft's IE registry, more on this here
              • Ensured that Edit, Preferences, Internet, "Display in the browser" is in fact checked. I did the extra mile here: I unchecked, pressed OK, left Adobe Reader then came back to enable it again just in case something doesnt get written accordingly to those settings in the UI.

               

              Now i'm out of clues

               

              For what its worth, only internet explorer gives me this problem, Firefox and Chrome just opens Adobe Reader inside the browser with the FDF provided.

              • 5. Re: FDF file not opening in IE 8 with Adobe reader 9 or Adobe pro 9
                BertABCD1234

                I have had this problem as well and have been able to (partially) solve it.

                 

                Mostly, you need to make sure that the appropriate site is in the Trusted Sites zone of Internet Explorer. You also need to add it to the list of allowed sites in Adobe Reader/Acrobat, as well (Edit > Preferences, "Trust Manager"). For me, this was a problem because the original form was located on a Web server; this was the address we needed to add. In fact, both Reader and IE normally asked if I wanted to allow the site, thus cluing me in: Reader with a popup asking if I wanted to allow the site, and IE with a yellow bar at the top. Reader gives you the option to "remember," which will save it to the Trust Manager for you.

                 

                Unfortunately, for me this also breaks similar FDFs that are sent as e-mail attachments and opened directly from Outlook. Copying them locally (e.g., dragging to the desktop and then opening that file) works. They also work if we remove the site from the "Trusted Sites" zone in IE--this lets the yellow bar appear, which we need to click, but at least it works. Mysteriosuly, adding the site to Trusted doesn't work AND doesn't give the yellow bar, so there's no way to get around the blank form.

                 

                So, the best solution I've found so far is to add the appropriate sites to the Trusted Sites in IE and the Trust Manager in Adobe Reader/Pro (and first save any Outlook FDF attachments locally before opening them). I'm still trying to figure out why attachments from Outlook don't work when opened directly from the application, however.

                • 6. Re: FDF file not opening in IE 8 with Adobe reader 9 or Adobe pro 9
                  roc524

                  Bert has a very helpful post above. I was also having a problem in which my FDF form opened with blank fields in IE8 (using Adobe Reader X).  After removing the associated  PDF file's URL from the IE8 "Trusted sites" zone, it started working!!!  After putting that URL back in the trust sites, it stopped working!  This is totally counter-intuitive!  How do I explain to my client that he has to remove his own website from his trusted zone?  Can someone please tell me why this behavior occurs?

                   

                  Note that this is true with my PDF's URL in the Adobe Reader's "Security (Enhanced)" "Privileged Locations" box.