1 Reply Latest reply on May 14, 2010 3:00 PM by Nancy OShea

    Library items with wrong link paths - how to fix?

    allfourthem

      Hello All,

       

      I am not terribly familiar with Dreamweaver and don't update my website frequently enough to remember how to do things from one session to the next. I'm running into a problem that I've run into before ... and fixed ... but I don't remember the fix. I need help, please.

       

      I'm using Dreamweaver MX 2004 on a Mac running OS 10.3.9. I use one template and half a dozen or so library items to update my website pages. Several of the library items include navigation links to other pages on my website. Yesterday I was doing some updating of these library items, and somehow I messed up the navigation. Before my "update", the navigation links in those library items pointed directly to the intended pages as in the links in the sidebar on the following page:

       

      http://lfrazer.com/iris/rosybows.html

       

      After the update, Dreamweaver changed the link paths in my navigation codes to include "library", so the navigation links no longer work correctly as on the following page:

       

      http://lfrazer.com/iris/acoma.html

       

      The "library" part of the link paths are not present in the library items themselves when I edit then, so I don't know how to get it out. It's something that Dreamweaver adds all on its own when a navigation library item is put into a webpage. How do make Dreamweaver quit adding that "library" part of the link paths in the library item itself without having to edit it out of each page individually (which entirely defeats the purpose of the library item)?

       

      Thank you for your assistance,

       

      Laurie