0 Replies Latest reply on May 14, 2010 2:24 PM by Mike6679

    VideoDisplay  rtmp stream - error 1000 on replay

    Mike6679 Level 1

      Hi,

       

      I am unable to restart my video after it plays once all the way through.  I keep getting error

       

      error: 1000: Unable to make connection to server or to find FLV on server.

       

       

      when I call  videoDisplay.play() after the video is done playing. Obviously it can find becasue it found it the first time through, Could this be due to the fact its an rtmp stream?  what else could be the issue?

       

      thanks in advance...

       

       

       

       

      <mx:Canvas  id="myCanvas"  visible="true"  rollOver="showControls()" rollOut="hideControls()">
              <mx:VideoDisplay   rewind="onRewind(event)" visible="false"  ready="onVideoReady(event)" id="videoDisplay" source="rtmp://myserver.com/flash/Desertrace.f4v" autoPlay="true" playheadUpdate="videoDisplay_playheadUpdate(event)" />
              <mx:HBox visible="false" id="controls" styleName="controllerStyle" alpha="0.0">
                  <mx:Button id="playPauseButton" styleName="playPauseStyle" toggle="true" selected="{videoDisplay.playing}" click="playPauseButton_click(event)" />
                  <mx:Button id="stopButton" styleName="stopStyle" click="stopButton_click(event)" />
                  <mx:Spacer width="100%" />
                  <mx:Label id="time" styleName="timeStyle" />
              </mx:HBox>
             
               <mx:ProgressBar  id="myProgress" indeterminate="true" minimum="0" maximum="100" label="Loading Movie..." fontSize="12" fontFamily="Arial" fontWeight="bold" color="#080808">
             </mx:ProgressBar>

       

             
            
          </mx:Canvas>