2 Replies Latest reply on May 16, 2010 9:04 PM by itsnotalwayseasy

    Getting "Unable to write cache file" message in DW CS4

    itsnotalwayseasy

      I was having some issues with a Javascript message, so looking for possible solutions, I came across “Deleting a Corrupted Cache File” in the Index to Dreamweaver FAQ located on this forum. I decided to give it a shot and carefully followed the instructions on my Windows XP, deleting the suggested cache file in my Configuration folder. That didn’t help make my Javascript message go away, though I did eventually find a work-around for that issue.

       

      However, after deleting this cache file, I began to get the following message every time I close my program or change sites in local files, “Unable to write cache file ‘C:\Documents and Settings\...” the message ends with the site name and the extension .dws.  If I go to Manage Sites and turn off the Enable Cache button for that particular site, I no longer get the message. But if I turn the Enable Cache Button back on, I get the message again. It gives this same message for all the sites.

       

      I’m hoping others have had this issue and there is a simple fix. I can’t say for sure that deleting the cache file in the configuration folder caused this, but it was only after that I began noticing the problem, so it would make sense the two are likely related.

       

      Also, I wonder how important the cache is. I could just turn off the Enable Cache Button for all the sites as a work-around if there's no quick fix and if it’s no big deal.

       

      -Steve

        • 1. Re: Getting "Unable to write cache file" message in DW CS4
          Randy Edmunds Adobe Employee

           

          I was having some issues with a Javascript message, so looking for possible solutions, I came across “Deleting a Corrupted Cache File” in the Index to Dreamweaver FAQ located on this forum. I decided to give it a shot and carefully followed the instructions on my Windows XP, deleting the suggested cache file in my Configuration folder. That didn’t help make my Javascript message go away, though I did eventually find a work-around for that issue.

           

          However, after deleting this cache file, I began to get the following message every time I close my program or change sites in local files, “Unable to write cache file ‘C:\Documents and Settings\...” the message ends with the site name and the extension .dws.  If I go to Manage Sites and turn off the Enable Cache button for that particular site, I no longer get the message. But if I turn the Enable Cache Button back on, I get the message again. It gives this same message for all the sites.

           

          I’m hoping others have had this issue and there is a simple fix. I can’t say for sure that deleting the cache file in the configuration folder caused this, but it was only after that I began noticing the problem, so it would make sense the two are likely related.

           

          Also, I wonder how important the cache is. I could just turn off the Enable Cache Button for all the sites as a work-around if there's no quick fix and if it’s no big deal.

           

          First of all, only delete cache files when DW is shutdown.

           

          Also, there are a few different caches. That article only addresses 1 of them. Take a look at this TechNote to be able to find the Site .dws cache files:

          http://kb2.adobe.com/cps/598/5989f7f4.html

           

          HTH,

          Randy

          • 2. Re: Getting "Unable to write cache file" message in DW CS4
            itsnotalwayseasy Level 1

            Randy,

             

            It worked! I deleted the .dws files in the site cache folder. Before, I hadn't noticed them, because they were hidden at the bottom of the screen. All I saw was folders corresponding to each site, and there was no .dws file in those, only an XML file that looked like it had no specific information in it. So once I located those .dws files and deleted them, and recreated the site caches in each folder, it did the trick!

             

            Thanks!!

             

            Steve