1 Reply Latest reply on May 17, 2010 10:14 AM by Flex harUI

    Problems loading modules (but no error on compile or run)

    mathijsgiesbers

      Hi,

       

      I have some problems loading modules, i visited almost every forum on the web but not found the right solution.

       

      The problem:

      I have an web application (Main) containing an object that load/unload/reload modules. This code worked fine.But after a project clean, and thus a rebuild of the application it stopped working. The problem now occurring is thatthe modules load and initiate correctly (found this using the debug mode), but the modules are not showing up, at leastnot when I add components to the mxml. the weird thing is that when i add components after the module is created, it works fine.I am not receiving a error, to make this problem a bit stranger

       

      following (simplified) code works:

       

      <mx:module creationComplete="creationCompleteHandler()">

           <fx:script>

                protected function creationCompleteHandler() : void {

                     this.addChild(new TextInput);

                }

           <fx:script>

      </mx:module>

       

      Following (simplified) code is not working:

       

       

      <mx:module>

           <mx:TextInput />

      </mx:module>

       

       

      I tried to merge libraries in the code (build option) but this did not solve the problem. Any suggestions?

       

       

      Mathijs Giesbers

       

      Message was edited by: mathijsgiesbers Also the application is acting strangely after a module load (looks like the displayobjects are not properly redrawn again after a change)