11 Replies Latest reply on Aug 10, 2007 3:14 AM by Newsgroup_User

    Wierd thing happening

    ~Billy~ Level 1
      I have a Div on my site for content, at the moment there are two lines of plain text inside it. When I click Refresh in IE7 the div vanishes. If I have another Tab open in IE7 and click to view that, then click back to my page the Div re-apperars!

      Any ideas why?

      www.tomkilbourn.com - this is where the content will go...this is where the content will go...
        • 1. Re: Wierd thing happening
          Level 7
          On Mon, 6 Aug 2007 19:36:44 +0000 (UTC), "~Billy~"
          <webforumsuser@macromedia.com> wrote:

          >I have a Div on my site for content, at the moment there are two lines of plain
          >text inside it. When I click Refresh in IE7 the div vanishes. If I have another
          >Tab open in IE7 and click to view that, then click back to my page the Div
          >re-apperars!

          There are a few problems with the page. First, you seem to be
          over-engineering it. Why so many <div> tags? You have 25 opening <div>
          tags and 27 closing </div> tags. That cannot be right. You need to
          figure out which two are the extras and remove them. Personally, I'd try
          to simplify it considerably.

          You also have some mixed html and xhtml. Change this:
          <link rel="shortcut icon" href="/images/favicon.ico" />

          To this:
          <link rel="shortcut icon" href="/images/favicon.ico">

          Change this:
          <br style="clear: both;" />

          To this:
          <br style="clear: both;">

          You have a style sheet link inside the body of the page:
          <link href="/Templates/main_site_template_css.css" rel="stylesheet"
          type="text/css" />

          That duplicates a link that is properly located in the head of the
          document. Delete the above link.

          On a side note, it appears that you have your style sheet located inside
          your Templates folder. That will cause you problems later on with things
          not updating correctly. You should move it out of the Templates folder.
          The ONLY thing that should be located in the Templates folder are the
          actual .dwt template files.
          • 2. Wierd thing happening
            ~Billy~ Level 1
            Hi thanks for those tips and advice, I will make the changes you have mentioned tomorrow and let you know how they went.

            I dont see where the style sheet css file is located inside the body tag however, It is in the opening Head tag.
            I have created the site using divs, so to get the positionings I want I guess that is why there is so many div tags. I have used some as "wrappers" around other divs. I have remove a couple of them, if u can spot any more let me know!

            Many thanks!!

            ~Billy~
            • 3. Re: Wierd thing happening
              Level 7
              On Mon, 6 Aug 2007 20:56:50 +0000 (UTC), "~Billy~"
              <webforumsuser@macromedia.com> wrote:

              >Hi thanks for those tips and advise, I will make the changes you have
              >mentioned tomorrow and let you know how they went. Excellent tips!
              >
              >Many thanks!!

              You're welcome. Hope it helps.
              • 4. Re: Wierd thing happening
                ~Billy~ Level 1
                Ive made the changes you suggested but the div is still dissapearing and its wrapper div is appearing, but there is a break, then it re-appears. BlueDiv, HiddenDiv and ContentDiv.

                I have everything positioned as I want, just have this issue with these divs.

                www.tomkilbourn.com
                • 5. Re: Wierd thing happening
                  OCEANTEC
                  hey billy. its jack
                  • 6. Re: Wierd thing happening
                    damonwsharp
                    try running your page through the w3c validator to see if you get any helpful error messages...

                    http://www.w3schools.com/site/site_validate.asp
                    • 7. Re: Wierd thing happening
                      ~Billy~ Level 1
                      The page has been passed as This Page Is Valid HTML 4.01 Transitional!

                      And I do not know who Jack is :s
                      • 8. Re: Wierd thing happening
                        Level 7
                        On Thu, 9 Aug 2007 15:45:01 +0000 (UTC), "franticnomad"
                        <webforumsuser@macromedia.com> wrote:

                        >try running your page through the w3c validator to see if you get any helpful error messages...
                        >
                        > http://www.w3schools.com/site/site_validate.asp

                        better go straight to w3 site:
                        http://validator.w3.org/


                        --

                        ~Malcolm N....
                        ~
                        • 9. Re: Wierd thing happening
                          Level 7
                          On Thu, 9 Aug 2007 15:40:52 +0000 (UTC), "~Billy~"
                          <webforumsuser@macromedia.com> wrote:

                          >Ive made the changes you suggested but the div is still dissapearing and its
                          >wrapper div is appearing, but there is a break, then it re-appears. BlueDiv,
                          >HiddenDiv and ContentDiv.


                          You still have a couple of errors in your CSS:

                          #rightMenu {
                          background-color: #999999;
                          width: 150px;
                          float: right;
                          border 1px solid;
                          margin-right: 10px;
                          margin-top: 10px;
                          border: 2px solid #BBB;
                          height: 335px;
                          }

                          Note that you have no color specified for the border property.

                          #p7menubar {
                          font-size: 0.85em;
                          width: 500px;
                          height: 100%;
                          background-color: #C6C6FF;
                          psdding: 0px;
                          }

                          Note the typo psdding should be padding.
                          • 10. Wierd thing happening
                            ~Billy~ Level 1
                            Ive sorted it.
                            • 11. Re: Wierd thing happening
                              Level 7
                              On Thu, 9 Aug 2007 21:46:59 +0000 (UTC), "~Billy~"
                              <webforumsuser@macromedia.com> wrote:

                              > Is anyone else seeing it in IE7? I have checked it on two computers and both
                              >are having the same problem.

                              No IE7 on this machine.