2 Replies Latest reply on May 18, 2010 12:06 PM by Peter Flynn (Adobe)

    Go to an Play on Button Click

    Xeon64 Level 1

      I have a flash animation, swf,  that plays when the user clicks a button. I want the user to click the button multiple times to replay the animation from the begining. The problem is that when the user clicks the first time the animation plays, click a second time nothing happens, click a third time it works.

       

      The scenario is this:

       

      click: animaiton plays

       

      click: nothing

       

      click: animation plays

       

      click: nothing

       

      I can not figure what is going on. I checked the timing of the swf file in flash, fades in catalyst, and still can not find the issue.

        • 1. Re: Go to an Play on Button Click
          Peter Flynn (Adobe) Adobe Employee

          Hi Xeon,

           

          What sort of action are you using in the button's action sequence?  This should work if you use a "Go to Frame and Play" action (with the frame set to 0 to restart from the beginning of the animation).  This way, even if the user hits the button before the complete animation has finished, it will restart immediately.  (If you're simply using a "Play SWF" action, clicking the button again before the animation finishes playing will do nothing -- that might be what you're seeing, especially if there are some "idle" motionless frames at the end of the SWF).

           

          - Peter

          • 2. Re: Go to an Play on Button Click
            Xeon64 Level 1

            I had a stop action at the begining and one at the end of the swf since I was going to play what was between them. This is what was causing the problem for me. Once I removed the stop action at the end and left one at the begining it worked. This is weird because the animation worked fine with the beta verison of Catalyst and then when I upgraded to the released verison it need to be fixed. THanks for the help.