7 Replies Latest reply on Apr 25, 2012 3:25 AM by Banan_hylsa

    Annoying "Dynamically-related..." alert

    Creyente de Dios

      I keep getting the following alert in the bar at the top of the source code:

       

      "dynamically-related files cannot not be discovered because there is no site definition for this document"

       

      Is there any way to stop telling me this? I keep closing it but it just comes back after a few saves of my source code.

      Searching updates...1/7
      close
        • 1. Re: Annoying "Dynamically-related..." alert
          sheacasey

          I second this. very annoying. please help make it stop!

          • 2. Re: Annoying "Dynamically-related..." alert
            Richard_vav Level 3

            In dreamweaver open the preferences screen which on windows is located at the bottom of the edit drop down menu.

            Click on the 'General' category.

            Under the fourth tick box down (enable related files) you will find a drop down (discover dynamically-related files) change this from 'automatically' to 'disabled'

             

            Richard

            • 3. Re: Annoying "Dynamically-related..." alert
              sheacasey Level 1

              Actually switching it to disabled didn't work, when DW was restarted it would default back to "manually" and would still popup. so in order to actually make it stop, i had to just uncheck that entire section "Enable Related Files", it prompts to restart DW which after doing makes it so it doesn't annoyingly pop up anymore. Thanks for your help Richard.

              • 4. Re: Annoying "Dynamically-related..." alert
                Creyente de Dios Level 1

                Thank you so much guys! Every time I save in PHP it pops up and it was annoying!

                • 5. Re: Annoying "Dynamically-related..." alert
                  Jiarsep

                  yep... VERY annoying. But the solution: Edit > Preferences > General > under Document Options > Enable related files > Disable

                   

                  gets rid of the annoying popup but then related files don't show under the file tab. For example, under index.php it would show main.css and other related files so you can switch quickly and easily. With Related files disabled then they don't show which is equally as annoying!

                   

                  So you can either have:

                  option 1) annoying pop up with related files showing

                  or

                  option 2) no annoying popup and no related files showing

                   

                  Is there a way to just get rid of this extremely annoying pop up without having to setup a testing/remote server. I wish they just left it alone from CS4.

                   

                  Any ideas anyone??

                  • 6. Re: Annoying "Dynamically-related..." alert
                    HedoBum

                    I have the same problem and haven't been getting any help anywhere to fix this.

                    It appears that Dreamweaver has annoying bug that needs to be fixed. There is a bug reporting area to post this issue to the Dreamweaver design team. Apparently they don't monitor the forums (poor design practice choice) so getting help here is kinda hit-and-miss because you end up getting something like the "disable dynamically related files" solution which, as you know, doesn't solve the problem at all...it merely shifts the weight of it.

                    The only thing we can do as I see it is report the bug and hope for the best. Until then, it looks like we'll have to be content with shutting the bar off manually whenever it pops up (you have probably noticed that whenever an error message shows up, that dynamically related files error pops up with it and remains even after the other error has been resolved).

                    I also noticed that if I choose the discover dynamically-rleated files option, Dreamweaver goes into f***-you mode and doesn't respond. The only way I can keep Dreamweaver from doing this is to not mess with the discover dynamically-rleated files option.

                     

                    I will probably check back in the forum from time to time to see if there's been a brilliant mind that has solved the problem, but until then I'll be submitting a bug report and I encourage you to do the same...the sqeaky wheel gets the grease.

                    • 7. Re: Annoying "Dynamically-related..." alert
                      Banan_hylsa

                      You must remember to use the template file if the html is on another file.