6 Replies Latest reply on May 19, 2010 12:56 PM by Valter Vilar

    Alpha Channel Question

    npelon

      Hello,

      I have an animation with a white drop shadow on it that I animated in Aftereffects.  I export the file from Aftereffects and no matter what I try the white drop shadow shows up as a dark shadow every time in Premiere as if it's matted with black.  So I'm wondering if there is a setting I'm missing or something I need to do differently when importing to Premiere, or even when exporting from aftereffects, although I've exporting it several different way so far to no avail.

       

      So here is what I have,

       

      I'm using Adobe CS4 for AE and Premiere, on Windows 7

       

      When I export from AE I'm using the color setting for unmatted (and I've tried it matted with black too just for fun, clearly that didn't work out for me:)

      I've tried it as an avi and as a mov file too.

       

      Sooo, in case your answer is for me to use Dynamic Link, I can't get that to work either.  And I'm sure that is just user error since I've never used it before.  I can get the aftereffects sequence to show up in my project files in Premiere, I can even get the animation to show up and play in the preview monitor, but when I put it on my Premiere sequence over the background it doesn't show up, just seems like a blank layer.

       

      Any ideas?

       

      Nina

        • 1. Re: Alpha Channel Question
          Valter Vilar Level 2

          Nina,

           

          EDIT: I just tried exporting as a Quicktime animation mov + alpha and it works beautifully in premiere CS5. Important, choose RGB + ALPHA. that will embed the alpha channel together with your animation.

           

          If exporting your animation as a sequence of PSDs fails you can try this:

           

          Tga is a file format that was used for a long time just because it supported alpha channels well and Targas where very popular back in the day, you are probably too young to know that ... Did you try exporting it as as a sequence of pictures (tgas) and building it back in Premiere? I find it hard to believe that Premiere would not do that simple task right... Please let me know.

           

          When I work with animations from let's say Maya or Lightwave, I export them as a sequence of pictures, not as a mov or quicktime since support for alpha channel is non existent or screwy. This way I can keep my pictures at full res and easily fix/re-render only a few if I spot problems in them.

          • 2. Re: Alpha Channel Question
            npelon Level 1

            Oh geeze,

            well I have the file exported as a targa sequence, and then i exported the alpha separatly as a targa sequence.  I imported them both into Premiere.  Now to figure out which key to use to get the alpha to work with the animation and I can't figure it out.  I'm sorry if I seem slow at this, I am old enough to know how these things should work, I do remember animation pic sequences and separate alpha channels.   I also remember just putting a simple matte key over the top and voila!  however Premiere is a whole different beast that I'm just now learning how to use.

             

            Oh yeah, also I usually have no problem with quicktime animations and their alpha's it's just this file has a white shadow and that's the part that isn't displaying properly over my background when rendered as a quicktime.  But I am using CS4 and not CS5.

            • 3. Re: Alpha Channel Question
              Ann Bens Adobe Community Professional & MVP

              Dont use Export but Add to Render Queue and select Lossless in the Output Module with the channels set to as said before RGB+Alpha.

              Should play with drop shadow on a transparant background just fine in CS4.

              • 4. Re: Alpha Channel Question
                Valter Vilar Level 2

                Hmm.. I don't have CS4 installed any longer but you didn't say if you tried RGB + alpha as a quicktime movie. I think CS4 has that option. Now, if Premiere CS4 will play nice with it... That is what I don't know. My guess is that Premiere does not like the fact that the alpha channel is separate?! I think targa can have the alpha channel together with the file. What about PSDs? Did you try that?

                 

                What effect are you using for the drop shadow? What if you rendered the shadow to another timeline thus converting it to a video file and then exporting it?

                 

                I often find myself stuck at the stupidiest things too!

                • 5. Re: Alpha Channel Question
                  npelon Level 1

                  Thanks for your replies!  So I'm not very good at explaining myself.  I did export (and by export i mean, make movie by adding it to the render queue) the file as both of you are recommending.  As a movie file, with an alpha channel, all one file.  The reason I was trying to do it separate next was because it wasn't displaying properly that way.

                  Finally, what I did as a work around, is just export the background I was using from premiere, import it into aftereffects, Put everything together in aftereffects and then render the finished file without using an alpha at all.  In pic #1 so you can see how premiere cs4 won't properly display an animation with a white shadow behind it if it's imported with an alpha channel and placed on top of a background.  #2 shows how it was supposed to look.. how it looked once I put everything together in Aftereffects instead.  I just thought there should be a way to fix my problem without the extra step of exporting the background.  But I don't think there is.

                  However,

                  THANK YOU for your replies and trys!!

                  Untitled-2.jpg

                  (Oh yeah I should also mention that I did try, PSD sequence, Quicktime rgb+alpha, Lossless with alpha etc.. none of which seemed to work for what I was trying to do.)

                  • 6. Re: Alpha Channel Question
                    Valter Vilar Level 2

                    Glad to know you've found a solution to your problem after all.Thanks for sharing the pictures, they look awesome!