0 Replies Latest reply on May 20, 2010 1:33 AM by Julien Kronegg

    [Solved] UnsatisfiedLinkError at startup

    Julien Kronegg

      Under Windows XP without administrator rights, after installation of Eclipse 3.5 with Flash Builder 4 plugin (build 272416), running Eclipse leads to the following behavior: at startup, Flash icons are displayed in the icon bar for 2-3 seconds then disapears. Afterwards, each Flash/Flex related actions (creating new Flex project, opening Flash perspective, opening Flash Builder 4 about dialog) leads to an error.

       

      All errors have the same root cause:

       

      Caused by: java.lang.UnsatisfiedLinkError: C:\Win32App\IBM\FormationRolex\dev\Adobe Flash Builder 4 Plug-in\eclipse\plugins\com.adobe.flexide.amt_4.0.0.272416\os\win32\x86\amt_win_jnilib.dl l: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem

              at java.lang.ClassLoader$NativeLibrary.load(Native Method)

              at java.lang.ClassLoader.loadLibrary0(Unknown Source)

              at java.lang.ClassLoader.loadLibrary(Unknown Source)

              at java.lang.Runtime.loadLibrary0(Unknown Source)

              at java.lang.System.loadLibrary(Unknown Source)

              at com.adobe.flexide.amt.AMTLib.initialize(AMTLib.java:134)

              at com.adobe.flexide.amt.Activator.AMT_Initialize(Activator.java:110)

              at com.adobe.flexbuilder.ui.asn.ASNUIBridge.start(ASNUIBridge.java:56)

              at com.adobe.flexbuilder.ui.UIPlugin.start(UIPlugin.java:91)

              at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:7 83)

              at java.security.AccessController.doPrivileged(Native Method)

              at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextIm pl.java:774)

              ... 68 more

       

      This issue is also referenced in http://forums.adobe.com/thread/444750. The proposed workaround (running Eclipse as administrator) did not work for me. The behavior also does not corresponds to the tests done in https://bugs.adobe.com/jira/browse/FB-17615, where creating a Flex project under Windows XP/Standard user works.

       

      Solution:

      I've managed to install and run the plugin under Windows XP by using the following procedure:

      1. Installation of Flash Builder 4 build 272416 with administrator rights (right click on the installer, "Run as..." command). Note that the integrated eclipse version does not work (not a single perspective available, not event the Java one), even when running as administrator
      2. Installation of Eclipse 3.5
      3. Copy of ...\eclipse-host-distro\dropins from installed software in step 1 to ...\eclipse\dropins from installed software in step 2.
      4. Run Eclipse installed from step 2 with a standard user (i.e. without administrator rights). No more UnsatisfiedLinkError; creating a Flex project worked.

       

      Why does this procedure works? In order to understand why this procedure worked, I repeated step 1 using a standard user (without admin rights) in another directory (without uninstalling the previous install done with admin rights), then step 2. And I was able to run Eclipse and create a Flex project.

      This would indicate that the first FlashBuilder installation with admin rights registered something (in the Windows registry?) which is reused by the second FlashBuilder installation without admin rights. This would confirm that FlashBuilder must be installed as admin but can be used as a standard user.

       

      Hope it helped...