12 Replies Latest reply on May 25, 2010 12:50 PM by Chorale0001

    Urgent - strange black flash on my website

    Chorale0001 Level 1

      Hello all

       

      This is somewhat an urgent matter, the website just got published and this bug appear. Open FIREFOX and go to my webpage at www.episodesoft.com and just move the cursor in and out of the button menu. do it a couple of time.

       

      You should get a full screen black flash of light each time.. Anyone know why ?

       

      The transparency of the flash ( menu) is correct for both firefox and IE.. i don't understand.

       

      The website work perfectly with IE, and Chrome. It is only a FF problems

       

      Please feel free to look at the source.

       

      I'll keep looking for the problems

        • 1. Re: Urgent - strange black flash on my website
          Ben M Adobe Community Professional

          What version of Flash are you using?  I'm using the 10.1 RC4 beta with Firefox 3.6.3 and notice no flashing on the page whatsoever.

          • 2. Re: Urgent - strange black flash on my website
            Chorale0001 Level 1

            Hello

             

            I'm using Flash CS4 AS2. as for Firefox i believe it is the latest version.. i've downloaded it only a couple day ago. I would have to check its version tomorrow morning.

            • 3. Re: Urgent - strange black flash on my website
              Chorale0001 Level 1

              I checked it is firefox 3.6.3

               

              Flash cs4 As2, SWF version :6.0.65.0

               

              Message was edited by: Chorale0001 I've isolated the probleme with the fact that the black flashes only when i activate the flash itself, if i replace the flash by a random picture, it work perfectly. i'm trying to see if it is something in the flash, but it seem weird that it could be inside the flash itself since i don't see it on any other browser

              • 4. Re: Urgent - strange black flash on my website
                hans-g. Adobe Community Professional & MVP

                Hi,

                 

                could this help to refresh your website by every visit (I qoute: Delay: The time in seconds to wait before the browser refreshes the page. To make the browser refresh the page immediately after it finishes loading, enter 0 in this box.)

                 

                 

                http://help.adobe.com/en_US/Dreamweaver/10.0_Using/WSc78c5058ca073340dcda9110b1f693f21-7b2 6a.html

                 

                Hans-G.

                Meilleures salutations et bonne chance.

                • 5. Re: Urgent - strange black flash on my website
                  Chorale0001 Level 1

                  Hi Hans


                  Thanks for the answer! but I fail to see how this help me in the current situation.

                   

                  I've managed to narrow the probleme to the flash itself by doing a small but usefull test.... After having disabled everything but the part require for the flash to work ( and the script to show/hide it ) i've added an image just above the flash itself. I've put that image in the same cell of the same tabloid of the same Div, so the image is just before the flash. I try to run in firefox and i discovered that the image will appear the right way, and that the flash ( below the picture ) will make his strange white ( now it is white ? ? ! ) flash before appearing. however that strange white flash didn't touch the image itself.. So something in the flash code must be wrong.

                   

                  function(){return A.apply(null,[this].concat($A(arguments)))}

                  <td align="center" valign="middle">
                  <img src="images/Header.png" width="2000" height="136" />
                  <!--<img src="images/Pixel_blanc.jpg" width="1" height="25" /> -->
                      <object id="FlashID" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="2000" height="950">
                        <param name="movie" value="Video/Menu.swf" />
                        <param name="wmode" value="transparent" />
                        <param name="quality" value="high" />
                        <param name="wmode" value="transparent" />
                        <param name="swfversion" value="6.0.65.0" />
                        <param name="expressinstall" value="Scripts/expressInstall.swf" />
                        <param name="embed" value="wmode=&quot;transparent&quot;" />
                        <param name="selectable" value="false" />
                        <param name="border" value="0" />
                        <param name="embed" value="wmode=&quot;transparent&quot;" />
                        <param name="allowScriptAccess" value="always" />
                        <object type="application/x-shockwave-flash" data="Video/Menu.swf" width="2000" height="950">
                          <param name="quality" value="high" />
                          <param name="wmode" value="transparent" />
                          <param name="swfversion" value="6.0.65.0" />
                          <param name="expressinstall" value="Scripts/expressInstall.swf" />
                          <param name="embed" value="wmode=&quot;transparent&quot;" />
                          <param name="scale" value="allowscale" />
                          <param name="selectable" value="false" />
                          <param name="border" value="0" />
                          <param name="embed" value="border=&quot;0&quot;" />
                          <param name="allowScriptAccess" value="always" />
                        </object>
                      </object>
                     
                      </td>


                  That's the code of the flash with the test image above it...

                   

                  What is wrong with my code here please ? i don't understand,

                   

                  As for the FLA/SWF itself, the background inside the flash is white and since you cannot remove the background in flash, i had to do it in Html here with the Embed.

                   

                  i can't find my mistake.

                  • 6. Re: Urgent - strange black flash on my website
                    hans-g. Adobe Community Professional & MVP

                    Hi,

                     

                    the code seems ok at first few (I for my part work only with an DW-insert-command), but did you load all the DW generated or changed files to your server, like "AC_RunActiveContent.js and swfobject_modified.js"?

                     

                    I for my part would like to persuade you to try just something else. Did you already use a flv-file instead of a swf-file? You could try to manage it from the begining and here "we/I" know that it will work. And it plays Please try this:

                     

                    You could insert this flash application into a solitary file. Here the procedure (translated from my German DW):


                    create a really new subdirectory
                    create a new html/php-file
                    Work in designMode --> Insert Flash-Video
                    search/browse ---> YourMenu.flv
                    skin: Halo Skin 3 (min. width 280) ( it was my choice, you don't need one)
                    width 640 ( it was my choice)
                    height 480 ( it was my choice)
                    I clicked all the boxes

                     

                    ---> And now away with all these files to your server (best you have a look with the WIN-Explorer to your directory, to see all the files DW has created in your subdirectory and don't forget anyone):

                    YourMenu.flv
                    YourMenu.php (or YourMenu.html)
                    Clear_Skin_1.swf (my choice)
                    FLVPlayer_Progressive.swf (it's generated from DW)

                     

                    Hans-G.

                    • 7. Re: Urgent - strange black flash on my website
                      hans-g. Adobe Community Professional & MVP

                      Hi,

                       

                      all is ok in my IE now!?

                       

                      Hans-G.

                      • 8. Re: Urgent - strange black flash on my website
                        jxlusa Level 2

                        I seem to recall running into a similar problem a while back.

                        If memory serves, I was able to solve it by simply moving the JavaScript up to a position BEFORE the CSS in the header.

                         

                        There is a rather weird rendering bug in the browser, related to JavaScript rather than to Flash itself.

                        Placing a javascript (any javascript) before your css (linked or embedded) solves the problem.

                        It doesn't have to be all the JS, just some JS.

                         

                        I hope this works for you and it's not something else harder to find causing it in your case.

                        • 9. Re: Urgent - strange black flash on my website
                          Chorale0001 Level 1

                          @Hans: IE was always fine, It is firefox that is the probleme. I'll try your solution

                           

                          @jxlusa : Very interesting, i'm gonna try that and will give you some news here. Thanks

                          • 10. Re: Urgent - strange black flash on my website
                            Chorale0001 Level 1

                            @jxlusa: Sorry for the delay, i tested your idea and no luck. I even tryed to modifie the flash itself to add a wide detection zone (viewscreen size !) in case you are mouseover the zone too fast for the menu to open. I setted that zone to the jump directly to the script to hide the div again. It is not working and it's even worse, now it's a LOT of black screen.

                             

                            I still can't figure it.

                             

                            @Hans: still no solution. going to try your idea today and tomorrow.

                             

                            Thanks all.

                            • 11. Re: Urgent - strange black flash on my website
                              Nancy OShea Adobe Community Professional & MVP

                              You can rule things out by running your code through the validation checker.  Often the littlest things can cause the most annoying problems.

                               

                              http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.episodesoft.com%2F

                               

                              Nancy O.
                              Alt-Web Design & Publishing
                              Web | Graphics | Print | Media  Specialists
                              http://alt-web.com/
                              http://twitter.com/altweb
                              http://alt-web.blogspot.com

                              1 person found this helpful