6 Replies Latest reply on May 26, 2010 10:47 PM by solotro

    OpenGL issues with AE CS5 - Some Help Please!

    solotro

      Hello,

      I have a  fresh win7 64-bit install with Adobe Master CS5 trial running with this specs:

       

      -Intel Core i7 Processor i7-920 2.66GHz 8 MB LGA1366 CPU BX80601920
      -Intel DX58SO Extreme Series X58 ATX Tri-Channel DDR3 16GB SLI or CrossFireX LGA1366
      -Corsair TR3X6G1600C8D Dominator 6 GB 3 x 2 GB PC3-12800 1600MHz 240-Pin DDR3 Core i7
      -Sapphire Radeon HD4850 X2 2GB DDR3 Dual DVI / TVO PCI-Express Graphics Card

      -640gb Caviar Black

       

      And with a real simple AE (720X480 px) project: 1 spot light and 2 3d Layers, all of it with the option Cast shadows enabled, everything looks fine until I move the light.. an error appears saying " Crash occurred while invoking rendering plug-in "AE_OpenGL".. sometimes appears something related to "dynamiclink.exe"

      I've already read related posts here and try everything I could, updated all drivers even BIOS with no solution...

       

      The only thing that seems to work is when renaming (or moving out) the AE_OpenGL.AEX plug-in, but makes all very very slow, the weird thing is after renaming that, the settings in AE about OpenGL looks the same, all say: Supported. By the way the OpenGL version is 2.1.9756 by ATI

       

      This are the full specs of the grpahic card: www.amd.com/us/products/desktop/graphics/ati-radeon-hd-4000/hd-4850/Pages/ati-radeon-hd-4 850-specifications.aspx

       

      Already tried wih the settings in ATI CCC panel options but still no solution...

       

      Can you please help me?

       

      Thanks in advace.

      Peace.

       

      (Sorry for my bad english)

        • 1. Re: OpenGL issues with AE CS5 - Some Help Please!
          Mylenium Most Valuable Participant
          Sapphire Radeon HD4850 X2

           

          Turn off the second GPU in the driver/ create an application specific profile for AE without the second GPU.

           

          Mylenium

          • 2. Re: OpenGL issues with AE CS5 - Some Help Please!
            solotro Level 1

            Thanks a lot Mylenium!

            Unfortunatly did not work...

            I turned off CrossfireX globally to disable 1 GPU but the error still there.. BUT

            a new one appears after the OpenGL error, replacing the one about the dynamiclink.exe, this new one says something about " english language entries not found in the registry...."

            There's something else I could try.

            Thanks again.

            Peace

            • 3. Re: OpenGL issues with AE CS5 - Some Help Please!
              MiniDoctor

              Hey Solotro!  I'm having the same issue with an ATI HD4850 and same Core i7 chip.  I've got 8GB RAM.  I had to turn off OpenGL support in AE CS5 in order to render anything.  It zips along pretty well with multi-processor support enabled but it would be MUCH nicer to have OpenGL running so that I could offload some rendering to the GPU.  Let me know if you've made any progress with your troubles!  Later!

              1 person found this helpful
              • 4. Re: OpenGL issues with AE CS5 - Some Help Please!
                solotro Level 1

                Thanks MiniDoctor! As you say it's not very nice with OpenGL turned off, especially with big-complex compositions, but is a lot better than before.

                I hope ATI come out with a later solution... or maybe an AE update/fix? Anyway, thank you again!

                Peace!

                • 6. Re: OpenGL issues with AE CS5 - Some Help Please!
                  solotro Level 1

                  Hi Todd, thank you but I had already tried all of these steps before asking for help here, but none worked fine for me, except the steps 4 and 5 wich makes all very very slow (something like MiniDoctor said). I've been playing around with all the options provided by that guide and the ATI CCC panel settings but always appears the same error:  "....while invoking AE_OpenGL.AEX" then something about "...dynamiclink.exe"... BUT if the option "Disable Catalyst AI"  is tuned on, instead of showing the dynamiclink.exe error apears this one: "After Effects error: Crash in progress. Last logged message was:<2312><ASL.ResourceUtils.GetLanguageIDFromRegistry><0>Unable to obtain the User 'Language' registry key at: Software\Adobe\After Effects\10.0\Defaulting to 'en_US'.

                  After that, the programs gives me the option to save my work and that's it... I still don't know what to do, only to apply the MiniDoctor's tip.

                  I have AE CS4 running smooth in my macbook, wich has an NVIDIA card... I guess I have  to switch to NVIDIA territory for my PC..

                  I appreciate all your help!

                  Thanks.