0 Replies Latest reply on Aug 13, 2007 3:01 PM by eholz1

    Movie clip will not "resize"

    eholz1 Level 1
      Hello Forum,

      I am baffled by something i "created". I have a swf file, that has 3 containers (aka movieclips).
      my first container (cleverly named "container") gets an attached movie clip beginning in frame 1 of the root timeline.
      I also have a clip on my stage (called "NavigationPane"). This is a movie clip as well. This is dragged to the stage at the design mode.

      My clip NavigationPane has an instance name ("navigaionpane"). This also has a border that gets sized dynamically at run time.

      My stage size is 640x525, and my resize for the navigationpane is 640x480. so far so good. If I run the swf file from flash player all works fine (or so it seems).

      My challenge is when I embed the swf file in an html page, and set the swf file to a smaller size (512x420 for the "stage"),
      the clip plays ok and at my desired size. I am using code like this to "resize" the swf object:
      /***************************************************************************************** ********
      <script type="text/javascript">
      <!--
      writeDocument('<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase=" http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" scale="exactfit" width="512" height="420" ID="Captivate1">'+
      '<param name="movie" value="Module1-4Buttons.swf">'+
      '<param name="quality" value="high">'+
      '<param name="loop" value="0">'+
      '<embed src="Module1-4Buttons.swf" width="512" height="420" loop="0" quality="high" pluginspage=" http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" menu="false"></embed>'+
      '</object>');
      //-->
      </script>
      <noscript>
      <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase=" http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="512" height="420" ID="Captivate1">
      <param name="movie" value="Module1-4Buttons.swf">
      <param name="quality" value="high">
      <param name="loop" value="0">
      <embed src="Module1-4Buttons.swf" width="512" height="420" loop="0" quality="high" pluginspage=" http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" menu="false"></embed>
      </object>
      /***************************************************************************************** *********************

      when the clip starts to play the size show as 512x420 (swf stage size is 640x525).
      I have code (actionscript) set at about 1/2 way thru clip to resize the nav pane to 640x480. when the code runs to resize the nav pane - the html sizing seems to be bypassed, and I get a piece of the stage in my 512x420 "window" in my html file.

      It seems that the resize overrides the html code. should I bite the bullet and just resize everything for my 512x420 size?

      thanks,
      eholz1