10 Replies Latest reply on Sep 27, 2010 8:33 AM by snowymike

    Cairngorm 2.2.1 and Flex 4

    snowymike

      Hi,

       

      I've seen in previous posts that Cairngorm 3 has not yet been updated for Flex 4.  I'm back on Cairngorm 2.2.1, which also has problems with Flex 4.  CairngormError.as does not build with Flex 4 (ResourceBundle.getString() is no more in Flex 4).  Attempting to use a Cairngorm 2.2.1 binary in a Flex 4 app will have a runtime error because of this API change.

       

      Is it possible to either get a) a new version of Cairngorm 2.2.1 that just adds Flex 4 support or b) a recommended process that developers should follow for updating Cairngorm 2.2.1 source or its build process to work in a Flex 4 compiled app?  I trust there are plenty of developers in my situation that are using Cairngorm 2.2.1 and that wish to update their applications for Flex 4.

       

      Thanks.

       

      -mike