3 Replies Latest reply on Sep 7, 2010 12:09 PM by Randy Edmunds

    Design View Issue Dreamweaver CS4 - Taking forever to load design view

    thebluedot

      I am having an issue where my site takes literally almost a full day to load in design view. Once it is loaded everything works seemlessly but once I close down Dreamweaver and reopen it, I have to wait another day to get to design view of my site. All files open just fine in code view.

       

      I have deleted the Dreamweaver CS4 cache folder, completely formatted my drive and reinstalled creative suite. I have also validated my code on W3c and everything checks out fine.

       

      The majority of my site is based off of a template, but even when I remove all the template references in the html files from Notepad I am still having the same issue. My site renders fine and quickly however on Explorer, Firefox, Chrome, and Safari.

       

      When loading any other site off the web into Dreamweaver I do not run into the problem so there must be something wrong with how my site is set up. Either the Template file is no good or somewhere else I am falling short. Can someone, please, please, please ( I am begging) help me figure out what is going on here.

       

      My index file is located at - http://www.thebluedot.net/index.html and the template file is located at - http://www.thebluedot.net/Templates/index.dwt

       

      I have searched high and low and even made a post on this same topic about a month ago but never came up with a resolution to my issue. I had given up on finding a solution to this problem for some time, but I really need to figure out where I am going wrong here!

       

      Additional Details -

       

      I am running - Windows Vista Ultimate on a Core 2 Processor with 12 GB of Ram & Solid State Hard Drive. Everything on my system runs super smoothly except loading my site in Dreamweaver CS4 design view.

       

      I really appreciate any help you can provide.

        • 1. Re: Design View Issue Dreamweaver CS4 - Taking forever to load design view
          Randy Edmunds Adobe Employee

          I am having an issue where my site takes literally almost a full day to load in design view. Once it is loaded everything works seemlessly but once I close down Dreamweaver and reopen it, I have to wait another day to get to design view of my site. All files open just fine in code view.

           

          I think the problem is that you have many remote images (http:// path) in your page.

           

          DW CS4 does not finish loading your page until they have all been downloaded. These files are cached, so they aren't downloaded again until you shutdown and restart DW. In DW CS4, you can turn off the downloading of external images here:

           

            View > Display External Files

           

          Starting in DW CS5, remote images are downloaded asynchronously, so your page will load first, and then the images wil be displayed as they are downloaded.

           

          Hope this helps,

           

          Randy Edmunds

          Dreamweaver Development

          Adobe Systems, Inc.

          • 2. Re: Design View Issue Dreamweaver CS4 - Taking forever to load design view
            BNChheda

            Hello Randi,

             

            I have used CS2 Adobe GoLive to create and manage a website (pro-prosperity.com).  Now, I have CS4 Dreamweaver.  I got a new site set up on Dreamweaver using the site management facility.  I then have the contents of website available locally on Dreamweaver.  I can edit files.  But the main home page, index.html, is not displaying on design view mode for editing, although it displays everything on live view mode.  I have struggled for days and am not getting any difference in attributes of index.html and another .html that is displaying fine on design view and is editable.

             

            I am really lost and am begging for any help.  Can you, for example, copy the home page from pro-prosperity.com and display on design view and edit it?  Please tell me what is in this file that is troublesome.  Thanks.

             

            BNChheda

            • 3. Re: Design View Issue Dreamweaver CS4 - Taking forever to load design view
              Randy Edmunds Adobe Employee
              I have used CS2 Adobe GoLive to create and manage a website (pro-prosperity.com).  Now, I have CS4 Dreamweaver.  I got a new site set up on Dreamweaver using the site management facility.  I then have the contents of website available locally on Dreamweaver.  I can edit files.  But the main home page, index.html, is not displaying on design view mode for editing, although it displays everything on live view mode.  I have struggled for days and am not getting any difference in attributes of index.html and another .html that is displaying fine on design view and is editable.

               

              I am really lost and am begging for any help.  Can you, for example, copy the home page from pro-prosperity.com and display on design view and edit it?  Please tell me what is in this file that is troublesome.  Thanks.

               

              The first thing you should do is to make sure that this feature is turned on (it's off by default):

               

                View > Code View Options > Highlight Invalid Html

               

              It's not perfect, but it will notify you of some problems. In Code View, there are many problems highlighted. Some of them don't make sense, but are triggered because of a problem with a parent tag.

               

              Be sure to make a backup copy of your file before doing the next step. Close your page. Go to Preferences > Code Rewriting, and turn on "Fix invalidly nested and unclosed tags", "Remove extra closing tags", and "Warn when fixing or removing tags". Click OK, then re-open your page. The messages in the dialog to tell you what was changed. This allowed me to see your page in Design View (I am using CS5).

               

              Note: I suggested that you reset your preferences to turn off those 3 settings as they can cause problems with some markup.

               

              In the long term, I suggest that you avoid nesting tables wherever possible.

               

              Hope this helps,

              Randy