10 Replies Latest reply on May 27, 2010 3:23 PM by Decisive77

    MPE layer bug(s) - GTX 480 and CS5 trial

    Decisive77

      Hi All,

       

      Due to some strange MPE-PPro behaviour, I am now having some last minute doubts about whether to jump up to a full version of the production suite - or perhaps wait for a .1 patch.

       

      Please advise if any of you can spot where the cause of these problems might lie...

       

      These are fairly easy-to-repeat MPE-related bugs in the trial version of PPro CS5, so far I have found issues both with scaling and when duplicating clips to new layers.

      Current hardware is as follows (will be looking for a new i7-920/X58 mobo combo if CS5 is purchased)

      Mobo- Asus Striker Extreme

      CPU - QX6700 C2Q@ 2.66Hz

      RAM 4G

      Win7 Pro x64

       

      So for testing purposes, I have "enabled" MPE using a GTX 480 and all seems fine for basic cuts-only or opacity fades on multiple layers. The bugs I have found seem to be related to adding more than 2 effects (even on just a few short clips...)

       

      Scenario 1:

      1) DV clip on layer 1, second DV clip on layer 2 scaled to 25% and positioned top left corner. Yellow line - playback behaviour is OK so far.

      2) With MPE enabled, if I add some fast CC to layer 2 clip then the footage plays back as though scaling is reset to 100% (although the slider still shows 25%)

      3) Switch from MPE to SW preview and the clip correctly returns to 25% scale (still with CC applied). Switch back and the scaling is again lost.

       

      Scenario 2:

      1) DVCPRO 1080 25p clip on layer 1, duplicated to layer 2 with a gaussian blur and 15% opacity (creates a basic glow effect).  Yellow line - playback behaviour is OK so far. Repeat for a second clip on to layers 3&4 with a simple opacity fade-up at start on each, overlaying the last few secs of 1&2 for the length of the fade.

      2) With MPE enabled, layers 3&4 only show when the layer 1&2 clip has reached the out point, ie the fade up on layer3&4 is "ignored" and the second clip only cuts in when the first clip has reached the out point. All the time with a Yellow line.

      3) Switch from MPE to SW preview and everything works as it should (after preview render is generated of course).

       

      So my questions are, can anyone with a GTX 285 or (certified) Quadro repeat either of these bugs? Am I better to wait until the GTX 480 is officially certified in a few months (possibly including a patch) or is there another cause elsewhere in my current hardware?

       

      MPE is really nice (in theory at least) but it worries me that it fails to calculate opacity occlusion and scaling correctly for such relatively simple sequences.

       

      Any suggestions/opinions/comments welcome!

       

      Cheers,
      Dave.

       

      Broader Pictures

        • 1. Re: MPE layer bug(s) - GTX 480 and CS5 trial
          Harm Millaard Level 7

          Dave,

           

          What driver are you using?

           

          I haven't seen these issues with the 480.

          • 2. Re: MPE layer bug(s) - GTX 480 and CS5 trial
            Decisive77 Level 1

            Hi Harm,

             

            Thanks for the quick reply, I am using latest WHQL drivers - direct from nVidia's site (197.75). I'm not currently at my machine, but let me know if any other hardware details are worth looking into.

             

            I would be very interested to hear your results (with this or any other card) if you're able to test either of the scenarios, clip/sequence length seems not to be important - just the number of effects added.

             

            Thanks again,

            Dave.

            • 3. Re: MPE layer bug(s) - GTX 480 and CS5 trial
              Harm Millaard Level 7

              Dave,

               

              That is the correct driver.

               

              I tried your scenario 1 to the letter and can not replicate it. Everything works as it should with MPE on. I did not try your scenario 2, but from testing with ridiculously complicated timelines on 4 tracks with mixes of AVCHD, XDCAM-EX, HDV and DV, both in PAL and NSTC, with lots of effects and transitions, PIP, scale, blend, blur, zoom, 3-way CC, fast CC, opacity, speed, etc. with most keyframed with bezier curves I have not seen these issues you describe.

               

              Keep in mind that the GTX-480 is not yet supported and the driver not optimized for CS5. When the next driver comes out and Fermi support coming somewhere in Q3, one may see much improved resutls, but on this strange timeline above, my non-MPE rendering time is 75 seconds and my MPE enabled rendering time is 13 seconds. That is quite an improvement and one may hope that the difference will be even bigger when Fermi support comes.

               

              Just wondering aloud if it could be the trial version? Does not seem to be logical, but who knows.

              • 4. Re: MPE layer bug(s) - GTX 480 and CS5 trial
                Decisive77 Level 1
                function(){return A.apply(null,[this].concat($A(arguments)))}

                Harm Millaard wrote:

                 

                 

                Does not seem to be logical, but who knows.

                Hi Harm,

                 

                This is exactly what worries me, I can't think that it is a trial limitation as the non-MPE previews work just fine. I will spend some more time tonight rebuilding the test sequences and see if I can find any more patterns to the behaviour.

                 

                Perhaps my "old" mobo/CPU/ram combination is crippling the GTX 480 too much, I was planning to incrementally upgrade my PC and maybe the i7-920-X58 combo is the last piece of the jigsaw that CS5/MPE requires to really fly happily.

                 

                Is there anyone with an older non-i7 machine experiencing any similar MPE "issues" ?

                 

                Thanks,

                Dave.

                • 5. Re: MPE layer bug(s) - GTX 480 and CS5 trial
                  Harm Millaard Level 7

                  Just to give you an update, the rendering of the timeline I told you about went to 4 seconds with the 5.0.1 update.

                  1 person found this helpful
                  • 6. Re: MPE layer bug(s) - GTX 480 and CS5 trial
                    Decisive77 Level 1

                    Hi Harm,

                     

                    I've created a fresh test project and recreated a timeline similar to scenaio 1 (sticking to DV to rule out demanding codec issues)...

                     

                    Here's the OK intial version of the timeline:

                     

                    LAYER4: PIP clip scaled to 25% pos. top left, no other effects just an opacity fade-in-out

                    LAYER3: PIP clip scaled to 25% pos. top right, no other effects just an opacity fade-in-out

                    LAYER2: PIP clip scaled to 25% pos. bottom right, no other effects just an opacity fade-in-out

                    LAYER1: Simple clip no scaling full screen (backdrop), fast cc effect w/ default values

                     

                    Preview bar is yellow and play back is fine with MPE on.

                     

                    THEN, if I add any other MPE-enabled effect to any layer, the preview goes red and the top-most layer disappears from the preview monitor!

                    The rendered preview also omits layer 4, as soon as I turn off MPE, the timeline returns to red and layer 4 pops right back on the monitor!

                     

                    Is this just a trial limitation of the MPE module, rather than restrict the 'extra' effect/layer to render-only you lose it altogether? This just seems a bit of a strange way to promote such an important feature, it certainly hasn't helped me decide on if/when to purchase, or perhaps it has?

                     

                    Any more thoughts?

                     

                    Thanks,
                    Dave.

                    • 7. Re: MPE layer bug(s) - GTX 480 and CS5 trial
                      Harm Millaard Level 7

                      I have a HDV project with 6 layers, 4 of which video tracks like yours organised in UL, UR, LL and LR areas, so 4 PIP's, a subtitle track and the transparent video track with timecode. Shows yellow and plays fine. Adding a MPE enabled effect to each track, like Gaussian blur, 8-point garbage matte, 3-way CC and levels does not change anything. The line remains yellow and plays correctly.

                       

                      In your case maybe opacity or the fast CC could be causing problems. Can you find when turning off these effects one by one, if there may be a problem with any of these?

                       

                      So, the 5.01 update effectively removes the 3 track limit from the Geforce line of cards, or at least for the 480. Haven't tried out if there is a new limit.

                      • 8. Re: MPE layer bug(s) - GTX 480 and CS5 trial
                        Decisive77 Level 1

                        Hi Harm,

                         

                        Thanks for taking the time to test and reply with results so quickly, proof that MPE can (& does) buy you some free time after all!

                         

                        Following more testing with the opacity, per your suggestion, I can conclude that this does indeed make a difference. Key-Framed-Opacity could fairly be classified as a built-in MPE effect. The problem only occurs on layer 4 (and I presume, all layers above), when using two (or more) MPE effects applied that layer just disappears from the preview (& output). In my test, I swap/toggled between fast CC and opacity and the layer would only disappear with both effects enabled.

                         

                        Perhaps, as a quality/expereince control, the trial is instructing the MPE to simply disregard layers that exceed the "certified" 3 effect/layer realtime limit..? Would be reassuring to get some official clarification if this is the case.

                         

                        Anyway, I'm downloading the 5.0.1 update now and will test again to see if this 4th-layer problem is fixed (or at least elevated a few layers!).

                         

                        Cheers,

                        Dave.

                        • 9. Re: MPE layer bug(s) - GTX 480 and CS5 trial
                          Harm Millaard Level 7

                          I just added two more tracks with scaling, so am now up to 6 video tracks of HDV, plus a title track and a transparent track and still yellow and no problems with playback or fast scrolling through the timeline. Will test tomorrow with keyframed opacity settings.

                           

                          I'm beginning to believe that the purchase decision for the 480 was not so bad. Curious to see what happens with improved drivers and formal certification.

                          • 10. Re: MPE layer bug(s) - GTX 480 and CS5 trial
                            Decisive77 Level 1

                            Good News! (so far anyway)

                             

                            The 5.0.1 update seems to have fixed the weird issues described in my OP (seemingly related to the 3 layer realtime limit), further thanks to Harm for testing and reporting the improved performance made possible by this update so swiftly.

                            Adobe have got a good thing here, both in Harm's commitment to "showing the way" for the rest of us and with the MPE.

                             

                            Of course, still looking at a mobo upgrade to get the best out of it but I think this is the release I will jump to from my ageing suite.

                             

                            I'll be doing a few more tests in the next day or two (still have a few days of trial left) and will report any persistent oddities.

                             

                            Thanks & Regards,

                            Dave.