14 Replies Latest reply on Jun 5, 2010 4:25 AM by AdelaideBen

    imported file split 20-30 times / need to multi-select de-flicker

    AdelaideBen

      Hi all - first time poster and all-round noob.

      First my set up - I'm running Win7 Home Premium (64 bit), with PRE8 on a custom build i5/750 + ATI5850 + 4GBram. I'm using an old (3+yo) Sony DVD digicam DC-706 if I remember correctly. My problem is twofold - but I'll start with the most immediate one. When I get media off the dvd's, they appear in as 2/3 VOB files (nothing unusual with that). However, when I drag them from the media window onto the Sceneline, these VOB files are automatically split. In some cases the one file can suddenly be split 20-30times. Now this is annoying, and I was wondering if (a) I can stop the splitting, and (b) whether I can merge these clips. I can't locate anything online to help.

       

      Now the second part of the problem... when I do videos, I always have to select de-flicker on the video options. If I don't there's an awful jitter to the finished product. I thought that this was field reversal problem but switching field dominannce doesn't seem to stop it. When I use de-flicker, it goes away. This has been the same in Premiere Elements 5. Not sure if it's the cam or what... or is it my TV? Anyhow - it's annoying having to go into the clip>video>field options>flicker removal each time... especially when the software automatically splits into 20-30 clips.

       

      Is there any way to set the flicker removal on a global level rather than on a clip by clip basis. Also does anyone have a better solution as to why changing the field order do anything, but why flicker removal does. [note - the jitter isn't just on horizontal lines - but looks exactly like an interlacing problem which most probably just gets smoothed out with flicker removal]

       

      Thanks in advance.

        • 1. Re: imported file split 20-30 times / need to multi-select de-flicker
          Steve Grisetti Adobe Community Professional

          If you use the DVD/Hard Drive preset for your project, your field dominance will automatically be reversed for you, eliminating the need for you to add flicker removal.

           

          You'll find more information on using project presets in part 1 of my 8-part Basic Training with Premiere Elements tutorials on Muvipix.com.

          1 person found this helpful
          • 2. Re: imported file split 20-30 times / need to multi-select de-flicker
            the_wine_snob Level 9

            Also, the "splitting" is very likely coming from having Auto Analyze turned on. This can cause some issues as it tries to do "scene detection." You should be able to turn it OFF. This is covered in this FAQ Entry.

             

            Good luck,

             

            Hunt

            • 3. Re: imported file split 20-30 times / need to multi-select de-flicker
              AdelaideBen Level 1

              Bill,

              Tried to turn off the auto analyzer i the Organizer (as suggested in the provided link) - however, when I then try to re-add the file, it still does the auto splitting. This could potentially be because the auto-splitting is occurring when I copy the dvd file over initially. In which case the breaks could be in there already - even before I add them to a project. This sounds a little unlikely to me (a lot of processing before you even do any work).

               

              So - short answer is that my video files are still being butchered to the point that for doing our movies - say 1.5 hours worth - there could be about 150-200 clips auto generated rather than the 4-5 I'd normally be working with. Very frustrating.

               

              Edit - here's another question. Is there anyway to stitch these clips back together?

              • 4. Re: imported file split 20-30 times / need to multi-select de-flicker
                AdelaideBen Level 1

                Steve,

                Tried changing the project presets... however, it doesn't seem to allow me to change the field dominance.

                 

                Not sure if there's something wrong with the way I'm going about it... but the only thing (under the general tab) that I can change re: video is going from 25fps Timecode to Frames. This doesn't allow me to change the field (i.e. currently set to lower field first).

                 

                The reason I use the anti-flicker field option is because changing the field dominance didn't appear to make any difference.... this is something that's been annoying me for sometime now.

                 

                Still thanks for suggestion.

                 

                Ben

                • 5. Re: imported file split 20-30 times / need to multi-select de-flicker
                  Steve Grisetti Adobe Community Professional

                  Again, if you use the DVD/Hard Drive Camcorder project preset you do not have to reverse the field dominance or do any flicker removal. The program will do this automatically for you.

                  • 6. Re: imported file split 20-30 times / need to multi-select de-flicker
                    AdelaideBen Level 1

                    Steve,

                    I understand that when you first setup the project, you can change  the setting to swap the frames. My follow-up post was to indicate that I couldn't seem to change this with an existing project.

                     

                    Also - my problem does not appear to be related to frame dominance, as I get the same extreme jitter regardless of whether it's upper or lower frame first (from what I can see). I will keep playing around to see if I can't resolve it... but at the moment flicker removal was the only thing that worked for me.

                     

                    I don't suppose you know how to join two clips together - out of curiosity?.... (thnx in advance).

                     

                    Cheers

                    Ben

                    • 7. Re: imported file split 20-30 times / need to multi-select de-flicker
                      AdelaideBen Level 1

                      Here's a follow up question. I've turned off the auto analyzer - and that appears to have solved the splitting problem. My next question is... is there anyway to remove the auto-analyzer products from the files after the event. I tried following the online help (in the organizer, right click and then press remove smart tags... when I do this it comes up with an error message. Also - there are about 10+ tags associated with the video files... and you seem only to be able to delete one at a time anyhow.

                       

                      Cheers

                      Ben

                      • 8. Re: imported file split 20-30 times / need to multi-select de-flicker
                        the_wine_snob Level 9

                        I do not use PrE 8, hence no Auto-Analyzer. Steve, or Neale, or others will have to address how you change things about with it. I only was able to spot the cause. Sorry.

                         

                        Good luck,

                         

                        Hunt

                        • 9. Re: imported file split 20-30 times / need to multi-select de-flicker
                          the_wine_snob Level 9

                          Ben,

                           

                          Some have been successful by hacking the PREL (the Project) file, to make changes to an existing Project. Otherwise, there is no way to do so, mid-stream. If you do hack the PREL, I would make sure that you both know what needs to be changed there, and that you ONLY work from a Copy of the PREL, in case something goes terribly wrong.

                           

                          Were I going to do this, I would do an empty Project with bot the settings as your original, and then one with the desired settings. I'd compare these two PREL files very closely, to see where they differ and then make those changes, X my fingers and test. Again - ONLY with a Copy and NOT the original.

                           

                          Hunt

                          • 10. Re: imported file split 20-30 times / need to multi-select de-flicker
                            the_wine_snob Level 9

                            Ben,

                             

                            I tried following the online help (in the organizer, right click and then press remove smart tags... when I do this it comes up with an error message.

                             

                            What is the error message? That might yield a clue.

                             

                            Good luck,

                             

                            Hunt

                            • 11. Re: imported file split 20-30 times / need to multi-select de-flicker
                              AdelaideBen Level 1

                              As it turned out - having the Auto Analyzer was exactly my problem re: automatic splitting. In the end, the hassle of re-stitching the clips back together was well and truly greater than the hassle of re-loading the originals. I scrubbed the videos (about 5 hours worth) and started again. I've also set the upper field dominance as Steve suggested - will try it on one dvd and see if that solves my jitter problem (had done this before, but just using the field options).

                               

                              Cheers all - will keep you all posted.

                              • 12. Re: imported file split 20-30 times / need to multi-select de-flicker
                                the_wine_snob Level 9

                                Glad that you tracked it down to Auto-Analyzer. That "feature" seems to come with a lot of "baggage" for some users.

                                 

                                Good luck, and thank you for posting the cause and your workflow to deal with it. That is very likely to help other users in the future, and they will thank you for it.

                                 

                                Hunt

                                • 13. Re: imported file split 20-30 times / need to multi-select de-flicker
                                  AdelaideBen Level 1

                                  Steve - I followed your advice about setting up the project presets for displaying the upper field. After completing my project (where I didn't select either remove flicker or reverse field dominance), I just burnt the DVD and the strong jitter remains. I thought I would just report back after trying the suggestion.

                                   

                                  To reiterate: I opened a new project, changing the preset to read D1/DV PAL Widescreen (which was the appropriate format) from the DVD/Hard-drive/Camcorder selection - and this selects the upper field first automatically. I then "get media" from the DVD directly (remembering that I've been recording using a DVD camcorder). As indicated I did not apply any filters or field options at this point - and the result is the same extremely jarring jitter that was there previously. I hope that this was following instructions.... but unfortunately, this is exactly what I had before where the only thing to remove the extreme jitter was to apply something like flicker removal.

                                   

                                  Also - as it turned out, I had more extreme problems with burning the dvd as it got to the fabled 96% mark and reported that there was a device error - target device not suitable. This was only resolved (after 3 attempts) when I removed the stop marker from the template. I had read about this before as a possible solution, but have yet to hear why that is. Any thoughts (I'll follow this up in another discussion as well).

                                   

                                  Cheers in advance

                                  Ben

                                  • 14. Re: imported file split 20-30 times / need to multi-select de-flicker
                                    AdelaideBen Level 1

                                    I've spent a little bit of time trying to understand this... and the following examples might be helpful to explain what's going on (apparently). This experimentation was done by (a) getting a vob file from dvd camcorder, (b) setting up a project with either lower (default, case A and B) or upper field first (case C and D). I then change the combination of parameters between reversing the field or not, and turning on interlacing of consecutive frames or not. The final parameter is whether or not to set a lower field first on the output (case A and C) or upper field first (B and D). Here I've written an X for where there was the jitter evident and OK where there was no jitter evident.

                                     

                                    TEST RESULTS

                                     

                                    (A) PROJECT PRESET - LOWER FIELD FIRST / OUTPUT AVI - LOWER FIELD FIRST

                                     

                                                                   REVERSE FIELD

                                                                   ON               OFF        

                                    Interlace   ON          OK                X

                                                  OFF           X                  OK

                                     

                                     

                                     

                                     

                                    (B) PROJECT PRESET - LOWER FIELD FIRST / OUTPUT AVI - UPPER FIELD FIRST

                                     

                                                                   REVERSE FIELD

                                                                   ON               OFF

                                    Interlace   ON          OK               X

                                                  OFF                          OK

                                     

                                     

                                    (C) PROJECT PRESET - UPPER FIELD FIRST / OUTPUT AVI - LOWER FIELD FIRST

                                     

                                     

                                                                   REVERSE FIELD

                                                                   ON               OFF

                                    Interlace   ON          OK               X

                                                   OFF          OK               X

                                     

                                     

                                     

                                    (D) PROJECT PRESET - UPPER FIELD FIRST / OUTPUT AVI - UPPER FIELD FIRST

                                     

                                     

                                                                  REVERSE FIELD

                                                                   ON               OFF

                                    Interlace   ON          OK               X

                                                   OFF          OK               X

                                     

                                    The end results is that the solution to getting a no-jitter output is not trivial. It appears to not only depend on the input field dominance, but also on the output field dominance and both the reverse field dominance+interlace consecutive frames.

                                     

                                    So from this very cursory examination - it would appear that if you had lower field first on both the import and export that there should be no need to do anything. Going for an upper field first however would still require you to reverse the field irrespective of whether you had an upper field first on output.

                                     

                                    I hope this helps a bit in understanding some of the issues... but please be aware that this is just for AVI files created on my hdd. I will need to test it out on the real thing (i.e. burnt to dvd)... stay tuned.