2 Replies Latest reply on Jun 2, 2010 1:23 AM by tessimon

    problem with a flash banner in a php includes

    tessimon

      I am creating a site that has many pages and I made an includes file for the header of the page that contains my navigation bar, i then made a template of the page to use for all my pages.

       

      Now I have created a flash banner that i want to play in the header of all my pages but i´m having problems getting it to show on all the pages.

      Firstly I added the flash swf into my includes file and inserted the flash into the includes file page using insert flash from the dreamweaver menu (code below):

       

      <?php $currentPage=basename ($_SERVER['SCRIPT_NAME']);?>
      <script src="../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>

       

      <div id ="adBanner">
        <script type="text/javascript">
      AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','wid th','468','height','60','title','advertise','src','advertise_banner','quality','high','plu ginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveF lash','movie','advertise_banner' ); //end AC code
      </script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="468" height="60" title="advertise">
          <param name="movie" value="advertise_banner.swf" />
          <param name="quality" value="high" />
          <embed src="advertise_banner.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="468" height="60"></embed>
        </object></noscript>
      </div>
      <div id ="NavBar">
          <p> </p>
          <p> </p>
          <p> </p>
          <p> </p>
          <p> </p>
          <p> </p>
          <p><a href="index.php" <?php if ($currentPage == 'index.php') {echo 'id="here"';}?>>Home</a></p>
          <p><a href="about.php" <?php if ($currentPage == 'about.php') {echo 'id="here"';}?>>About Us</a></p>
        <p><a href="contact.php" <?php if ($currentPage == 'contact.php') {echo 'id="here"';}?>>Contact Us</a></p>
        <p><a href="advertise.php?ad=y" <?php if ($currentPage == 'advertise.php') {echo 'id="here"';}?>>Advertise</a></p>
        <p> </p>
          </div>

       

      Great the flash ad works when I load the includes page in a browser and when i look at all my other pages that have the link to the includes file the flash file shows as a grey box with F in the center, however if i load any of these pages into a browser the flash ad does not show.

       

      I also tried doing exactly the same, adding the flash to the header of my template and saving it. However this did not update all of the pages that use the template, the flash ad would play in the browser if I load the template in the browser. (in this instance the actual swf file was in my templates folder with the template page).

       

      The final thing i tried was just to add the flash to one of my pages just to see if it would work when i loaded the page into a browers, it didn´t and i don´t understand why as it worked on the includes page and template page. (the swf file in this case was in the file along with all the pages of my site).

       

      It doesn´t seem that i have a problem with the actual flash banner, i just cannot seem to put it in the pages that i want to.

       

      Any help or input in this matter will be greatly appreciated.

      Thank you in advance.