9 Replies Latest reply on Jul 11, 2014 6:04 AM by kwood_mn

    Activities missing in Workbench- Why?

    $Nith$ Level 4

      Few of the activities missing in the floating panel. What might be the reason?

       

      I have Super Administrator & Applications administrator permission.

       

      If I login using others login from the same machine it works. But only for my login few of them are missing.

       

      activities missing.PNG

       

      Any suggestions?

       

      Nith

        • 1. Re: Activities missing in Workbench- Why?
          Jasmin Charbonneau Level 4

          What roles do the other users have?

           

          Jasmin

          • 2. Re: Activities missing in Workbench- Why?
            $Nith$ Level 4

            Other developers have Application Administrator Role.

             

            The only difference is I'm having Super Admin role which the other users don't have.

             

            Thanks,

            Nith

            • 3. Re: Activities missing in Workbench- Why?
              Diana Densmore Level 3

              Hi Nith

              I have seen issues with icons on the toolbar in the past. Typcially it was because a Component was not started or installed correctly.

              Usually, I would get an initialization error when I first logged into Workbench.

              I don't recall seeing any issues based on the role. Just the Application Administrator role gave me all the toolbar icons.

               

              Are you seeing anything in the server log?

               

              Based on the missing icons on your toolbar, the Components to check are:

              The Assign Task and Assign Multiple Task (which are missing) appear courtesy of the Task Manager DSC.

              The Set Value and Decision Point (which are missing) appear courtesy of the Workflow DSC.

              The Email with Document icon (missing) appears courtesy of the Component called Email (The second one with an active service callled EmailService).

              The Invoke Web Service icon (missing) appears courtesy of the Component called WebService.

               

               

              Diana

              • 4. Re: Activities missing in Workbench- Why?
                $Nith$ Level 4

                Hi Diana,

                 

                The server instance is Production. All the components are running properly. I tired unassign reassign roles, but no luck.

                 

                I will try to reinstall Workbench ES2 and see what happens..

                 

                Thanks,

                Nith

                • 5. Re: Activities missing in Workbench- Why?
                  Adam_Chojnacki Level 1

                  Hello,

                   

                  I'm having the same problem with my workbench.

                  Why did you solve this problem?

                   

                  Is it server issue or local workbench instalation problem?

                  Reinstallation of workbench helped?

                   

                  P.S

                  In workbench log I found these error messages:

                   

                  !MESSAGE failed to get service registry
                  !STACK 0
                  java.lang.NullPointerException
                      at com.adobe.common.utils.internal.ServiceRegistryCache.findConfigs(ServiceRegistryCache.jav a:1196)
                      at com.adobe.common.utils.internal.ServiceRegistryCache.getHeadActiveConfiguration(ServiceRe gistryCache.java:615)
                      at com.adobe.workflow.eclipse.utils.registry.ServiceUtils.isWorkflow(ServiceUtils.java:132)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.addSteps (TemplateDocumentManager.java:869)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.addSwiml anes(TemplateDocumentManager.java:779)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.addPools (TemplateDocumentManager.java:754)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.init(Tem plateDocumentManager.java:687)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.<init>(T emplateDocumentManager.java:133)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.FlexProcessDesigner.setInput(Fle xProcessDesigner.java:577)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.FlexProcessDesigner.refreshInput (FlexProcessDesigner.java:938)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.FlexProcessDesigner.handleEvent( FlexProcessDesigner.java:1710)
                      at com.adobe.ape.api.APEView.notifyListeners(Unknown Source)
                      at com.adobe.ape.api.APEView.layout(Unknown Source)
                      at com.adobe.ape.api.APEViewManager$1.run(Unknown Source)
                      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
                      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:133)
                      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3800)
                      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3425)
                      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2384)
                      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2348)
                      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2200)
                      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:495)
                      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
                      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:490)
                      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
                      at com.adobe.lcide.rcp.Application.start(Unknown Source)
                      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
                      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)
                      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)
                      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
                      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
                      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                      at java.lang.reflect.Method.invoke(Method.java:597)
                      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
                      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
                      at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
                      at org.eclipse.equinox.launcher.Main.main(Main.java:1212)

                   

                  !ENTRY com.adobe.workflow.editor 4 4 2011-04-04 11:02:17.819
                  !MESSAGE failed to load image
                  !STACK 0
                  java.lang.NullPointerException
                      at com.adobe.common.utils.internal.ServiceRegistryCache.findConfigs(ServiceRegistryCache.jav a:1196)
                      at com.adobe.common.utils.internal.ServiceRegistryCache.getHeadActiveConfiguration(ServiceRe gistryCache.java:615)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.FlexProcessDesignerPlayerCallbac k.loadImageFromRepository(FlexProcessDesignerPlayerCallback.java:307)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.loadImag e(TemplateDocumentManager.java:2352)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.addSteps (TemplateDocumentManager.java:873)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.addSwiml anes(TemplateDocumentManager.java:779)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.addPools (TemplateDocumentManager.java:754)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.init(Tem plateDocumentManager.java:687)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.TemplateDocumentManager.<init>(T emplateDocumentManager.java:133)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.FlexProcessDesigner.setInput(Fle xProcessDesigner.java:577)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.FlexProcessDesigner.refreshInput (FlexProcessDesigner.java:938)
                      at com.adobe.workbench.editors.workbenchflexprocessdesigner.FlexProcessDesigner.handleEvent( FlexProcessDesigner.java:1710)
                      at com.adobe.ape.api.APEView.notifyListeners(Unknown Source)
                      at com.adobe.ape.api.APEView.layout(Unknown Source)
                      at com.adobe.ape.api.APEViewManager$1.run(Unknown Source)
                      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
                      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:133)
                      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3800)
                      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3425)
                      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2384)
                      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2348)
                      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2200)
                      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:495)
                      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
                      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:490)
                      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
                      at com.adobe.lcide.rcp.Application.start(Unknown Source)
                      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
                      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)
                      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)
                      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
                      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
                      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                      at java.lang.reflect.Method.invoke(Method.java:597)
                      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
                      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
                      at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
                      at org.eclipse.equinox.launcher.Main.main(Main.java:1212)

                  • 6. Re: Activities missing in Workbench- Why?
                    BapediBoupi

                    Hi everybody,

                     

                    I have the same issue, some activities are missing only for my login.

                     

                    I have 3 roles :

                    - LiveCycle Workspace user

                    - Workspace administrator

                    - Service user

                     

                    Since the activities are not missing for other users, I think that the problem is on the local workbench installation ? Maybe the cache ?

                     

                    Did you managed to solve your issues ? How ?

                     

                    Regards,

                     

                    Thomas

                    • 7. Re: Activities missing in Workbench- Why?
                      hussam ihmaidi Level 1

                      Hi Nith,

                       

                      We faced this issue before the problem was with the user. What we did, we created another user and gave him the same old roles, It worked!!

                       

                      Why? we did not know.

                       

                      Hussam

                      • 8. Re: Activities missing in Workbench- Why?
                        BapediBoupi Level 1

                        Hi hussam,

                         

                        The problem is that my user comes from an Active Directory using LDAP authentication ...

                         

                        I can't really delete or create an user (i don't want to use local users).

                         

                        EDIT : Today, the activities came back without problem. It tooks a new LDAP Sync to fix the problem...

                         

                        Message was edited by: BapediBoupi

                        • 9. Re: Activities missing in Workbench- Why?
                          kwood_mn

                          I am going to necro this very old post because I experienced this today with LiveCycle Workbench ES3. I found the same buttons missing in my toolbar. I also found that someone who logged in to the same server (with their own windows account) and logged into LiveCycle Workbench with the same user (administrator in this case) could see the buttons. Thus the problem was tied to the windows user instead of the LiveCycle user. I fixed the problem by deleting the .metadata folder found in c:\Users\<problem user>\Workbench 10.

                           

                          This folder also houses important information regarding the local copies of your various applications so I would make sure you are in a good place to delete all local copies and re-download them from the server before deleting the .metadata folder.

                           

                          I have found that various Workbench issues that I have come across can be fixed by deleting the .metadata folder.