9 Replies Latest reply on Jul 19, 2010 3:05 AM by Wade_Zimmerman

    Rendering glitch in Save For Web?

    AFDTypecastFilms Level 1

      Hello,

       

      When I "save for web" with some particular files, I get a rendering glitch in the image that takes the form of small, colorless horizontal lines.

       

      Example 1

       

      Example 2

       

      Where do these come from? What can I do about it?

        • 1. Re: Rendering glitch in Save For Web?
          Wade_Zimmerman Level 6

          I do not know what version you have and I cannot reproduce it,itmightbe the vido card, whichcouldbe going bellyupor I see that the topobject orobjects above the objects or image looks like they have Opacity masks applied to them.

           

          What version ofAI.

           

          The only thing I think would cause this is if there hand been some kind of transparency flattening the objects image in question other than a corrupt card.

          • 2. Re: Rendering glitch in Save For Web?
            AFDTypecastFilms Level 1

            This is using CS5. These rendering glitches have only began to show up since I upgraded from CS4.

            • 3. Re: Rendering glitch in Save For Web?
              [scott] Level 6

              Bad RAM?

               

              I've never seen the  issue here. Generally unwanted horizontal lines are due to RAM or some disk corruption somewhere. Just throwing that out there.

              • 4. Re: Rendering glitch in Save For Web?
                davidmacy Adobe Employee

                Any difference if you use Export instead of Save for Web?

                • 5. Re: Rendering glitch in Save For Web?
                  Neeraj N-LscgRS Level 2

                  In the examples that you've posted, the formats are PNG and JPG so the issue does not seem to be that of a particular format. Could you please try using a different anti-aliasing (Type Optimized) and see if the problem still persists.

                   

                  Anti-aliasing options are available in the bottom left of the tab 'Image Size'.

                  • 6. Re: Rendering glitch in Save For Web?
                    mtt1853 Level 1

                    I can confirm, I am getting the same lines in my export.  I read elsewhere that it might be showing up in files with gradient meshes.    This is definitely a glitch, and it definitely needs a fix.

                     

                    Mike

                    1 person found this helpful
                    • 7. Re: Rendering glitch in Save For Web?
                      Wade_Zimmerman Level 6

                      mtt1853 wrote:

                       

                      I can confirm, I am getting the same lines in my export.  I read elsewhere that it might be showing up in files with gradient meshes.    This is definitely a glitch, and it definitely needs a fix.

                       

                      Mike

                      Export there is this bug but save for the web there is not this bug.

                       

                      So it has been confirmed by just about everyone for export to jpeg with gradient mesh. What you can is to raster the gradient mesh(s) before you export and that will solve your issue.  A bit of a pain but it works fine.

                       

                      I do suspect that this issue will be resolved hopefully with a dot release though you can never tell.

                      1 person found this helpful
                      • 8. Re: Rendering glitch in Save For Web?
                        jthreecon Level 1

                        I have this exact issue.

                        Happens in "Save for web" and in  "export". I managed to keep CS4 still installed and took the exact same  file and "exported" it and "saved for web", and no issue at all in CS4.  This is def. an issue that has popped back up in CS5 then.

                        On my  attached image there is no gradients or special effects, just clipping  masks.

                        I've tried the new options they have in save for web, "Art  Optimized" and "Type Optimized". The issue does not happen in "Type  Optimized" but the quality in type optimized is lower and it renders the  exact same as the vector file appears(so colors bleeding out a pixel  behind some objects etc.) The issue does happen in "art optimized".

                        Issues  happens when saving in png and jpg format, with or without  transparency.

                         

                        I've  attached an example, notice the lines in her face. (same as initial  attached image)

                         

                        So is this a "wait for an update" sort of scenario? or is  this a "use a different program to save for web" scenario?

                        cs5.problem.png

                        • 9. Re: Rendering glitch in Save For Web?
                          Wade_Zimmerman Level 6

                          Well the work around works if you simply raster the objects with gradient mesh before using Save for Device and Web.

                           

                          Then it will work fine.

                           

                          Although at the moment I do not seem to see this happening on the Mac?