3 Replies Latest reply on Jan 17, 2012 8:08 PM by Zeeshan Aqeel

    Dreamweaver CS5 Subversion Problems




      I recently upgraded to Dreamweaver CS5 from CS4 on my Windows XP machine. In CS4, I was using Subversion v 1.4.3 and it was working fine. However, I am having some problems in CS5.


      All of my sites from CS4 carried over during the upgrade and when I tested the web sites and the subversion in the site manager, I get the "Server and project are accessible!" alert, so I know I'm pointing to the right location.


      In CS4, I would sometimes encounter a situation where in my local view, the files would have a plus sign next to them, indicating that the file was new and would be added to the repositiory when checked in, even though there was already a copy in the repository. If I tried to check one of these files in, it would give an error because the file already existed in the repository. The only way to solve this problem was to delete the file from my local view, go to the repository view, right-click the file and select "Get Latest Versions". When I would go back to the local view, the plus sign would then be gone and I could check the file in and out.


      In CS5, when I go to repository view and right click a file, there is no option to Get Latest Versions. The only options in repository view are "Update Status" and "Show Revisions"


      If I try to Get Latest Versions from my local view, I get the error: "SVN: #155000, Failed to add directory 'C:\Documents and Settings\***\***': an unversioned directory of the same name already exists"


      If I try to use CS4's Subversion, I get an error saying a new, incompatible version of Subversion exists on this machine.


      I'm a bit stuck here and I was wondering if anyone had encountered a similar problem. Any help would be much appreciated. Thanks!

        • 1. Re: Dreamweaver CS5 Subversion Problems
          wfntest Level 1

          I also tried creating a new site in Dreamweaver and getting the whole site locally again to a different location on my hard drive and it didn't work.

          • 2. Re: Dreamweaver CS5 Subversion Problems
            AllDayDev Adobe Employee

            [I'm replying to this older thread because another user contacted me separately with what appears to be the same issue.]


            Per the Subversion FAQ, the "same name already exists" error may be caused by having a case mismatch between the repository and your local file system:



            Subversion is case-sensitive, but the file systems on Windows are not, so this case mismatch can happen in a number of scenarios.

            If for, example, one of the directories in the path to a file changed (e.g. "documents and settings" versus "Documents and Settings"), or one of the files changes (e.g. "img0102.jpg" versus "IMG0102.jpg"), then you could run into this issue. A less common but possible scenario is if the case on the file name extension changes (e.g. "IMG0102.jpg" versus "IMG0102.JPG").


            So, check the paths in the repository, and compare to what you have in the local view. (Maybe even move all of the files/folders from the local copy to somewhere else, or delete them if you know you have current copies of all files elsewhere.) If it's not a directory, then check the case on the file names.



            Hope that helps!

            • 3. Re: Dreamweaver CS5 Subversion Problems
              Zeeshan Aqeel

              Hi Carey,


              Zeeshan again, from the private message. Let me tell you my exact scenario.


              I just installed Adobe CS 5.5 trial, and installed wamp on my D drive, now keeping this in mind, the www directory is completely empty and I am using dreamweaver SVN to get the latest version from the repository that has the code and this is where I get this error:


              SVN: #0, Path '' is not canonicalized; there is a problem with the client.


              and sometimes


              SVN: #155000, Failed to add directory 'D:\wamp\www':



              Now the thing is the folder is clean, why will I get this error?


              Please advise.