4 Replies Latest reply on Jun 22, 2010 3:02 PM by Codefinger

    Connection via Contribute faulty?

    Codefinger Level 1

      Hi,

       

      Have just been trawling the 'net, looking for answers to this question: "http://forums.adobe.com/message/251294#251294" because I'm having the same prob just now, but with the CS5 Suite.

       

      So, I have the correct connection details and auth (even contacted my Host wrt this problem), but Dreamweaver, and 3 other Dav Clients can connect and communicate seamlessly.

       

      What's the deal with Contribute? Do I need Contribute-like files to sit on my Dav directory, waiting to be talked to? Or something else? Does the functionality work?

       

       

      -d

        • 1. Re: Connection via Contribute faulty?
          Krishna Prasad B V Level 3

          This might be a permissions issue. Can you check the permissions the webdav user has on the server, for the folder containing the website? If he does not have modify/write permissions for it, assign these permissions to him. Then, can you connect within Contribute to the website and verify whether Contribute connects to your website properly.

           

          Hope this helps.

          • 2. Re: Connection via Contribute faulty?
            Codefinger Level 1

            Well, it may or may not be a permissions issue - but perhaps it may have been at one time and then changed.

             

            At the time of this original post I had not created a site in Dreamweaver.

             

            After failing to connect Contribute to my webdav server, which did have the right permissions, I decided to try connecting to my web server via webdav - in Dreamweaver CS5. I successfully connected via Dreamweaver, which surprised me after my failure via Contribute.

             

            I then decided to re-check Contribute, as everything was still open, and bingo - connected. I'm now successfully writing, reading and versioning will be hooked up soon. Dreamweaver already checking in/out nicely.

             

            I've not tried opening a new connection in Contribute, which points to a different webdav directory, to see if I still have those initial connectivity issues. Let me know if you want me to give it a bash for curiosity's sake.

             

            -d

            • 3. Re: Connection via Contribute faulty?
              Krishna Prasad B V Level 3

              Yes, can you try opening a new connection in Contribute which points to a different webdav directory, and tell me whether it works fine.

              • 4. Re: Connection via Contribute faulty?
                Codefinger Level 1

                Any chance you can give me some quick guidance on settings up directives for Apache, to enable WebDAV methods? I have a local WAMP server running, my WebDAV modules active, and a local directory set aside for DAV.

                 

                The other option for me to test this is to contact my host and have them manually set up a another WebDAV directory, but that's time consuming for both them and myself :/