9 Replies Latest reply on Jun 29, 2010 11:06 AM by redtopia

    Slow editor after update

    redtopia Level 1

      Is it my imagination, or has there been a performance hit after update 1? After heavy use, I've had to restart eclipse in order to speed things up, which seems to help for a short time, but eventually the editor slows down again, particularly on large CFC files with a mix of CF and HTML code. Sometimes I have to wait a couple seconds after each editor change before I can do anything, which is problematic when you're trying to move quickly. That's when I just restart and say F###! Everytime this happens, the little tractor track progress icon moves. Not sure what it's doing since it goes away too quick for me to click on it. Could it have something to do with syntax highlighting? I notice that the screen flickers a lot after each editor change, which is also annoying.

       

      I can't wait until CFB becomes a stable and fast because it's DEFINITELY NOT!

        • 1. Re: Slow editor after update
          nikos101 Level 2

          I can't even get the update

          • 2. Re: Slow editor after update
            redtopia Level 1

            I have a file that cripples the editor. It's 1300 lines long. As soon as I open the file, the editor becomes very slow. My mouse doesn't move smoothly and any edits I make take a few seconds to complete.

             

            I'm running Windows 7 x64, CFB update 1.

            • 3. Re: Slow editor after update
              redtopia Level 1

              I have another 497 line CFC file that cripples my editor. It's also got a mix of cfml and html. It's not that complicated though, and it's not a massive file. The editor cannot keep up with my edits.

              • 4. Re: Slow editor after update
                Abram Adams

                Just to throw in my stats, I can edit 900+ line cfm/cfc files without any lag.  Maybe something going on with a plugin or on your system?  Any background services eating up CPU or HDD I/O?

                • 5. Re: Slow editor after update
                  Abram Adams Level 1

                  Update: found a ~1500 line cfc that CFB has no troubles with.  Everything (insight, syntax highlighting, typing, etc...) seems to be quick.

                   

                  FWIW, I'm running CFB update1 inside FB4 Premium on Win7 Pro with intel i7 cpu + 8GB RAM.

                  • 6. Re: Slow editor after update
                    redtopia Level 1

                    Well, there's definitely something going on with memory/cpu consumption. When I start eclipse, things work fine for a while. After I do lots of work, eclipse bogs down and becomes very, very slow. Every edit takes seconds. When I look at the task manager, eclipse is using 350,000 K of memory and the CPU usage spikes anytime I do anything in eclipse.

                     

                    I'm running Windows 7 Ultimate 64 bit on an Intel Code 2 Duo, 2.4 GHz with 4 GB of RAM.

                    • 7. Re: Slow editor after update
                      Dipanwita S Level 1

                      Hi,

                       

                      When you say 'slow editor after update', do you mean you did not see this issue before applying updater (while working on the same file)?

                       

                      This sounds more like a one-off issue. We need more information like logs and stacktraces to investigate this. Next time you see this occuring, please go to http://www.adaptj.com/main/download, say 'Launch Stacktrace'. Then provide the process id for CFB, take the thread dump and mail it to us.

                       

                      Also, is it possible for you to mail me the file, I wanted to check couple of things along with CPU/Memory consumption.

                       

                      Thanks,

                      Dipanwita

                      Adobe ColdFusion Builder Team

                      • 8. Re: Slow editor after update
                        redtopia Level 1

                        Sorry, I don't know the extent of this issue before the update. But it does seem like it got worse after the update. I'll send you my stacktrace when it happens again.

                        • 9. Re: Slow editor after update
                          redtopia Level 1

                          I think I've resolved my performance issues by increasing the memory size of eclipse... I modified the eclipse.ini file from:

                           

                          -startup
                          plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
                          --launcher.library
                          plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
                          -showsplash
                          org.eclipse.platform
                          --launcher.XXMaxPermSize
                          256m
                          -vmargs
                          -Xms40m
                          -Xmx256m

                           

                          to:

                           

                          -startup
                          plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
                          --launcher.library
                          plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
                          -showsplash
                          org.eclipse.platform
                          --launcher.XXMaxPermSize
                          256m
                          -vmargs
                          -Xms128m
                          -Xmx512m

                           

                          (changed: -Xms40m to -Xms128m and -Xmx256m to -Xmx512m)

                           

                          So far the performance has been acceptable. I've been using these settings for about a week or so, and so far I haven't had any serious performance issues.