2 Replies Latest reply on Jun 14, 2010 3:21 AM by ahiq

    Buffer overrun after recording?

    ahiq

      When I do some recording in Captivate, since recently I get an error message after recording.

       

      Steps:

      • Start recording, do what needs to be recorded
      • End recording
      • Captivate shows the "Importing..." dialog
      • Importing stops halfway through. Windows shows an error dialog "Adobe Captivate has stopped working / Windows can check online for a solution to the problem. / Check online for a solution and close the program/Close the program"
      • Details in this dialog are:

       

        Problem Event Name:                        BEX

        Application Name:                             AdobeCaptivate.exe

        Application Version:                           4.0.1.1658

        Application Timestamp:                     2a425e19

        Fault Module Name:                          businessrules.dll

        Fault Module Version:                        4.0.0.1596

        Fault Module Timestamp:                  494fe471

        Exception Offset:                                00003782

        Exception Code:                                  c0000409

        Exception Data:                                   00000000

        OS Version:                                          6.1.7600.2.0.0.256.48

        Locale ID:                                             2057

        Additional Information 1:                  b8e0

        Additional Information 2:                  b8e02f170de3c6a934bc729e9440511a

        Additional Information 3:                  2efb

        Additional Information 4:                  2efb2b5cafff69e217a1c94d92a6ff90

       

      Some searching led me to the idea that Windows Data Execution Protection system has stopped Captivate, because of a buffer overrun (because of the Exception Code c0000409)

       

       

      Captivate has been installed on that computer for 4 weeks, and earlier it worked. The problem only is present since a couple of days. The update for 4.0 has been installed.

       

      Does anyone has a solution for this?

       

      (there was a post with the same error in a different forum, but no solutions there)

       

      Thanks,

      Alex

        • 1. Re: Buffer overrun after recording?
          ahiq Level 1

          We spent 4 days fiddling around with all kinds of settings, including disabling DEP, running as Administrator, running in Windows XP compatibility, disabling video acceleration, etc. Nothing helped.

           

          It turned out that the Captivate project file (the thing we're working on) was corrupt in one way or the other. We created a new file, copied the slides, and now recording works again.

           

          If anyone from Adobe cares to get the corrupt file, you can contact me. Can I get a voucher to upgrade to CP 5? :-)

          • 2. Re: Buffer overrun after recording?
            ahiq Level 1

            problem seems to be solved....