2 Replies Latest reply on Aug 16, 2007 8:12 PM by GhengisJones

    Library asset, layers and DW design view

    GhengisJones Level 1
      I've got a page I created as a library asset which incorporates a couple of images (jpg) and a form in different layers.

      Placed in other pages and then viewed in a browser, they appear exactly as they should.

      When I look at the library asset on its own, it appears exactly as it should.

      Here's the weird thing -- the library asset when placed in another page looks all wonky within Dreamweaver!

      Usually things look fine in your layout program and then go all wonky when viewed in a browser!

      Since it displays okay in browsers, I'm not too worried by it but it does interfere with assessing the look of a layout.

      Any ideas why this happens? Code example below:
      <%@LANGUAGE="VBSCRIPT" CODEPAGE="1252"%>
      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" " http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns=" http://www.w3.org/1999/xhtml">
      <head>
      <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
      <title>Untitled Document</title>
      <style type="text/css">
      <!--
      body {
      margin-left: 0px;
      margin-top: 0px;
      margin-right: 0px;
      margin-bottom: 0px;
      }
      a:link {
      color: #003D7C;
      }
      a:visited {
      color: #003D7C;
      }
      a:hover {
      color: D11241;
      }
      a:active {
      color: D11241;
      }
      -->
      </style></head>

      <body>
      <table width="100%" border="0" cellpadding="0" cellspacing="0" id="Tbl_Centre">
      <tr>
      <td align="center" valign="top"><table width="800" border="0" cellpadding="0" cellspacing="0" id="Tbl_3_Cols">
      <tr>
      <td colspan="3" align="left" valign="top"><!-- #BeginLibraryItem "/library/page_header20.lbi" -->
      <link href="dmw.css" rel="stylesheet" type="text/css" />
      <style type="text/css">
      <!--
      #BaseBar {
      position:absolute;
      left:0px;
      top:0px;
      width:800px;
      height:94px;
      }
      #Search {
      position:absolute;
      left:590px;
      top:10px;
      width:230px;
      height:75px;
      z-index:5;
      }
      #Container {
      position:relative;
      left:0px;
      top:0px;
      width:800px;
      height:94px;
      z-index:1;
      }
      -->
      </style>
      <div id="Container">
      <div id="BaseBar">
      <div id="Search">
      <form method="get" action=" http://search.atomz.com/search/">
      <input type="hidden" name="sp_a" value="xxx" />
      <input size="15" name="xxx />
      <input type="image" name="search_button" src="images/buttons/search_button.jpg" alt="Search" align="absmiddle" border="0" />
      <input type="hidden" name="sp_p" value="all" />
      <input type="hidden" name="sp_f" value="ISO-8859-1" />
      </form>
      </div>
      <img src="images/header_dmw_base_bar_800px.jpg" width="800" height="94" /></div>
      </div>
      <!-- #EndLibraryItem --></td>
      </tr>
      <tr>
      <td width="100" align="left" valign="top"> </td>
      <td width="600" valign="top">main bit goes here </td>
      <td width="100" valign="top"> </td>
      </tr>
      <tr>
      <td colspan="3" align="left" valign="top"> </td>
      </tr>
      </table></td>
      </tr>
      </table>
      </body>
      </html>
        • 1. Re: Library asset, layers and DW design view
          Level 7
          > Here's the weird thing -- the library asset when placed in another page
          > looks
          > all wonky within Dreamweaver!

          Does the Library item contain <html>, <head>, or <body> tags? If so, you
          will get exactly the symptoms you describe. This also means that you didn't
          create the Library item properly, since a well-formed Library item cannot
          contain those tags, and also cannot contain embedded or linked external CSS
          rules.

          --
          Murray --- ICQ 71997575
          Adobe Community Expert
          (If you *MUST* email me, don't LAUGH when you do so!)
          ==================
          http://www.dreamweavermx-templates.com - Template Triage!
          http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
          http://www.dwfaq.com - DW FAQs, Tutorials & Resources
          http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
          ==================


          "GhengisJones" <webforumsuser@macromedia.com> wrote in message
          news:fa2hqc$o7p$1@forums.macromedia.com...
          > I've got a page I created as a library asset which incorporates a couple
          > of
          > images (jpg) and a form in different layers.
          >
          > Placed in other pages and then viewed in a browser, they appear exactly as
          > they should.
          >
          > When I look at the library asset on its own, it appears exactly as it
          > should.
          >
          > Here's the weird thing -- the library asset when placed in another page
          > looks
          > all wonky within Dreamweaver!
          >
          > Usually things look fine in your layout program and then go all wonky when
          > viewed in a browser!
          >
          > Since it displays okay in browsers, I'm not too worried by it but it does
          > interfere with assessing the look of a layout.
          >
          > Any ideas why this happens? Code example below:
          > <%@LANGUAGE="VBSCRIPT" CODEPAGE="1252"%>
          > <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
          > " http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
          > <html xmlns=" http://www.w3.org/1999/xhtml">
          > <head>
          > <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
          > <title>Untitled Document</title>
          > <style type="text/css">
          > <!--
          > body {
          > margin-left: 0px;
          > margin-top: 0px;
          > margin-right: 0px;
          > margin-bottom: 0px;
          > }
          > a:link {
          > color: #003D7C;
          > }
          > a:visited {
          > color: #003D7C;
          > }
          > a:hover {
          > color: D11241;
          > }
          > a:active {
          > color: D11241;
          > }
          > -->
          > </style></head>
          >
          > <body>
          > <table width="100%" border="0" cellpadding="0" cellspacing="0"
          > id="Tbl_Centre">
          > <tr>
          > <td align="center" valign="top"><table width="800" border="0"
          > cellpadding="0" cellspacing="0" id="Tbl_3_Cols">
          > <tr>
          > <td colspan="3" align="left" valign="top"><!-- #BeginLibraryItem
          > "/library/page_header20.lbi" -->
          > <link href="dmw.css" rel="stylesheet" type="text/css" />
          > <style type="text/css">
          > <!--
          > #BaseBar {
          > position:absolute;
          > left:0px;
          > top:0px;
          > width:800px;
          > height:94px;
          > }
          > #Search {
          > position:absolute;
          > left:590px;
          > top:10px;
          > width:230px;
          > height:75px;
          > z-index:5;
          > }
          > #Container {
          > position:relative;
          > left:0px;
          > top:0px;
          > width:800px;
          > height:94px;
          > z-index:1;
          > }
          > -->
          > </style>
          > <div id="Container">
          > <div id="BaseBar">
          > <div id="Search">
          > <form method="get"
          > action=" http://search.atomz.com/search/">
          > <input type="hidden" name="sp_a" value="xxx" />
          > <input size="15" name="xxx />
          > <input type="image" name="search_button"
          > src="images/buttons/search_button.jpg" alt="Search" align="absmiddle"
          > border="0" />
          > <input type="hidden" name="sp_p" value="all" />
          > <input type="hidden" name="sp_f" value="ISO-8859-1" />
          > </form>
          > </div>
          > <img src="images/header_dmw_base_bar_800px.jpg" width="800"
          > height="94" /></div>
          > </div>
          > <!-- #EndLibraryItem --></td>
          > </tr>
          > <tr>
          > <td width="100" align="left" valign="top"> </td>
          > <td width="600" valign="top">main bit goes here </td>
          > <td width="100" valign="top"> </td>
          > </tr>
          > <tr>
          > <td colspan="3" align="left" valign="top"> </td>
          > </tr>
          > </table></td>
          > </tr>
          > </table>
          > </body>
          > </html>
          >


          • 2. Re: Library asset, layers and DW design view
            GhengisJones Level 1
            I'll check it out! Thanks