9 Replies Latest reply on Aug 17, 2007 5:59 AM by MergeThis

    Show Navigation pane link in topics disappears

    Polle2 Level 1
      When I click on a help link the topic with the navigation pane link is shortly displayed and is then replaced with the topic and the TOC in the left pane. I want to display the topic with the navigation pane link.
        • 1. Re: Show Navigation pane link in topics disappears
          MergeThis Level 4
          Asking the same question in a different way, in multiple posts, will not get you better or quicker answers. Some code was probably introduced by a previous help author to cause this topic replacement issue.

          Have you investigated the possiblity I mentioned in my response to your previous post? To do that, open the file in Notepad, outside of the project.


          Good luck,
          Leon
          • 2. Re: Show Navigation pane link in topics disappears
            Polle2 Level 1
            I could not find anything in the file. I found out that everything was OK when I accessed the files directly by double-clicking them.

            The problem is only present when I access the files from the application. I replaced the main html file with a dummy file. The same thing happened. Now I think it is a case for R&D. I know that they have a script to move and scale the help.
            • 3. Re: Show Navigation pane link in topics disappears
              HKabaker Level 2
              This behavior can vary among browsers. Are you using IE, or something else, to view the help system?

              Harvey
              • 4. Re: Show Navigation pane link in topics disappears
                MergeThis Level 4
                So, R&D has "a script to move and scale the help," do they?

                Sounds like they need to do some heavy lifting to fix this while, of course, you watch while trying to resist snickering...

                What they (and even a lot of help authors) don't understand, is that the topic that RH creates as the start page has absolutely nothing to do with any of the topics in your RH project (source files). It's what RH uses to present the help within the frameset and for multiple browsers (a lot of if-then-else stuff, and javascripts, and functions, and variables, oh my!).

                Just remind them not to rename or move anything: all folders and files generated by RH MUST remain intact.


                Good luck,
                Leon
                • 5. Re: Show Navigation pane link in topics disappears
                  Polle2 Level 1
                  I just tested 20 of the help links. 13 of them first displayed the help with the navigation pane link and then the help with the TOC displayed. 7 were OK. No double displaying. The help with the pane showed right away.

                  I really hope this is an R&D error, because if it is a Robhelp error it is beyond my comprehension.

                  Regards,

                  Verner
                  • 6. Re: Show Navigation pane link in topics disappears
                    Peter Grainge Adobe Community Professional (Moderator)
                    It may be stating the obvious but if the help works standalone, then the problem is with the calling.

                    • 7. Re: Show Navigation pane link in topics disappears
                      MergeThis Level 4
                      I concur with Peter's assessment.

                      1. The links work when viewing outside the application.
                      2. The links do not work when viewing from within the application.
                      3. The difference between 1 and 2 is that the application is calling the help.

                      Therefore, the calls to the help from the application are incorrect.


                      Good luck,
                      Leon
                      • 8. Re: Show Navigation pane link in topics disappears
                        Polle2 Level 1
                        All

                        I hope you are right. I must however mody my statement that the links work when called directly. They work when called directly by double-clicking any .html file. However, when clicking the "View result" in Robohelp after generating the files the TOC is always displayed and not the page with the navigation pane link in topic.
                        • 9. Re: Show Navigation pane link in topics disappears
                          MergeThis Level 4
                          Clarification of the WebHelp generation process seems to be called for.

                          The .htm file that appears in the "Select Output Folder and Start Page" field at the top of the first "WebHelp General - WebHelp" dialog is the file in which RH will place all the frameset and browser information needed to display the three frames (toolbar pane, left-hand TOC/Index/Search navigation pane, and right-hand topic pane). (The "Default Topic" field, in the same dialog, tells RH which actual content page/topic to display when that start page is launched.)

                          The direct launching of any other topic (you double clicking the filename or R&D calling it in the application) will result in one topic pane being displayed for that topic, with the "Show" button provided to switch over to the three-pane frameset.

                          However, launching a specific topic indirectly through the start page will display that page with the three-pane format. The call from the application would then be StartPage.htm#DestinationPage.htm. If you want to open the same topic at a prearranged bookmark, the call would be StartPage.htm#DestinationPage.htm#BookmarkSection.


                          Good luck,
                          Leon