9 Replies Latest reply on Jul 2, 2010 5:37 AM by nishadmusthafa

    Configure return type: There was an error while invoking the operation

    nikos101 Level 2

      This error only occurs when I pass parameters to Configure return type dialog

       

      As a follow on from http://forums.adobe.com/message/2663481

      I am getting this in the log.


      !ENTRY com.adobe.flexbuilder.DCDService 4 1 2010-06-15 11:45:29.323
      !MESSAGE Please specify a valid <services/> file path in flex-config.xml.
      !STACK 0
      flex.messaging.config.ConfigurationException: Please specify a valid <services/> file path in flex-config.xml.
          at flex.messaging.config.LocalFileResolver.getConfigurationFile(LocalFileResolver.java:79)
          at flex.messaging.config.AbstractConfigurationParser.parse(AbstractConfigurationParser.java: 67)
          at flex.messaging.config.ServicesDependencies.getClientConfiguration(ServicesDependencies.ja va:150)
          at com.adobe.flexbuilder.dcrad.utils.DCRADUtility.getServiceSettingsOnServer(DCRADUtility.ja va:1398)
          at com.adobe.flexbuilder.dcrad.utils.DCRADUtility.getServerConfiguration(DCRADUtility.java:1 374)
          at com.adobe.flexbuilder.dcrad.views.ServiceExplorerView.refreshService(ServiceExplorerView. java:1703)
          at com.adobe.flexbuilder.dcrad.views.ServiceExplorerView.refreshSelectedServices(ServiceExpl orerView.java:1650)
          at com.adobe.flexbuilder.dcrad.views.internal.actions.ServiceRefreshAction.run(ServiceRefres hAction.java:41)
          at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
          at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionI tem.java:584)
          at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
          at org.eclipse.jface.action.ActionContributionItem$6.handleEvent(ActionContributionItem.java :452)
          at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
          at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
          at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3880)
          at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3473)
          at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
          at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
          at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
          at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
          at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
          at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
          at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
          at com.adobe.flexbuilder.standalone.FlexBuilderApplication.start(FlexBuilderApplication.java :109)
          at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
          at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)
          at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)
          at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
          at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
          at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
          at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

       

      screen.jpg

       

      One problem I keep getting is that FB keeps setting this setting as J2EE Server even when I tell it is standalone. When I add a server an tell FB that it is Remote, does that mean its J2ee?