7 Replies Latest reply on Jun 18, 2010 1:48 AM by Joela47

    Maximum of one-second playback on Quad Core i5

    Joela47

      Not sure if this is the right avenue to ask this question, but i've trawled the forum and cant find an answer - I can't contact Tech Support as I only own CS4, and am just trialling Premiere CS5.

       

      ----

       

      Im trialling Premiere CS5 with a vision to upgrade from CS4 soon (primarily need CS5 for InDesign, Fireworks, Dreamweaver), but also looking at Master Collection to get more into video editing and make use of my Canon 7D.

       

      The issue i have is not being able to playback any more than a second within Premiere (hitting space bar or the play button) before i stops. Press play again and plays that same minuscule amount again.

       

      Aside from that, I really like the interface and can import / add / edit as intended and have no issue adding effects & transitions.

      Note: Even straight playback of a clip to preview it doesn't work.

       

      I can also export with no issues and can scrub through the clip and see the effects & transitions as planned.

       

      I've tried video footage straight off the 7D, and also several different codecs with no success.

       

      Updated the trial version i had this afternoon, but this hasn't resolved the problem.

       

      I'm running an iMac Quad Core i5 - 2.66hgz.

      Watching the activity monitor it really only maxed out when exporting.

       

      So today i decided to trial Final Cut Pro to see if it works, using the same footage it plays back smoothly with no issues - needed a render when using multiple layers.

       

      Exporting the same 20 second (unedited) clip is much faster in Premiere than Final Cut Pro.

       

      Personally prefer the Premiere interface too, and would rather spend my money in upgrading my CS4 suite than purchasing FCP.

       

      Is there something i've missed?

       

      Until then, back to iMovie for my little web clips

       

      Thanks

        • 1. Re: Maximum of one-second playback on Quad Core i5
          Harm Millaard Level 7

          Reading the limitations of the trial version may help:

           

          *The trial version of Adobe Premiere Pro CS5 does not include some  features that depend on software licensed from parties other than Adobe.  For example, some codecs for encoding MPEG formats are available only  with the full version of this product.

           

          7D material is MPEG based, so it does not work.

          • 2. Re: Maximum of one-second playback on Quad Core i5
            Joela47 Level 1

            Thanks Harm,

             

            Reading that adobe page it mentions "MPEG files cannot be imported or exported" which makes sense as i couldnt import direct off camera.

             

            But i had no issue importing files i'd converted to h264, cinepak, (mov, avi, mpg) etc, several unsuccessful attempts.

             

            My understanding of all the codecs/filetypes/wrappers isnt that great - is an mpeg off my DSLR always an mpeg at its heart even after converting it?

            • 3. Re: Maximum of one-second playback on Quad Core i5
              Harm Millaard Level 7

              If a MPEG-based file is converted to a non-MPEG format such as Lagarith, DV or Cinepak (if you want to use a really outdated codec) you can use it in the trial version. It will not be beneficial to the quality, but is a good way to circumvent the trial limitations and see if the program appeals to your workflow. The alternative is to buy the full version and if not satisfied return it within 30 days for a full refund.

              • 4. Re: Maximum of one-second playback on Quad Core i5
                Joela47 Level 1

                Whether its an outdated codec or not is a mute point with regards to my issue of getting playback to work.

                 

                My testing is not for production work, its simply to see if I want to purchase the product (i do) and if it works on my computer (the playback doesnt, everything else does).

                 

                As mentioned ive tried multiple file types & codec combinations, these have enabled me to import into Premiere and successfully edit/clip/add effect etc but NONE allow me playback/preview - which is a pretty crucial element to editing.

                 

                Thanks for your suggestions, but i think we're on a different wavelength with regards to my issue.

                • 5. Re: Maximum of one-second playback on Quad Core i5
                  Joela47 Level 1

                  Solved - sort of

                   

                  Being stubborn i refused to accept the suggested reasonings for no playback.

                   

                  So I installed the trial version of Premiere CS5 on my 3 year old imac (dual core, 2GB ram) to see if playback would work as intended. it's old system that is simply used as an "email machine".

                   

                  It worked fine (albeit a little slow when i applied ultra key) using the exact same footage I tried and failed with on the Quad Core i5.

                   

                  Im contemplating doing a complete reinstall of my OS on the weekend to see if that solves the problem on my main computer.

                  • 7. Re: Maximum of one-second playback on Quad Core i5
                    Joela47 Level 1

                    Brilliant, thanks Todd.

                    Logging in as root as you suggested was the solution, fixed the problem perfectly.

                     

                    Can you talk to the boss to provide me the funds to purchase the upgrade from CS4 please