4 Replies Latest reply on Jun 21, 2010 8:47 AM by Sean S Murphy

    Router Settings

    Sean S Murphy Level 1

      Is there any router guidelines or network admin standards that will enable stratus to make p2p connections easier.

       

      I have my own network with a standard linksys router, and for some reason i'm not able to have two computers within my network connect to each other using stratus. I'd like to make any necessary changes to rectify that situation.

       

      Thanks,

       

      Sean

        • 1. Re: Router Settings
          Michael Thornburgh Adobe Employee

          is one computer wired and the other wireless?  if so, you probably have a "double-NAT" setup.  if your router doesn't support hairpinning, then they won't be able to talk directly with each other.  if this is the case, you may be able to configure the wireless portion as bridged instead of NATted, which effectively makes the wired and wireless networks the same LAN.  then see my next paragraph. 

           

          if both computers are on the same LAN, then they should be able to communicate directly no matter what settings you have on your router (assuming they can both connect to Stratus at all).  if they're on the same LAN and they can't directly communicate, then it's a firewall configuration issue on one or the other (or both) of the computers.

          1 person found this helpful
          • 2. Re: Router Settings
            Sean S Murphy Level 1

            It looks like it is indeed because one computer is on the wired portion of the router, and the other on the wireless. I plugged my wireless comp into the wired portion of the network and they were able to connect fine.

             

            So the next question i have is on a typical linksys router (WRT-xxx) do you know what would be the setting to modify to get this working?

             

             

            Network topology looks like this

             

            Internet -> linksys router -> Desktop computer (wired)

                                                -> Laptop (wireless)

             

             

            Thanks,

             

            Sean

            • 3. Re: Router Settings
              Michael Thornburgh Adobe Employee

              i don't have any experience with those.  but in general you want to look for the settings for the wireless network and set it to "bridged to your wired network" instead of having its own (sub-)NAT.

              • 4. Re: Router Settings
                Sean S Murphy Level 1

                Thanks for your patence and help.

                 

                For some reason windows 7 set up different firewalls for my wired and wireless connections, after disabling my firewall and connecting wirelessly, i was able to get the two computers to communicate through Stratus. It looks like the router by default doesn't double nat anything.

                 

                So i guess the lesson learned here is if stratus is having a hard time connecting try disabling the firewall and see if that makes a difference