5 Replies Latest reply on Jun 21, 2010 5:25 AM by Steve Grisetti

    video shows as red screen

    HelpGrandma

      I thought it would be a wonderful idea to make keepsake movies for my grandchildren.  I purchased both Photoshop and Premiere Elements 8.

      Video's work in the Organizer but not in Premiere. (Audio works in Premiere)  I've read countless pages of info that I don't understand but when I try to load photo's and video's into Premiere, I get the message I'm missing something called a CODEC. (The still images will load - just problem with video's.) Again, I researched as much as I could to try and understand this but to no avail.

       

      My video's are all taken with a Sony DSC T90 digital camera.  It uses MPEG4 (as format? don't know what it's called).  The Adobe box says it's compatible with MP4.  I have QuickTime 7 which says it has MPEG4 CODEC.  I have Windows Media Player version 11.0.6002.18111 and says it has MP4.

       

      My Dell computer has Intel R (TM)2 Duo CPU T9300 @ 2.50 GHz.

      4GB RAM  Video card ATI Mobility Radeon HD3650 version 8.477.0 (up to date),   Audio IDT High Definition Audio CODEC

      Disk Drives  ST9200420ASG partition MBR  1 free MB  driver version 6.0.6002.18005  date 6/21/2006

       

      I have Vista Home Premium 32 bit.

       

      I am hoping someone can give me simple, easy to follow instructions on how to get my video's to work in Premiere Elements 8.  (I upgraded from Premiere 6 that came with my computer - had played around with it a bit and thought I could figure out how to use Premiere 8 but, as mentioned above, can't get the video's to show anything except a red screen.  I uninstalled Premiere 6 in case there was some kind of conflict.)

       

      Thanks to anyone who can help 'lower my blood pressure'.

      Barbara