7 Replies Latest reply on Jun 29, 2010 1:22 PM by wjt1321

    NavigatetoURL only working on some computers

    wjt1321

      I am working on a Flex web app (using FlashBuilder 4) and I am having a strange issue.  On the final page, I am using a "Finish" button that calls a function that sends the user to another web page, with form data already filled in.  I am using the navigatetoURL function to do this.

       

      My function call looks like this:

       

       

      navigateToURL(new URLRequest(whereTo), '_parent');

       

       

      whereTo is a string variable defined previously, it is a valid web page. 

       

      Now, this works fine on most computers (in fact, it works fine on every computer I personally have access to, tested it on all 38), but on other computers clicking the button does absolutely nothing.  The browser does not attempt to load anything, it just sits there, as if no button had been pressed.

       

      I have tried changing it from '_parent' to '_self' and I have allowScriptAccess set to "always" in the wrapper. (both of those were causing this particular issue for some of the users calling me with the issue)

      This issue effects both FireFox and IE (Not many of our users use any other web browser, so I haven't had reports on those).  I have tried adjusting every security setting I can find on two different computers and cannot recreate the issue.  However, the issue is the same, coming from a wide variety of sources.

       

      Anyone have any ideas on anything else I can try?  Any ideas as to what could be going wrong with this?

       

      Thanks.