2 Replies Latest reply on Jun 23, 2010 9:39 AM by rtalton

    RSL load error #2046

    atsai89

      Hi,

       

      I have been experiencing this error when I try to use the framework.swc RSL with flex sdk 3.5. I receive an RSL Error #2046: The loaded file did not have a valid signature.

       

      The file specifically is framework_3.5.0.12683.swz - and I have tried with both the version in the open source SDK, as well as the one that comes with Flash Builder 4. I am compiling my swf with mxmlc, and I am pretty sure the config and settings are all correct. When I keep the same settings and use flex 3.0 I have no problems with the RSL.

      If I build the project in FlashBuilder with 3.5 with RSLs and run from there, it will load correctly and the swz is cached. However, with the same swf and framework files run outside of FlashBuilder and a cleared cache, I once again get the error.

       

      I searched around and found almost the same issue someone had with datavisualization_3.5.0.12683 here http://bugs.adobe.com/jira/browse/FB-25156 . The issue was resolved and I see that a new version of the datavisualization RSL is available for download on the Adobe site. Is there the same issue with the framework.swc? Are there any other possible sources for this error?

       

      Thanks

        • 1. Re: RSL load error #2046
          Darrell Loverin Level 4

          I tried the framework_3.5.0.12683.swz that comes with FlashBuilder 4. It worked fine for me and cached.

           

          I'd say either the framework.swc or RSL have been modified. One way to help debug the problem is to compile your application with -keep. Search for "cdRsls" in the generated code. The generated code should be in the bin-debug directory. In the generated code near "cdRsls" you should see the framework RSL load information. What is the RSL URL and digest? The digest should be "3c82b2a2455b252b8595fd0113249aa19d7e8bdd516b2f6ea43244aa6d543d58".

           

           

          -Darrell

          • 2. Re: RSL load error #2046
            rtalton Level 4

            I always get this error using Flex Builder 3 after updating to a new SDK version. I don't use mxmlc to compile, but I can tell you in my case I have to adjust the RSL URL settings.

             

            In Flex 3:

            -->PROJECT-->PROPERTIES
            Flex Build Path
            Library Path tab
            Expand the node which reads "Flex 3.x - C:\program Files\..."
            Expand the node: "framework.swc"
            Select the node: RSL URL
              Check the version number here, if it is wrong, edit to match the SDK being used.
              i.e.  "framework_3.5.0.12683.swf"    and "framework_3.5.0.12683.swz"

             

            You might check this before you compile using mxmlc.