12 Replies Latest reply: Sep 10, 2010 8:44 PM by garymeans RSS

    "SwitchBoard Server (32-bit) has stopped working" Bridge CS5

    garymeans Community Member

      I installed Design Premium CS5 last week and tried Bridge today. It worked fine and then suddenly whenever I open it, I keep getting this window. I close the window, but it appears again after a few seconds. I can still use Bridge, but the window won't go away.

        • 1. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
          juliem321 Community Member

          The switchboard server process provides communication between Bridge and Mini Bridge (in Photoshop, InDesign and InCopy). The switchboard server launches when you launch Bridge and runs in the background. It sounds like this process keeps trying to start, then crashes. What Windows OS are you running and is it 32bit or 64bit? Once I find that out, I'll get you some information on where to find a crash log that you can send.

           

          Thanks,

          Julie Manley

          Adobe

          • 2. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
            garymeans Community Member

            I'm using Windows 7 Pro on a 64-bit machine.

            • 3. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
              Baichao Li Adobe Employee

              Please try a few things in the following,

               

              - Try launching switchboard.exe directly (located in \Program Files (x86)\Common Files\Adobe\Switchboard). On a working system, switchboard should launch, run for a few seconds, then exit (since it has no connection to Bridge or Mini Bridge, please use "Windows Task Manager"->Processes to monitor this).

               

              - Try deleting the switchboard.ini file (located in \Users\<username>\AppData\Roaming\Adobe\Switchboard), then launch switchboard.exe manually again. This should regenerate the ini file.
              - Check the contents of the switchboard.ini file - it should contain 5 values:
              MD5=Alphanumeric value
              USERID=Alphanumeric value
              SWITCHBOARD=Alphanumeric value
              PORT=3705
              SERVER=path to Switchboard.exe
              (See tech note http://kb2.adobe.com/cps/830/cpsid_83045.html if the MD5 or USERID values are missing.)

               

              - Check the user's hosts file (a default hosts file can be found here:http://support.microsoft.com/kb/972034)

               

              - Try creating a new user account, log into the new account and try running Bridge to see if switchboard still crashes.

              • 4. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
                garymeans Community Member

                Thanks for the reply. I tried all of these things and still get the same error message when using the new user account and my normal user account. What should I try next?

                • 5. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
                  garymeans Community Member

                  I've found that if I close the error message about 5 or 6 times, Bridge finally catalogs everything and works just fine. The error message doesn't come up again until the next time I open Bridge. It's a problem I can live with, but my concern is that it indicates that something is not right with my system or with my copy of Bridge.

                  • 6. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
                    nico_angleys Community Member

                    I'm having the exact same problem. It usually takes 4 times telling the windows message to "stop the program" for Bridge to remember and stop popping it up. I'm using a Dell Precision M4400 with 4GB RAM. So yeah, I'd love to hear of a solution that works!

                    • 7. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
                      garymeans Community Member

                      This is so frustrating. I got support from Adobe for a while. My case was opened on July 14. But since July 27, the status has been: "Open pending  Adobe response." They just stopped communicating with me. No explanation.  I've sent three messages since then asking for some communication, even just to let me know that there's nothing they can do.

                       

                      I did everything they suggested and answered all of their questions. Nothing helped. Perhaps they've started hiring former Dell employees to run their customer support.

                      • 8. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
                        MikeV99 Community Member

                        I am having a problem with the switchboard server on an XP/sp3 system as well.Since the switchboard server is not loading correctly, mini-bridge will sit waiting for CS 5 Bridge forever.However, Mini-Bridge still does start correctly if Bridge was started previously. I think I know why, but do not know how to fix it.

                         

                        The Adobe Switchboard service is suppose to load which leads to a switchboard process being loaded. The switchboard service does not load (error information below) and the switchboard.exe process is not started in the Windows XP run list when one logs on. Hence, mini-bridge has no switchboard to use to start bridge.

                         

                        However, if one starts Bridge first (even if one closes and exits bridge) the switchboard.exe process is started by Bridge. After that, mini-Bridge works correctly.

                         

                        I have attempted to start the process from a command window, but nothing happens and no event is recorded.

                         

                        C:\Program Files\Common Files\Adobe\SwitchBoard>dir
                        Volume in drive C has no label.
                        Volume Serial Number is 88E4-EDB7

                        Directory of C:\Program Files\Common Files\Adobe\SwitchBoard

                        07/28/2010  03:26 PM    <DIR>          .
                        07/28/2010  03:26 PM    <DIR>          ..
                        02/19/2010  01:37 PM           422,400 adobe_caps.dll
                        07/28/2010  03:26 PM    <DIR>          AMT
                        07/28/2010  03:26 PM    <DIR>          Legal
                        02/19/2010  01:37 PM           517,096 SwitchBoard.exe
                        02/19/2010  01:37 PM            30,489 SwitchBoard.pdf
                                       3 File(s)        969,985 bytes
                                       4 Dir(s)  84,354,781,184 bytes free

                        C:\Program Files\Common Files\Adobe\SwitchBoard>switchboard.exe

                        C:\Program Files\Common Files\Adobe\SwitchBoard>

                         

                        So Bridge can start the process but I cannot (even with an administrative account).

                         

                        The following is the error information about the Adobe Switchboard service error:

                         

                        Event Type: Error
                        Event Source: Service Control Manager
                        Event Category: None
                        Event ID: 7009
                        Date:  8/24/2010
                        Time:  4:29:05 PM
                        User:  N/A
                        Computer: MAINXP
                        Description:
                        Timeout (30000 milliseconds) waiting for the Adobe SwitchBoard service to connect.

                        For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


                        Event Type: Error
                        Event Source: Service Control Manager
                        Event Category: None
                        Event ID: 7000
                        Date:  8/24/2010
                        Time:  4:29:05 PM
                        User:  N/A
                        Computer: MAINXP
                        Description:
                        The Adobe SwitchBoard service failed to start due to the following error:
                        The service did not respond to the start or control request in a timely fashion.

                        For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


                        sc query Adobe SwitchBoard

                         

                        Microsoft Windows XP [Version 5.1.2600]
                        (C) Copyright 1985-2001 Microsoft Corp.

                        C:\Documents and Settings\testuser>sc query Adobe SwitchBoard
                        [SC] EnumQueryServicesStatus:OpenService FAILED 1060:

                        The specified service does not exist as an installed service.

                         

                        These types of errors are happening with other users, but the causes vary with the OS being used.

                         

                        Ideas?

                        • 9. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
                          garymeans Community Member

                          @MikeV99, I don't know if you have an active support case on this with Adobe, but if you do and you get an answer from Adobe (or any response at all, for that matter) please post it here. I'm still waiting for a response from Adobe. Very frustrating not to get a reply, let alone a solution to the problem.

                          • 10. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
                            MikeV99 Community Member

                            I have had a ticket open for a while -- not seeing a lot of progress though.

                             

                            I upgraded my laptop to CS5/LR3. It runs Vista. I am seeing the same issue on that machine as well. The switchboard process does not get started unless I first start Bridge. After that everthing works as it should. Two different computers, two different operating systems, two different user accounts and same problem.

                             

                            My workaround is to first start Bridge (it has an option to be started automatically at logon to run in the background).

                            • 11. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
                              nico_angleys Community Member

                              Mike - good to know there's a workaround, I'll give that a try! I still have the problem, and it take 4 tries every time I launch bridge.

                              Adobe support told me to do the following (see below the dashed line) I haven't tried solution 2 and the reinstall yet, as that's a bit more time-intensive and I haven't had the space in life to do that now. The solution 1 thing didn't work for me.

                               

                              maybe this will help either of you? Please do let me know if it does!

                              Cheers.

                               

                              ------------------------------------------------------------------------------------------ -------------------------------

                               

                              I would like to inform you that i have found some troubleshooting steps
                              that can help you resolving the issue :

                               

                              Reset Bridge preferences and default workspace, and purge the entire
                              thumbnail cache.

                               

                              Reset Bridge preferences and default workspace, and purge the entire
                              thumbnail cache to eliminate problems with unexpected behavior when
                              launching Bridge CS5.

                               

                              Note: When you use this solution, Bridge will create new preferences and
                              a new default workspace, and you will lose custom settings associated
                              with your current preferences and workspace. The thumbnail cache will
                              re-created automatically when you start Bridge.

                               

                              To reset Bridge preferences and default workspace and purge the
                              thumbnail cache:

                               

                              1. Quit Bridge.
                              2. Hold down the Ctrl key while starting Adobe Bridge CS5.
                              3. Choose one or more of the following options from the Reset
                              Settings dialog box:
                              * Reset Preferences to reset Bridge preferences.
                              * Reset to Default Workspace to reset Bridge to the default
                              workspace.
                              * Purge Entire Thumbnail Cache to purge entire thumbnail
                              cache.

                               


                              Solution 2 : Run Bridge while no other applications are running.

                               

                              Some applications or services may cause system errors or freezes when
                              running concurrently with Bridge. Before starting Bridge, disable other
                              applications, including startup items and services (items that start
                              automatically with Windows).

                               

                              To disable startup items and non Microsoft services:

                               

                              1. Quit all applications.
                              2. Choose Start, type msconfig in the Search text box, and press
                              Enter.
                              3. Write down all unselected items under the Startup and Services
                              tabs.
                              4. Click the General tab, and choose Selective Startup.
                              5. Click the Startup tab and select Disable All.
                              6. Select any startup items that are essential for testing the
                              problem (for example, Adobe CS4 Service Manager). If you are unsure
                              whether an item is essential, leave it deselected (disabled).
                              7. Click the Services tab, and check Hide All Microsoft Services.
                              8. Select Disable All, then turn back FLEXnet Licensing Service and
                              click OK. If you are unsure whether an item is essential, leave it
                              deselected (disabled).
                              9. Click Apply, and restart Windows for the changes to take effect.

                               

                              Note: Upon restart, you'll be notified that the System
                              Configuration utility has made changes to the way that Windows starts u
                              p. Click OK. When the System Configuration utility appears click Cancel.

                               

                              10. Right-click icons in the Notification Area and close or disable
                              any startup items that are still active.

                               

                              Then, try to re-create the problem:

                               

                              * If the problem no longer occurs, one of the startup items is the
                              cause of the problem.
                              * If the problem recurs, startup items are not the cause of the
                              problem and you can re-enable them:
                              1. Choose Start, type msconfig in the Search text box, and
                              press Enter.
                              2. Click the General tab, and choose Normal Startup.
                              3. Deselect any items that you wrote down in Step 3 of the
                              previous section.
                              4. Click Apply, and restart Windows for the changes to take
                              effect.

                               


                              Also if the issue still persists then you need to reinstall Adobe Bridge
                              again and then try to launch Adobe Bridge CS5.
                              If you are unable to install an individual product that contains Bridge
                              (for example, Adobe Photoshop CS5) from your CD/DVD drive, then install
                              the individual product that contains Bridge from the desktop.

                               

                              1. Copy the product installation disc that you have to the desktop.
                              2. Open the product folder that contains Bridge from the desktop.
                              3. Double-click the Setup.exe file, and then follow the on-screen
                              instructions.

                               

                              This should resolve your issue. If it does, please let us know, however
                              in case it does not; please revert with any new information that you
                              might want to add which will help us in resolving your issue.

                               

                              You can also try referring to our knowledge base and User to User
                              forums by clicking on the following links:
                              Knowledgebase: http://www.adobe.com/cfusion/search/index.cfm
                              U2U Forums: www.forums.adobe.com

                              • 12. Re: "SwitchBoard Server (32-bit) has stopped working" Bridge CS5
                                garymeans Community Member

                                Nico, I tried those steps, to no avail. I also tried Mike's work-around. But it did not work for me. I still get the SwitchBoard Server error message popping up whenver Bridge opens. It finally stops popping up after I delete it about 6 or 7 times and then Bridge works fine.

                                 

                                MiniBridge does not work though.The frustrating thing is that MB worked the first time I opened Photoshop CS5. I use Abobe products for at least 8-hours a day. I just wish I could more of their functionality.