8 Replies Latest reply on Jul 14, 2010 11:18 AM by Eric in CA

    Problem with full-text search in RH8

    Aplrh8

      Hi All,

       

      I've just upgraded from RH6 to RH8 (laptop running Windows XP SP3; RH6 still present on the computer but the RH8 setup program did not seem to have a problem with that: identified an earlier version was present, asked for its serial number, and then proceeded).

       

      RH8 is working just fine, except for one thing: in the WebHelp output I generate, the Search tab displays: "Error: Failed to initialize database".

       

      As a matter of fact, the generation details in RH8 output view state:

      ...

      Processing Full-text-search data...

      Finished processing Full-Text-Search data in 0 sec(s)

      ...

       

      This is the case for legacy projects that RH8 upgraded from RH6, but also when I create a project from scratch in RH8.

       

      Now, to add to my confusion, before buying RH8, I had downloaded RH8 trial version and installed it on a spare computer (so it would not interfere with my RH6 installation and projects). The tests with this version were OK (hence the decision to buy the upgrade), and guess what: there was no problem whatsoever with full-text search, neither on legacy projects nor on new projects.

       

      So before I go into the pains of uninstalling / reinstalling (hello registry, it's me again, trying to clean things up ;-), I'd like to know if anyone has any idea why this is happening.

       

      Just to be clear: The RH8 version I bought and installed was a new download, distinct from the initial trial download.

      The 3 differences between the trial version and the current working version are:

      • Trial was on a Vista computer (working version is on XP SP3)
      • Trial did not have RH6 present on the computer
      • Trial was version 8.0.0.203, whereas the working version is 8.0.2.208 (immediately after it was installed, RH prompted me to install the updates)

      Thanks in advance for any help or advice.

        • 1. Re: Problem with full-text search in RH8
          Peter Grainge Adobe Community Professional (Moderator)

          Did you buy a full licence for RH8 or an upgrade? If the latter, you are not entitled to keep RH6 and I have seen that cause problems. I am not saying that is the cause, just that it is a possibility.

           

          Is the trial still within its 30 days? If so try the project on that machine.

           

          Also try the supplied sample projects. Do they error? If not, try the old trick of deleting the CPD and reopening the project.

           

          If you do have to uninstall, you might like to take a look at RevoUninstaller. Quite a few people have reported good results with that as it deep cleans the registry. Just make sure you read the instructions. Hopefully it will not be necessary.

           


          See www.grainge.org for RoboHelp and Authoring tips

           

          @petergrainge

          • 2. Re: Problem with full-text search in RH8
            Aplrh8 Level 1

            Thank you so much for you answer.

             

            I bought the upgrade, and actually I was quite surprised to see that the RH6 version was still there after installing RH8: I thought the upgrade would make it unavailable. So I guess (hope ;-) this is what is causing this issue.
            The trial version is still in its 30 days and all the projects, including test projects created from scratch, work fine with it, so the problem is not with the projects, but most likely, as you suggest, with something in the software configuration of my working laptop.

             

            Can I uninstall RH6 without previously uninstalling RH8? (Sorry, but I'm a bit confused with these software upgrades that do not actually upgrade the existing version.)

             

            Thanks again.

            • 3. Re: Problem with full-text search in RH8
              Peter Grainge Adobe Community Professional (Moderator)

              You might be able to but I would uninstall RH8 and then RH6.

               

              Also whilst theoretically not necessary, I would deactivate both before uninstalling.

               

              Once done, reinstall RH8 and hopefully all will be OK. Let us know.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

              @petergrainge

              • 4. Re: Problem with full-text search in RH8
                Peter Grainge Adobe Community Professional (Moderator)

                I should add there are other posts about text search problems, albeit different to yours, so the upgrade could be a red herring.

                 

                You might want to look at the other posts first.

                 


                See www.grainge.org for RoboHelp and Authoring tips

                 

                @petergrainge

                • 5. Re: Problem with full-text search in RH8
                  Aplrh8 Level 1

                  Before posting, I checked the forums and tried the suggestions I had found (like editing the RoboHHRE.lng file), but nothing worked.

                  I will now follow your advice on uninstalling & reinstalling (crossing fingers ;-). I'll post my "results"...

                  Thanks for your help.

                  • 6. Re: Problem with full-text search in RH8
                    Aplrh8 Level 1

                    Ok, so I uninstalled RH8 and RH6 (and deleted undeleted folders and registry keys, etc.), and then reinstalled RH8, created a project from scratch using one of RH8 default templates, generated the WebHelp output... and got the same error. The time to index full-text search is still 0 sec. and as a result, when viewing the generated output, the Search tab displays "Error: Failed to initialize database".

                    I'm at a loss here, anybody has any idea what I could do now?

                    Thanks in advance.

                    • 7. Re: Problem with full-text search in RH8
                      Aplrh8 Level 1

                      Hi All,

                       

                      Just for the record, IT people here were eventually able to have RH8 full-text search feature working on my laptop by:

                       

                      1/ Installing an XP virtual machine from scratch, and then installing RH8 on it (we created a small project and generated the webhelp output, just to make sure the search feature did work in that environment).

                       

                      2/ Using a software virtualization application to capture that RH8 install and deploy it on my laptop.

                       

                      The problem is not solved, because we still don't know what caused it (conflicting DLLs?), but it looks like we have a workaround - although certainly not a quick and easy one ;-)

                      • 8. Re: Problem with full-text search in RH8
                        Eric in CA

                        Hello,


                        This is an FYI...no question.

                         

                        We are experiencing the same problem when upgrading to RH8 (i.e. “Failed to Initialize Database” error).  In our case, with prior releases we need to do some post processing of the files after RoboHelp generates them (for example, remove CTRL-M and CTRL-S which occur when transferring to Unix, and changing Topic Names, etc).   It has never been a problem until RH8.

                         

                        Now RH8 has changed its JavaScript to handle the searching of help files to be similar to a database, and when the search tab is checked, a sort of CheckSum is used to check that the integrity of the help files are intact.    The post processing that we run on the search directories (whxdata, whdata, and whgdata), is causing the the new JavaScript checksum routines RoboHelp 8 to yield a “Failed to Initialize Databse” error.

                         

                        We have had to rethink our post-processing handling due to this new integrity checking in RH8.

                         

                        Eric