7 Replies Latest reply on Mar 31, 2011 8:49 AM by R.S

    Export Release Build stopped working on Flash builder 4.0.1

    Zlaper

      Does anybody else have a problem  with "Export Release Build..." with the new Flash builder version ?

       

      I'm  selecting the option through the menu, and nothing happens.

        • 1. Re: Export Release Build stopped working on Flash builder 4.0.1
          Zdrif

          Same here the error log of eclipse:

          !ENTRY org.eclipse.ui 4 0 2010-07-05 11:25:51.796
          !MESSAGE Unhandled event loop exception
          !STACK 0
          java.lang.NoClassDefFoundError: com/adobe/flexbuilder/exportimport/releaseversion/ui/ExportSigningPage$1
              at com.adobe.flexbuilder.exportimport.releaseversion.ui.ExportSigningPage.createControl(Expo rtSigningPage.java:117)
              at org.eclipse.jface.wizard.Wizard.createPageControls(Wizard.java:170)
              at com.adobe.flexbuilder.exportimport.releaseversion.ui.ExportReleaseVersionWizard.createPag eControls(ExportReleaseVersionWizard.java:310)
              at org.eclipse.jface.wizard.WizardDialog.createPageControls(WizardDialog.java:675)
              at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:549)
              at org.eclipse.jface.window.Window.create(Window.java:431)
              at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1089)
              at com.adobe.flexbuilder.exportimport.releaseversion.ExportReleaseVersionAction$1.run(Export ReleaseVersionAction.java:93)
              at com.adobe.flexbuilder.exportimport.releaseversion.ExportReleaseVersionAction.run(ExportRe leaseVersionAction.java:103)
              at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:251)
              at org.eclipse.ui.internal.WWinPluginAction.runWithEvent(WWinPluginAction.java:229)
              at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionI tem.java:584)
              at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
              at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java :411)
              at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
              at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
              at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3880)
              at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3473)
              at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
              at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
              at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
              at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
              at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
              at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
              at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
              at com.adobe.flexbuilder.standalone.FlexBuilderApplication.start(FlexBuilderApplication.java :109)
              at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
              at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)
              at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)
              at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
              at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
              at java.lang.reflect.Method.invoke(Unknown Source)
              at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
              at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
              at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

          • 2. Re: Export Release Build stopped working on Flash builder 4.0.1
            Zlaper Level 1

            There was a problem during the update process. I downloaded the full Flash Builder package and everything is fine now.

            • 3. Re: Export Release Build stopped working on Flash builder 4.0.1
              DavidSalahi Level 1

              It looks like I ran into the same thing. All of a sudden today I found that choosing Export --> Release Build did nothing. Tried it in various projects in various workspaces and got the same lack of response everywhere. I downloaded the latest from adobe.com, uninstalled and reinstalled and now it's working again.

               

              It does appear that there was some error during the 4.0.1 upgrade the first time around. Before uninstalling I checked the Flash Builder version and it was saying 4.0 and NOT 4.0.1 even though I had run the updater to install 4.0.1.

               

              This also apparently explains another problem that I had experienced. After installing 4.0.1 the first time (which completed with no reported error) I found that the 4.1 SDK was not shown as an option in my Project Properties. However, the 4.1 SDK  had been installed into my C:\Program Files (x86)\Adobe\Adobe Flash Builder 4\sdks directory. I was able to manually add the SDK by clicking the Configure Flex SDKs link on the Flex Compiler tab. But now, after uninstalling/reinstalling the 4.1 SDK shows up as the default and the 4.0 SDK which was also previously present is gone.

               

              David Salahi

              • 4. Re: Export Release Build stopped working on Flash builder 4.0.1
                mrvwman

                I am having this same problem in the select files to include part of the wizard I click finish and nothing happens.  It just brings me back to the same spot.

                 

                I read the forums and then uninstalled Flash Builder and re-installed it.  All my projects were working fine before and had stopped working in this same way.  Re-installing fixed the problem for some of my projects, but two still have this problem.  For the problem that still exists this is what the log file says.

                 

                !SESSION 2010-08-27 07:23:31.097 -----------------------------------------------
                eclipse.buildId=unknown
                java.version=1.6.0_16
                java.vendor=Sun Microsystems Inc.
                BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
                Command-line arguments:  -os win32 -ws win32 -arch x86 -clean

                !ENTRY org.eclipse.equinox.ds 4 0 2010-08-27 07:23:33.069
                !MESSAGE
                !STACK 0
                org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0"
                     at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1313)
                     at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1297)
                     at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:309)
                     at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:370)
                     at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1068)
                     at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:557)
                     at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:464)
                     at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:248)
                     at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:445)
                     at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
                     at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)

                !ENTRY org.eclipse.ui 4 4 2010-08-27 07:24:01.671
                !MESSAGE Unable to find view with id: com.adobe.flashbuilder.analytics.ui.SiteCatalystView, when creating perspective com.adobe.flexbuilder.editors.mxml.ui.perspectives.development

                 

                Any suggestions or help would be appreciated.

                 

                ~>Bill

                • 5. Re: Export Release Build stopped working on Flash builder 4.0.1
                  mrvwman Level 1

                  I solved my own problem.

                   

                  This error was caused by using \ vs / in the app descriptor xml file.

                   

                  <icon>

                    <image32x32>assets\icon.png</image32x32>

                  vs.

                    <image32x32>assets/icon.png</image32x32>


                  This seems like something that should be caught before you get to the export release build step, but it isn't.  The \'s work fine in building and running from within FB, it's only when you go to export that it becomes an issue.

                   

                  ~>Bill

                  • 7. Re: Export Release Build stopped working on Flash builder 4.0.1
                    R.S

                    You save my time! Thanks!