15 Replies Latest reply on Jul 26, 2010 6:13 PM by C. Agruss (Adobe)

    FB 4.0.1 Design Mode not working

    adambergman

      After installing the update, I am able to use Code View just fine, but when switching to design view the entire application "whites out".  After resizing the window some things come back, but I am never fully in Design View.  I get the error "com.adobe.flexide.embeddedplayer.ExternalPlayer.<init>(ILcom/adobe/flexide/embeddedplaye r/IPLayerHost;I)V"

       

      Screen shot 2010-07-01 at 1.34.30 PM.png

      Screen shot 2010-07-01 at 11.54.46 AM.png

      Screen shot 2010-07-01 at 1.38.21 PM.png

        • 1. Re: FB 4.0.1 Design Mode not working
          C. Agruss (Adobe) Level 3

          Thanks for reporting this. I've notified the Engineering team, to see if they understand what's happening here, and will let you know.

           

          -Chris

          • 2. Re: FB 4.0.1 Design Mode not working
            gfeng

            Hello,

             

            I have the same issue. The log files contains the following exception (maybe it helps):

             

            com.adobe.flexide.embeddedplayer.ExternalPlayer.<init>(ILcom/adobe/flexide/embeddedplayer/ IPlayerHost;I)V
                   at com.adobe.flexide.playerview.PlayerViewer.<init>(PlayerViewer.java:48)
                   at com.adobe.flexbuilder.designview.DesignViewPart.createPlayerCanvas(DesignViewPart.java:15 8)
                   at com.adobe.flexbuilder.designview.DesignViewPart.loadDesignViewSwf(DesignViewPart.java:195 )
                   at com.adobe.flexbuilder.mxml.editor.design.MXMLDesignPart.startDesignView(MXMLDesignPart.ja va:203)
                   at com.adobe.flexbuilder.mxml.editor.design.MXMLDesignPart.<init>(MXMLDesignPart.java:68)
                   at com.adobe.flexbuilder.mxml.editor.design.MXMLDesignEditor.initializePlayer(MXMLDesignEdit or.java:1411)
                   at com.adobe.flexbuilder.mxml.editor.design.MXMLDesignEditor.initializeDesignView(MXMLDesign Editor.java:1576)
                   at com.adobe.flexbuilder.mxml.editor.design.MXMLDesignEditor.setFocus(MXMLDesignEditor.java: 1736)
                   at org.eclipse.ui.part.MultiPageEditorPart.setFocus(MultiPageEditorPart.java:1119)
                   at org.eclipse.ui.part.MultiPageEditorPart.setFocus(MultiPageEditorPart.java:1101)
                   at org.eclipse.ui.part.MultiPageEditorPart.pageChange(MultiPageEditorPart.java:837)
                   at com.adobe.flexbuilder.editorcore.editor.CodeAndDesignEditor.pageChange(CodeAndDesignEdito r.java:546)
                   at com.adobe.flexbuilder.mxml.editor.MXMLEditor.pageChange(MXMLEditor.java:479)
                   at org.eclipse.ui.part.MultiPageEditorPart.setActivePage(MultiPageEditorPart.java:1076)
                   at com.adobe.flexbuilder.editorcore.editor.CodeAndDesignEditor.setActivePage(CodeAndDesignEd itor.java:683)
                   at com.adobe.flexbuilder.mxml.editor.MXMLEditor.setActivePage(MXMLEditor.java:544)
                   at com.adobe.flexbuilder.editorcore.editor.CodeAndDesignEditor$1.clicked(CodeAndDesignEditor .java:454)
                   at com.adobe.flexide.editorcore.ui.controls.ButtonBar.clicked(ButtonBar.java:289)
                   at com.adobe.flexide.editorcore.ui.controls.AbstractButton.sendClickEvent(AbstractButton.jav a:41)
                   at com.adobe.flexide.editorcore.ui.controls.ToggleButton.handleChange(ToggleButton.java:79)
                   at com.adobe.flexide.editorcore.ui.controls.ToggleButton.mouseDown(ToggleButton.java:66)
                   at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:179)
                   at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
                   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1598)
                   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1622)
                   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1607)
                   at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1396)
                   at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3484)
                   at org.eclipse.swt.widgets.Control.sendTrackEvents(Control.java:3036)
                   at org.eclipse.swt.widgets.Control.actionProc(Control.java:125)
                   at org.eclipse.swt.widgets.Display.actionProc(Display.java:363)
                   at org.eclipse.swt.internal.carbon.OS.CallNextEventHandler(Native Method)
                   at org.eclipse.swt.widgets.Widget.kEventControlTrack(Widget.java:1133)
                   at org.eclipse.swt.widgets.Control.kEventControlTrack(Control.java:2109)
                   at org.eclipse.swt.widgets.Widget.controlProc(Widget.java:375)
                   at org.eclipse.swt.widgets.Display.controlProc(Display.java:863)
                   at org.eclipse.swt.internal.carbon.OS.SendEventToEventTarget(Native Method)
                   at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3051)
                   at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
                   at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
                   at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
                   at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
                   at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
                   at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
                   at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
                   at com.adobe.flexbuilder.standalone.FlexBuilderApplication.start(FlexBuilderApplication.java :109)
                   at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
                   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)
                   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)
                   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
                   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
                   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                   at java.lang.reflect.Method.invoke(Method.java:597)
                   at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
                   at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
                   at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

             

                    So long,

                    Gregor Féng

            • 3. Re: FB 4.0.1 Design Mode not working
              reidit

              I was having the same problem but seem to have found a workaround for it.

               

              When I discovered the problem I tried uninstalling and reinstalling Flash Builder 4 and then re-applying the 4.0.1 update, only for the problem to

              occur again.

               

              When I tried again I noticed that the uninstall left some material in the Flash Builder 4 folder, namely the SDK folder containing the Flex 3.3.0 SDK I had added to my Flash Builder.  This 2nd time I removed this folder and the outer Flash Builder 4 folder  that had been left by the uninstaller.  I again reinstalled Flash Builder 4 and the 4.0.1 update and this time the problem did NOT recur!  I then reimported the Flex 3.3.0 SDK and Flash Builder 4 continues to work OK with no sign of this previous problem.

               

              So the workaround is:

              1) Run the Flash Builder 4 uninstaller

              2) Remove anything left by the uninstaller

              3) Reinstall Flash Builder 4

              4) Reapply the 4.0.1 update

              5) Import any additional SDKs etc. as needed

               

              The above has worked for me on 2 different Macs, hopefully, it'll help some others!

              • 4. Re: FB 4.0.1 Design Mode not working
                gfeng Level 1

                Hi,

                 

                that worked for me. Thanks a lot. It's just sad, that you have to complete deinstall it ...

                 

                        Again, thanks!

                • 5. Re: FB 4.0.1 Design Mode not working
                  reidit Level 1

                  Hi

                   

                  I'm glad it worked for you.  Hopefully Adobe will produce a proper fix sometime soon!

                   

                  Regards

                   

                  Peter

                  • 6. Re: FB 4.0.1 Design Mode not working
                    C. Agruss (Adobe) Level 3

                    Hi All,

                     

                    The Engineers looking into this determined that the problem was with some of the VC9 runtimes not always getting installed reliably via the Microsoft merge modules we're using to deliver them. They're of the opinion that these are bugs with the merge modules themselves, that can only be fixed by Microsoft.

                     

                    Assuming they are correct about the root cause, then a faster workaround (without requiring uninstall/reinstall of FB) would be to download the VC9 redist package from here and install it:

                    http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-3802B2AF5 FC2&displaylang=en

                     

                     

                    -Chris

                    • 7. Re: FB 4.0.1 Design Mode not working
                      reidit Level 1

                      Hi Chris,

                       

                      Thanks for the update but my problem was on a Mac not a PC and so the Microsoft solution won't work and is almost certainly not relevant!

                       

                      Regards

                       

                      Peter

                      --

                      Peter Reid

                      71 Leconfield Road, Loughborough, Leics. LE11 3SP, UK

                      Tel: +44 (0)1509 268843

                      Email: peter@reidit.net

                      • 8. Re: FB 4.0.1 Design Mode not working
                        C. Agruss (Adobe) Level 3

                        Thanks for the info about Mac versus Win here - you're correct of course that the microsoft merge modules can't really be the problem on OS X. It's uncertain whether this is part of the problem on Win, or if it's something else entirely.

                         

                        Re-reading the diagnosis from the Engineers, they provided more info than I had assimilated: they believe that another source of this problem is with trying to update the Player and Adobe Player for Embedding (APE) while it's in use. This would explain why it might have failed during the initial installation, but would succeed on subsequent installations.

                         

                        -Chris

                        • 9. Re: FB 4.0.1 Design Mode not working
                          gfeng Level 1

                          Hi,  just to be complete: I also use a Mac. Maybe Windows is innocent - this time (^_^)     The OS version is 10.6.4 at the current patch level and fixes.  So long, Gregor Féng

                          • 10. Re: FB 4.0.1 Design Mode not working
                            C. Agruss (Adobe) Level 3

                            Hi All,

                             

                            For tracking this down, it would help to know if everyone encountering this had run the Updater to patch FB 4.0 to FB 4.0.1, or if you had downloaded the full installer for FB 4.0.1?

                             

                            -Chris

                            • 11. Re: FB 4.0.1 Design Mode not working
                              gfeng Level 1

                              Hi,  I didn't find a full installer for 4.0.1, so I installed the version I got with the Order and applied the same patch installer. The only difference is, that between installation and patching, FlashBuilder was this time not started.  Greetings, Gregor

                              • 12. Re: FB 4.0.1 Design Mode not working
                                reidit Level 1

                                I used the updater, not a full 4.0.1 installer

                                 

                                Peter

                                • 13. Re: FB 4.0.1 Design Mode not working
                                  C. Agruss (Adobe) Level 3

                                  Thanks to both of you for this info about having patched. This will help us narrow down what's holding these libaries open.

                                   

                                  -Chris

                                  • 14. Re: FB 4.0.1 Design Mode not working
                                    the-jebbis

                                    I encounter the exact same problem.

                                    I am on Mac, 10.6.4 used the updater for 4.0.1 and can't use Design-mode anymore ...

                                     

                                    An error has occurred. See error log for more details.

                                    com.adobe.flexide.embeddedplayer.ExternalPlayer.<init>(ILcom/adobe/flexide/embeddedplayer/ IPlayerHost;I)V

                                    • 15. Re: FB 4.0.1 Design Mode not working
                                      C. Agruss (Adobe) Level 3

                                      We have yet to reproduce this error internally, but according to Gregor's note earlier, he was able to avoid the problem by making sure Fb wasn't running when the Patch was applied. The patch should automatically ask you to quit Fb before it proceeds, but if it doesn't, please try quitting Fb, and perhaps count to twenty before allowing the Updater to continue, as extra insurance that any libraries in need of replacing have time to unload fully.

                                       

                                      -Chris