5 Replies Latest reply on Oct 15, 2006 11:09 AM by stickleback

    go to url - is this right?

    stickleback
      sorry if this is a dumb question - but can someone just reassure me - please?

      I've created a small banner for a client which has an invisible button over the whole banner area. The action is on release go to url in a _blank window.

      when I save the swf file and open it on my desktop (alos happens the same when I control enter to test the banner) I get the finger and when I click my browser opens - but it doesn't go to the page specified in the action.

      Is this right? will it only work properly once placed in a website or am I missing something here? the action appears to be working but for the address it's supposed to find.

      Can anyone take the time to explain where or how I might check?

      TIA
        • 1. Re: go to url - is this right?
          fman05
          fyi - its usually good to post your code with the problem. The following should work.

          BUTTON.onRelease = function():Void {
          getURL("URL.html", "_blank");
          }
          • 2. Re: go to url - is this right?
            stickleback Level 1
            I didn't write the code - just used the behaviours panel chose "web" and the go to panel where I inserted the web address and selected _blank.

            this is automated (no?) and writes the code for me (or so I thought) and it appears to work part of the way - just doesn't go to the page specific once the browser is opened...

            hmmmmm
            • 3. Re: go to url - is this right?
              Level 7
              it does write the code for you but it should put the code in the actions
              panel. can you see the code in there? if so, what is it?

              --

              Dan Mode
              --> Adobe Community Expert
              *Flash Helps* http://www.smithmediafusion.com/blog/?cat=11
              *THE online Radio* http://www.tornadostream.com
              *Must Read* http://www.smithmediafusion.com/blog


              "stickleback" <webforumsuser@macromedia.com> wrote in message
              news:eglnfq$ooa$1@forums.macromedia.com...
              >I didn't write the code - just used the behaviours panel chose "web" and
              >the go
              > to panel where I inserted the web address and selected _blank.
              >
              > this is automated (no?) and writes the code for me (or so I thought) and
              > it
              > appears to work part of the way - just doesn't go to the page specific
              > once the
              > browser is opened...
              >
              > hmmmmm
              >


              • 4. Re: go to url - is this right?
                stickleback Level 1
                yes - this code is in the action panel:




                it would appear that the browser should open and go to the magic palace web site - but when I test it opens the browser - but it stays on my home page

                wondering if this is something that will "fix itself" once the swf file is on a web page (I'm not doing the web page - it's a banner ad for a client)
                • 5. Re: go to url - is this right?
                  stickleback Level 1
                  just in case anyone comes here looking for the same thing - I thought I'd let you know that the button works as it is supposed to once on an active site. it seems to be a protection kind of thing in Flash which doesn't make it fully active on the desktop

                  strange - and I can't think why this would be a preferred choice - but there you go....