3 Replies Latest reply on Jul 14, 2010 5:38 PM by chris.campbell

    Can't open xml file in linked source (error #2302)

    ehibbs

      Hey all, I'm building a level editor for a game I'm making, and have linked some of the packages in the game engine to my AIR project. However, I find myself unable to grab an xml file from the linked src with an HTTPService. I'm getting the 2302 error (which, I think, basically means "I can't find it!").

       

      I've tried relative pathing with and without "../" at the beginning of the path, and nothing. i'm not really sure what the issue could be. If there's any more information that you guys need to help with this, I'd really appreciate it.

       

      thanks,

      Eric

        • 1. Re: Can't open xml file in linked source (error #2302)
          chris.campbell Adobe Employee

          Do you mind posting the relavent code and an example path for the xml file?

           

          Chris

          • 2. Re: Can't open xml file in linked source (error #2302)
            ehibbs Level 1

            Edit: I realize there's a typo in the screenie, but rest assured that I've gotten the same error with correct file names. I've been renaming them to attempt to resolve filename ambiguity with the whole copy/paste thing, hence the typo.

             

            Oh, yeah, sorry. I was rather tired when I posted this, and kinda hacked something together, which is far from the solution I want.

             

            src_path.png

             

            The files I'm trying to use are xml files from my engine, enemyData, Level, patterns. When I make a new package and copy the files into localXml, the HTTPServices work, but when I try to get to the linked "xml" package, I get a #2032.

             

            I've tried "../xml/file", "../../xml/file", and "xml/file". None of these work.

             

            And I'm about 100% sure you can find a million violations of best practices, but I'm brand new to AIR, so forgive me.

             

            Thanks again, and sorry about not actually giving you any of the information necessary to help, haha.

             

            ~Eric

            • 3. Re: Can't open xml file in linked source (error #2302)
              chris.campbell Adobe Employee

              Hi Eric,

              Thanks for posting the screenshot.  It's odd that patterns isn't working correctly.  I tried something similar (based off the HTTPService code from this post) and my xml loaded from the project file as expected.  Check that out and let me know if it helps.

               

              Chris