13 Replies Latest reply on Aug 19, 2010 2:03 PM by Jesst124

    Imported Flash files are not playing in published output

    TtotheB Level 1

      Adobe Presenter 7 with the latest updates and PowerPoint 2007

       

      When I insert a Captivate 3 generated Flash file into a Presenter slide, the flash file does not play in the Published output. The slide's image is displayed for 5 seconds and then stops.

       

      After further review, I found that my imported Flash files are not included in the output. Any ideas?

       

      Terry

        • 1. Re: Imported Flash files are not playing in published output
          robva65 Level 2

          Hi Terry,

           

          It's been awhile since I've messed around w/ Captivate 3, but I have a quick question: does your Captivate content include a skin.swf file?  If so, then you may have to look at a couple of different solutions to fix the playback problem that you're seeing with Presenter.

           

          One fix includes eliminating the skin by turning the borders option off which will eliminate the "_skin.swf" file. That'll be one less file to deal with, but you need to do that BEFORE publishing in Captivate.  From there, you should end up with one swf file from your Captivate content; and then at that point you can include that swf in your Presenter content.

           

          And while we're at it....are you using any Full Motion Recordings at all?  I've seen instances where, as you reported, Captivate content will run for awhile, but then the screen "goes blank"...so I'm just curious to know if your Captivate content in actuality has many more files than the "base" swf---which is probably the swf you included in PowerPoint.

           

          Having said that, can you share more information about what your Captivate project looks like (in terms of the number of swf files you're working with, etc), and let's see if we can resolve this for you.

           

          Rob

           

          http://www.robrode.com/yabb/

          • 2. Re: Imported Flash files are not playing in published output
            TtotheB Level 1

            Hi Rob,

            Thanks for the reply,

            I just upgraded to Captivate 5 (via Tech Suite 2.5), started from scratch following your guidelines and I am getting the same results. Only an image (screen shot) of the video is displayed – for 5 seconds.

            Captivate 5 video: Single .swf file (290Kb) that plays for about 15 seconds. No audio, No playback controls, no borders. No full motion recording. I've also tried varations of AutoPlay on/off and without Preloaders.

            When Insert the Flash file into Presenter, the insert file dialog displays “This swf file may not playback correctly” near the bottom.

            I insert it anyway. The video plays correctly when I preview the slide presentation using PowerPoint’s Slide Show. While publishing, I’ve tried both options in Adobe Presenter > Manage Flash – “Control using presentation playbar” without success.

            I’m working and publishing to my C drive.

            One more thing to note is that in the Published folder (data), the flash file is not included. Windows Vista OS and IE8

            Terry

            • 3. Re: Imported Flash files are not playing in published output
              BillG-Seattle Level 1

              Have you tried saving the PowerPoint as a 97-2003 ppt file rather than as pptx? That seems to solve most issues for me.

              • 4. Re: Imported Flash files are not playing in published output
                TtotheB Level 1

                Saving to Powerpoint 97-03 worked. But now I've got some "Product Created by Captivate 5" box continually flashing in the middle of the video. Any suggestions?

                • 5. Re: Imported Flash files are not playing in published output
                  BillG-Seattle Level 1

                  Is Captivate 5 officially supported in Presenter yet?

                  Have you tried maybe saving and publishing as a prior version of Captivate?

                  1 person found this helpful
                  • 6. Re: Imported Flash files are not playing in published output
                    contact@phoenix-system.ne

                    hello,

                    I have a same bug. I using screenrecoder 5 for to create my flash and i imported flash files are not playing in published output

                    I have create flash with 30 pictures per seconde .

                    thx for all help

                    • 7. Re: Imported Flash files are not playing in published output
                      TtotheB Level 1

                      Hi Bill,

                       

                      I think you might be right. Captivate 5 may not be compatible with Presenter 7. However there is a new update available for Presenter 7 this morning. I'm quite sure it wasn't available late last week when my problems began. I'll install the update and try it again later.

                       

                      But getting back to your post. I tried importing Captivate 3 swf files into Presenter 7 and it worked perfectly.

                       

                      Terry

                      • 8. Re: Imported Flash files are not playing in published output
                        jp_arg

                        Hello.

                         

                        I've just installed the trial version of the e-learning suite (Captivate 5, Presenter 7, no updates available at this time for any of the two products). I've created a test presentation in Captivate, generated the SWF file (with the default options), and then tried to import it in Presenter. I have tried everything with the default options.

                        My problem is that when the project is published (in Presenter) the SWF movie starts making a weird noise (like if it tries to start for one second, and then restart again in a loop way), and images twinkle all the time.

                         

                        I tend to think that if I install a package of products, they should become preconfigured so that they can be used easily by using the default options, but it doesn't seem to be the case.

                         

                        So, as you can see, I need some help!!

                         

                        Thanks in advance.

                        Juan

                        • 9. Re: Imported Flash files are not playing in published output
                          robva65 Level 2

                          JP,

                           

                          I think part of the issue that you might want to look into is how Captivate 5 is publishing your content.  Before I get too far down a path here, I want to be clear about one thing in particular: I do not currently own Captivate 5...but I AM aware of a "bug" when trying to incorporate a Captivate swf into a Presenter course.

                           

                          Here's what I'd like you to look into: by default, Captivate 5 publishes swf files using Actionscript 3.0.  Actionscript is a code base used to program how things operate...but without getting terribly technical here, there's a setting in Captivate that allows you to publish using Actionscript 2.  That's critically important, because Presenter RIGHT NOW only accepts swf files using Actionscript 2.

                           

                          So check to see how Captivate handles file publishing...make sure it's set to Actionscript 2 and then try re-importing the Captivate swf into your Presenter content.

                           

                          Rob

                          • 10. Re: Imported Flash files are not playing in published output
                            jp_arg Level 1

                            Thanks Rob for your answer,

                             

                            I'm pretty sure that you are right, but take a look at: http://forums.adobe.com/message/3027666?tstart=1. They say that Captitative 5 does not support AS2.

                            I've spent some time navigating through the menues and can't find any option to activate AS2 instead of 3.

                            Are you sure that this setting is available in Captitative 5?

                             

                            Thanks again for your quick reply.

                            JP

                            • 11. Re: Imported Flash files are not playing in published output
                              robva65 Level 2

                              One thing to potentially consider here JP:

                               

                              If the publish settings in Cp5 do not allow for migration back to AS2, then the ONLY solution that I can offer is to link to your Captivate project using hyperlinking in PowerPoint.

                               

                              Not ideal when you're trying to keep everything in Presenter, but there are some HUGE advantages when linking to an externally-loaded Captivate movie.

                               

                              Hyperlinking can be done either by creating links directly in PowerPoint, or, if you're somewhat ambitious, you can also create a flash button that uses the getURL() method to point to (and load) the html file used to display the Captivate swf.

                               

                              Rob

                              • 12. Re: Imported Flash files are not playing in published output
                                Jesst124 Level 1

                                I will be out of the office starting  13/08/2010 and will not return until

                                31/08/2010.

                                 

                                If your matter is urgent, then please contact Emma Dawson on ext. 15832.

                                • 13. Re: Imported Flash files are not playing in published output
                                  Jesst124 Level 1

                                  I will be out of the office starting  13/08/2010 and will not return until

                                  31/08/2010.

                                   

                                  If your matter is urgent, then please contact Emma Dawson on ext. 15832.