2 Replies Latest reply on Aug 9, 2006 1:42 AM by Newsgroup_User

    Problem by copyPixels

    Level 7
      Hi

      I create one big image (image text) out ouf many small images with
      alpha-channel (images of letters)
      If I use some background image (colored shape of bitmap) and then copy all
      letters into destination image, the text looks nice (as desired)
      But if no background is used, resulting member is shown with some shades (it
      looks like alpha channels are copied as untransparent areas into resulting
      image). Can anyone help me with this annoying problem
      I do not want copy a part of background each time I create new Text

      Any help will be appreciated
      Thanx in advance
      LM


        • 1. Problem by copyPixels
          Chunick Level 3
          when using copyPixels and copying an image with an alpha layer into another, try this:

          imageObjRef.copyPixels(sourceImgObj, destRectOrQuad, sourceRect {, paramList})

          where {paramlist} looks something like below:
          [#maskImage: imageObjRef.extractAlpha()]
          • 2. Re: Problem by copyPixels
            Level 7
            This doesn't help
            I get the same result, with alpha-Channels looking white on resulting image
            Can someone give me exact parameters, that should be used?
            I spent a lot of time with this and with no result :-)



            "Chunick" <webforumsuser@macromedia.com> wrote in message
            news:ebbine$kp$1@forums.macromedia.com...
            > when using copyPixels and copying an image with an alpha layer into
            another,
            > try this:
            >
            > imageObjRef.copyPixels(sourceImgObj, destRectOrQuad, sourceRect {,
            paramList})
            >
            > where {paramlist} looks something like below:
            > [#maskImage: iimageObjRef.extractAlpha()]
            >