3 Replies Latest reply on Jul 22, 2010 6:10 AM by Tanya Heins-2I5OoU

    Some animations not working properly... please... help me :'-(

    _zebra_

      hey guys

       

      first: sorry for my bad english  but i'm not a native speaker and its 6:30 in the morning and i had a long night...

       

      im on this problem for hours now and im not gettin any further...
      not one bit...
      most of my animations are working wonderful. but some are just not appearing IF i wait for longer than 15seconds before i move from one state to another.
      while in flash catalyst all of the animations are working properly.
      so if any of you has only a hint for me i would be perfectly glad...

       

      to get to my exact problem:
      ive uploaded my page as far as i am so you can see the problem: http://www.sphynxx-artz.com
      if you click on "enter" and then click on "artist" right after the animation has finished there is no problem.
      BUT if you click on "enter" and wait for 15-20 seconds before you proceed 1 or 2 of the white rectangles are not flying in nor are they even appearing.
      i'm totally lost since i have no clue whats the problem or what i could do about it.

       

      i've tried literally everything i could do in flash catalyst... took out all my repetitions, moved all the animations around on the timebar, cried at my notebook, knelt down and praid... but nothing worked for me...

       

      thanks a lot...
      alex
      (here's the fxp-file:  http://dl.dropbox.com/u/8320904/flashpage_sphynxxartz.fxp )

        • 1. Re: Some animations not working properly... please... help me :'-(
          Tanya Heins-2I5OoU Level 3

          Hi,

           

          I see your Action Sequences are setup to bring in the appropriate content (your custom components) when a user interacts with 'On Click'.

           

          Though, It looks like you have only setup animated Transitions (fade, move, rotate 3d etc.) in your timeline for a few of of the possible user interactions. Take a look at 'welcome > artist' and setup the other state transitions in the same way.

           

          Another factor may be that your assets have not yet loaded.  Your total file size is 22.5MB.  I would suggest compressing your artwork (.pngs) so that they are much smaller.

           

          Here are a couple of related resources:

          Setting up transitions - http://tv.adobe.com/watch/flash-catalyst-cs5-feature-tour/working-with-transition-timeline s/

          Compressing images inside Flash Catalyst - http://help.adobe.com/en_US/flashcatalyst/cs/using/WSe0363cf428f0b465ffa9edb1273635cfd7-80 00.html

           

          Hope this helps,

           

          Tanya

          • 2. Re: Some animations not working properly... please... help me :'-(
            _zebra_ Level 1

            ok... my fault... seems i havent made myself clear enough...

            but thanks for the answer fast answer first.

            i know i havent set up most of my transitions yet.

            to explain my problem exact:

             

            after you've gotten from state "enter" to "welcome" the animations appear perfectly.

            now there are two ways you can proceed:

             

            first one: you dont waste any time and click on "artist" immediately. if you do so this animation will appear as it should an the 3 rectangles will fly in properly (resize, move, fade).

             

            second way: you dont click on artist immediately but wait for 10 seconds or something. afterwards you click on "artist" this time the animation will appear again. BUT 1 or 2 of the rectangles (depends on how long you wait) will NOT fly in.

             

            that's the main problem.

            the animations are just transitions with resize move and fade. nothing else. the rectangles are not even components.

             

             

            the problem i can live with but which is kinda annoying, too is:

            when you go from state enter to welcome there's a slowly pulsing circle under the foot of the person.

            i let it fade in first and then use a fade out and a fade in which are of the same duration, repeating forever with the same delay... but after some minutes the repeat seems to crash and the animation is getting kinda wrong... jumping from one state to another, not "fading" anymore.

            i hope i have made myself clear enough.

             

            and i didnt optimize the graphics yet because i need them to be still editable.

             

            thank you for your help

             

            alex

            • 3. Re: Some animations not working properly... please... help me :'-(
              Tanya Heins-2I5OoU Level 3

              second way: you dont click on artist immediately but wait for 10 seconds or something. afterwards you click on "artist" this time the animation will appear again. BUT 1 or 2 of the rectangles (depends on how long you wait) will NOT fly in.


              I am not sure about the exact reason why the problem above is occurring.  You do have a lot happening in your project (90+ layers).  Perhaps try reducing the amount of layers you are using.   For example you could create the "rechtsoben" and the "rechtsoben's Outer Glow" as one object (a rectangle with the outer glow filter).  Right now you are animating a lot of png images.  It would help if they were vectors created/imported into Flash Catalyst.

               

              the problem i can live with but which is kinda annoying, too is:

              when you go from state enter to welcome there's a slowly pulsing circle under the foot of the person.

              i let it fade in first and then use a fade out and a fade in which are of the same duration, repeating forever with the same delay... but after some minutes the repeat seems to crash and the animation is getting kinda wrong... jumping from one state to another, not "fading" anymore.

              Regarding this other issue (above) - Your timeline does do a fade in - fade out - fade in.  And the result is behaving as it should.  It doesn't repeat or loop.  The transition occurs only once when you click from enter to welcome.

              snap004.jpg

              Hope this helps.

              Tanya