1 Reply Latest reply on Jul 25, 2010 12:23 PM by Goldfish1957

    ProMedia E-book reader unable to install DRM

    biepmiepje

      When trying to install Adobe Digital Editions on my new ProMedia Ebook Reader (bought yesterday) I get a message: this content requires Flash. When I try to install that I receive a message : unsupported device. Who can help me please with this.

      I tried to chat with Adobe, but they cannot help me either.

      Thxs