16 Replies Latest reply on Aug 19, 2010 11:34 PM by Marco Lonardi

    Update Adobe Reader 9.3.3

    Marco Lonardi

      I can't update the last version of Adobe Reader 9.3.3

      i use XP System.

      Thank you for your consideration.