3 Replies Latest reply on Aug 1, 2010 7:31 PM by RED UFO

    I bought a new computer with Windows7 and my PE 2.0 won't work.

    RED UFO

      I know I am behind the times but I like mt 2.0. I installed 2.0 on the new computer with Windows 7 and it freezes. Does this mean I need PE 8.0? If so where will I find the program the least expensive?

       

      Thanks,

       

      Al