11 Replies Latest reply on Aug 5, 2010 7:45 AM by Amarelv

    Help not generating

    pmcg56

      When I try to generate a .chm file using Microsoft HTML Help the system processes for a while and then exits out of the entire program and takes me back to my desktop.  When I go to the directory that I have saved it to there is a "!chm_tmp_folder_0" folder.  (Earlier in the day I was able to generate a .chm file with no problem.) What am I doing wrong?  Thank you so much for any help you can provide.  

        • 1. Re: Help not generating
          RoboColum(n) Level 5

          The "!chm_tmp_folder_0" folder is a temporary working folder used during the generation of the CHM and is deleted once completed. The fact that the directory is still there, indicates an issue with the generation. Is this only happening on one project? Can you generate a CHM on another project? If you can, try creating the CHM to a different local directory. Out of interest where are you generating to?


            The RoboColum(n)   @robocolumn   Colum McAndrew
          • 2. Re: Help not generating
            pmcg56 Level 1

            Thank you for responding.  In answer to your questions:

             

            1.  I did try to generate a .chm file for another project and received the same behavior; Robohelp runs through the generation screens and then just exits out of the program.  There is a !chm_tmp_folder in the directory and a .chm file, but when I try to open the .chm file I get a message saying "Cannot open the file:  mk:@MSITStore:c:\directory\file name

             

            2.  I'm generating output to a subdirectory of my root drive (example:  C:\CHM\filename).

             

            I've tried generating the .chm to a different directory and I have tried renaming the file.  Neither seemed to changed anything, I still get kicked out of the program.

             

            I am working in a version control environment with 4-5 other users.  I had one of the other users try to generate a.chm file and they receive the same behavior at their workstation.  Could this be a network issue?   I'm flying blind here...so any help is greatly appreciated.  Thank you in advance.

            • 3. Re: Help not generating
              RoboColum(n) Level 5

              <shudder>You used the "N" word</shudder>

               

              Are you saying your source files are on a network drive after you have checked them out of source control? If so the issues you are having trying to compile could be just the start of things to come. Never ever work on RoboHelp source files on anywhere but a local drive.


                The RoboColum(n)   @robocolumn   Colum McAndrew
              • 4. Re: Help not generating
                pmcg56 Level 1

                Uh-oh, now I'm frightened. ;-)

                 

                We work from our local drives by checking out files, working on them, then saving and checking them in.  The actual "source" files are on a network drive but all of our work is done locally and then is checked in.  We are using RoboSource Control 3.1.

                 

                I'm trying to troubleshoot the problem but I'm running out of options.  Any ideas as to what would make the .chm compiling process behave this way?  Or, are there some actions I should take to keep the problem from escalating.

                 

                Thank you!  It's nice to know there's someone out there willing to help.

                • 5. Re: Help not generating
                  Captiv8r Adobe Community Professional & MVP

                  Hi Colum

                   

                  I'm doubtful that's the case as they stated they were working from C and all the examples say the same.

                   

                  My own guess here is that they will discover they have a single topic that is causing the compilation to fail. Figuring out exactly *WHICH* topic is the task.

                   

                  How to do this? Divide and conquer.

                   

                  Copy the project to another folder. Remove half the topics and compile. Did it work? If so, the problem is likely in the half that was removed.

                   

                  Work that way until you determine which topic is the culprit.

                   

                  Cheers... Rick

                   

                   

                  Helpful and Handy Links

                  RoboHelp Wish Form/Bug Reporting Form

                  Begin learning RoboHelp HTML 7 or 8 moments from now - $24.95!

                  Adobe Certified RoboHelp HTML Training

                  SorcererStone Blog

                  RoboHelp eBooks

                  • 6. Re: Help not generating
                    MergeThis Level 4

                    Sometimes the generation or layout processes get corrupted and need to be bypassed. Try these (if #1 doesn't work, try #2)

                    1. Delete the entire folder where you are generating and try generating again.
                    2. Create a new layout (not a copy of your existing one), and generate to a new folder.

                     

                     

                    Good luck,

                    Leon

                    • 7. Re: Help not generating
                      pmcg56 Level 1

                      Thank you to everyone for trying to help.  I tried creating a new directory and filename--no luck.  I then tried creating a new layout and when I tried to generate the .chm file, I saw the same behavior -- the software runs through the generating screens then just exits out of the program and I'm back at my desktop.  I can't read what's happening in the output file because it scrolls so fast and then I'm kicked out of the program.  Does anyone know what the name of that file is so I could take a look at it?

                       

                      I tried to run a .chm for a different project and received the same behavior.  So it doesn't look like it's the individual project.  What gives?

                       

                      I'm new to Robohelp so there's a good chance I'm missing something.  I have three different TOC's in the one project, could that cause a problem?  I've tried generating using each one and the end result is always the same, I'm kicked out of Robohelp and there's only a !chm temp file and a non-functioning .chm file in the directory I generated to.

                       

                      Thanks for any help.

                      • 8. Re: Help not generating
                        Jeff_Coatsworth Adobe Community Professional & MVP

                        What happens when you try playing with the sample projects that RH ships with?

                        • 9. Re: Help not generating
                          pmcg56 Level 1

                          Thank you for the suggestion.  I just tried it and I was able to produce a MS HTML Help .chm file from the sample .xpj.  What does that mean?  That my project's .xpj is funky? 

                          • 10. Re: Help not generating
                            ElisaFnord Level 2

                            Something about your project is funky. It doesn't have to be the .xpj file.

                             

                            You've ruled out two options (problems with the folder you're generating to, problems with RoboHelp generating code). Excellent work.

                             

                            Now would be a good time to work on option 3 - problems with a topic that stop the generating process. This is where you use Rick's "divide and conquer" approach (see above). It doesn't take as long as you think - and remember to take a backup first!

                             

                            Good luck,

                            Elisa

                            • 11. Re: Help not generating
                              Amarelv

                              We're also having the same issue with unable to generate the project into a CHM file.

                              I get stuck halfway through the process - please see screen shot below.

                              HELP.JPG

                               

                              In the !SSL! folder, I could see a

                              temp.JPG

                              but not the actual CHM file.  Any help is greatly appreciated on what we could have this issue resolved.