8 Replies Latest reply on Jan 19, 2011 1:32 PM by lordB8r

    FlexUnit 4.1 causing Error #1009

    sdeschenes17

      Hi again,

       

      When I run execute the FlexUnit tests in Flash Builder using FlexUnit 4.0, all my tests pass with flying colors. If I switch to FlexUnit 4.1 beta 1 and run the tests, I get an Error #1009: Cannot access a property or method of a null object reference. The error points to spark.components::WindowedApplication/enterFrameHandler and the file is located at “E:\dev\4.0.0\frameworks\projects\airspark\src\spark\components\WindowedApplication.as:23 50”.

       

      What’s strange is this error only happens when I use FlexUnit 4.1 beta 1. I even tried using FlexUnit 4.1 beta3 and I still get this error. This will not happen when I use FlexUnit 4.0.

       

      I thought this might be similar to a problem someone reported in this forum: http://forums.adobe.com/thread/679488?tstart=0.

       

      Has anyone encountered this particular issue?

       

      Note: Using Flex 4.0 SDK w/ AIR 2.0

       

      Thanks,

      Scott Deschenes