1 2 Previous Next 45 Replies Latest reply: Aug 26, 2012 1:52 PM by abustraan RSS

    scanintf.dll is missing

    Erol Community Member

      can't use twain for Canon MP600 in Acrobat 9. Scanner does work. have even tried twain org twacker to test it.


      have latest driver and MP Navigator from Canon


      running Win7 64bit



        • 1. Re: scanintf.dll is missing
          Bill@VT MVP

          You do not mention the version of AA9. It is currently at AA9.3.3. If you are not updated, try to update AA and try again. Also, have you tried the scan from other software, such as a graphics package?

          • 2. Re: scanintf.dll is missing
            MichaelKazlow ACP/MVPs

            You may have a functioning twain driver, but is it 64-bit native???

            • 3. Re: scanintf.dll is missing
              Erol Community Member

              Acrobat 9.3.3.

              Tried XnView and it lists my Canon MP600 under "Select TWAIN source" & "Acquire" pulls up the Canon ScanGear dialog.


              scanintf.dll is a Canon ScanGear file. Seems Acrobat know to call it and fails.


              I believe Acrobat is 32bit, yes? (Only Photoshop is 64bit, which is another separate mess.)

              • 4. Re: scanintf.dll is missing
                Fiske12 Community Member

                I'm experiencing the exact same problem with brand new Adobe Acrobat X. I'm using a Canon Lide 600F, running on Windows 7 64-bit.


                Did you resolve this problem in Acrobat 9?

                • 5. Re: scanintf.dll is missing
                  Erol Community Member

                  No luck! Seems it's Canon just doesn't have 64bit scanner driver? Seems Canon just orphaned this older printer.

                  • 6. Re: scanintf.dll is missing
                    ravishar Adobe Employee

                    I just tried with Canon PIXMA MP780 with 64 Bit Win 7 and it worked with Acrobat X. Are you able to scan with other applications, like MSPAINT, TWACKER that use TWAIN driver?

                    • 7. Re: scanintf.dll is missing
                      ravishar Adobe Employee

                      Can you please check if you have latest 64 Bit driver? You may want to download one from http://software.canon-europe.com/products/0010401.asp

                      • 8. Re: scanintf.dll is missing
                        Fiske12 Community Member

                        Yes, I'm able to scan with other programs. I'm also able to scan with Acrobat X, but only using Custom Scan. All the presets are greyed out, and when I select Configure Presets, and select the twain driver I get the error about the missing SCANINTF.dll. When selecting the WIA driver I get this error:"This scanner does not support presets".


                        What is strange is that I have used this scanner with Acrobat 9 and Windows 7 64-bit before, and everything worked just great. Seems to me this is a problem with Acrobat X, not the scanner driver..


                        I'm using the latest Canon driver (12.12).

                        • 9. Re: scanintf.dll is missing
                          Brecker10 Community Member

                          OK, add me to the list. I was able to use my Canon CanoScan 8600F up until the last Adobe Std. update. Then I get the missing scanintf.dll error.  Any help from the frontlines would be greatly appreciated.


                          BTW, I tried downloading the lastest x64 Canon driver (I'm on Win7x64) with no joy. I'm up to date on Adobe Std.

                          • 10. Re: scanintf.dll is missing
                            Fiske12 Community Member

                            Just to let you know: I was able to get scanning using profiles working again by downgrading to Acrobat 9 Pro. Thanks for your input.

                            • 11. Re: scanintf.dll is missing
                              Erol Community Member

                              Problem on my systems is Canon ScanGear won't load.


                              In MP Navigator, clicking "open driver" does nothing. In the scan section, it just says "scan failed"


                              Twacker also can't load it. scanintf.dll not found.


                              Are you thinking that Acrobat broke twain some how? Both Acro 9 & 10, & nothing other than WIA scan work.


                              Spent quite some time with Canon on this. They are completely clueless. Only know how to unistall and reinstall the driver. 

                              • 12. Re: scanintf.dll is missing
                                Brecker10 Community Member

                                Re: Windows 7 (64-Bit) with a CanonScan 8600F Scanner


                                Previously I had the "scaninitf.dll is missing" error, but now after trying to re-point Adobe 9 Std to the scanner, I'm also getting "Error while interacting with the scanner: the selected scanner was not found."


                                Now here's the interesting part: If I create a PDF using the CanoScan Toolbox (it is pointed to "C:\Program Files (x86)\Adobe\Acrobat 9.0\Acrobat\Acrobat.exe"), and create a PDF all works fine. If I leave Adobe open to this created document, and try a 'Create PDF from Scanner' operation from within Adobe directly to create a new scanned PDF, Adobe works as it used to before this most recent Adobe update. That is, it finds and scans a new PDF just fine!


                                For now, I'm using the CanoScan toolbox to fire up Adobe 9.0 for creating PDF's from the scanner...and patiently waiting for an update to be pushed down from Adobe Galactic.

                                • 13. Re: scanintf.dll is missing
                                  Erol Community Member

                                  The problem is with Canon. Their ScanGear fails. Try to run it directly from "MP Navigator 3.0" pick "open scanner driver" nothing happens. I've talked to Canon and it's the usual hole of not knowing what to do. Just stop buying Canon for win7 x64 I guess?

                                  • 14. Re: scanintf.dll is missing
                                    Brecker10 Community Member

                                    Erol, thanks for your post.


                                    We must have slightly different issues. I don't have a ScanGear app on my install (just a readme and uninstall icon in the folder where it should be). This was from a fresh install from the CanonUSA site for the 8600 Win7x64 driver, Adobe RGB, and CanoScan Toolbox 5.0.


                                    My toolbox runs just fine and in all functions. The Windows Devices and Printers Scanner icon operates just fine with no problems. All other scanner-related apps on my machine operate properly with the scanner. It is only Adobe Acrobat Std. (core version 9.4.1) that is not operating properly. Prior versions of Adobe 9.0 used to work properly on my machine but now don't since the latest update.

                                    • 15. Re: scanintf.dll is missing
                                      Erol Community Member

                                      Ah! I have an MP600. So, as with every hardware vendor, they stopped updating the software so it would become obsolete and I'd have to buy a new one. LOL


                                      But, as I guess, new software, same old garbage twain driver. I think my drive is from 2006, though the software install is 2009. SOS!


                                      What's the best printer software/company? Alas, it's all made in China, so probably all the software is poor. Just a sad fact of cheap harware prices.

                                      • 16. Re: scanintf.dll is missing
                                        abustraan Community Member



                                        I even went so far as to copy the twain drivers to the Acrobat Directory, and create an environment variable and now I get the image above:


                                        Windows 7x64 Canon Lide600F with 12.12 drivers and CanoScan Tool Box 5.


                                        If I try to use a Custom Scan I get this image:



                                        Any thoughts? NE1?Capture2.PNG

                                        • 17. Re: scanintf.dll is missing
                                          abustraan Community Member

                                          I have a solution! I killed my ability to twain scan at all in

                                          photoshop just a little while ago while checking 64-bit Photoshop for twain on another thread.


                                          My earlier post stated I tried an environment variable and copying the twain files to the Acrobat directory. I have since removed them and the environment variable and added this path to my Path Statement in my System Variables: C:\windows\twain_32\CNQ4802.


                                          I would check the twain path per the directory that your driver(s) create.


                                          I can now scan in any mode from Acrobat X.


                                          Hope this helps

                                          • 18. Re: scanintf.dll is missing
                                            LarryJones22 Community Member

                                            Abustraan - you did it! Thank you. I added my twain driver path to the system environment path, re-booted, and all is well.


                                            For Adobe staff - in case they ever read this thread, here are the two places this twain driver file is referenced in my registry:








                                            Mine was a Win7x64 OS.


                                            Thank you again Abustraan for getting my Adobe back up and working again with my Canon scanner! Good Job!

                                            • 19. Re: scanintf.dll is missing
                                              Bobby_Johnson_ Community Member

                                              May I know the scanner make and model you are having? Is that from  Canon or from any other manufacturer?

                                              • 20. Re: scanintf.dll is missing
                                                LarryJones22 Community Member

                                                Canon 8600F

                                                • 21. Re: scanintf.dll is missing
                                                  abustraan Community Member

                                                  Thank you Larry. Glad it worked for you.


                                                  Some days I get lucky, some days I make money...lol


                                                  As for the 8600F problem.


                                                  Trying to determine if the scanner supported Twain functionality previously, I can only assume that it's still there and just have to figure out how to "Path" it.


                                                  I noticed that Canon does have Windows 7 x64 bit drivers and an Updated Tool Box: http://www.usa.canon.com/cusa/support/consumer/scanners/canoscan_series/canoscan_8600f#Dri versAndSoftware


                                                  If you've already installed the drivers, I'd check the Windows\Twain_32 folder for any subdirectories and add "C:\Windows\Twain_32\<Subdirectory>" to the environment variable "Path =".


                                                  Hope it helps.

                                                  • 22. Re: scanintf.dll is missing
                                                    Erol Community Member

                                                    Indeed abustraan, you are a hero!

                                                    Adding the path to c:\windows\twain_32 + my printer model (checking the folder) has twain picked up in all my apps. None were working, only WIA.


                                                    I spent a couple hours with Canon support on the phone and they were completely clueless. Said, "it should work" but couldn't verify on their side because they didn't have any x64 systems.




                                                    Message was edited by: Erol

                                                    • 23. Re: scanintf.dll is missing
                                                      Erol Community Member

                                                      Any ideas on how to get 64-bit scan to work? Does Canon even provide that?

                                                      Photoshop 64 of course needs that. so it is still dead.

                                                      • 24. Re: scanintf.dll is missing
                                                        abustraan Community Member

                                                        I just re-installed the ScanGear 12.12 64-bit software from the Canon Website and here is what the readme says:


                                                        Copyright CANON INC. 1998-2007. All Rights Reserved.


                                                        Canon ScanGear Version 12.1.2 64-bit Edition
                                                        for Microsoft Windows


                                                        "Windows" is a trademark of Microsoft Corporation, registered in the
                                                        United States and other countries.
                                                        All other names and brands mentioned here may be trademarks or
                                                        registered trademarks of their respective owners.


                                                        < Contents >

                                                        Installation Components
                                                        Deleting ScanGear


                                                        < Foreword >

                                                        This product is a 64-bit TWAIN-compliant scanner driver for CanoScan
                                                        LiDE 600F scanner.
                                                        When this driver is selected from within a TWAIN-compliant
                                                        application program, this scanner can be used to scan image data.

                                                        < Installation Components >

                                                        The following components make up the installation package:

                                                          - Installer (Setup.exe)
                                                            Installs the TWAIN-compliant scanner driver for CanoScan
                                                            LiDE 600F scanner on your computer.

                                                          - ScanGear 12.1.2 for CanoScan LiDE 600F (hereafter referred to as
                                                            The software allows you to scan image data.

                                                          - Uninstaller
                                                            Lets you remove the ScanGear from your computer.

                                                          - Readme (readme_english.txt)
                                                            This document. It contains important information about the
                                                            ScanGear. To view it after installation, select [Start]-
                                                            [(All) Programs]-[CanoScan LiDE 600F]-[Readme].

                                                        < Deleting ScanGear >

                                                        Delete unnecessary ScanGear according to the following

                                                          1.  From the [Start] menu, select [(All) Programs], and then
                                                              select [CanoScan LiDE 600F].

                                                          2.  Click [Uninstall].

                                                          3.  If the [Scanner Driver Uninstaller] dialog box appears,
                                                              click the [Execute] button.

                                                        • 25. Re: scanintf.dll is missing
                                                          mkmike207 Community Member

                                                          Thanks, you did it for me as well (Canoscan 4400F, Windows 7 x64, Canon 12.13 x64 drivers).

                                                          • 26. Re: scanintf.dll is missing
                                                            tollersdelight Community Member

                                                            I'm having kind of the same problem.

                                                            My Brother MFC-9840CDW used to work perfect on Adobe Acrobat Pro 9.5.0

                                                            Suddenly, a few days ago it stopped working. In fact, it looks like all my Twain-driven applications has stopped working, but only my WIA works (example: Photoshop).

                                                            I have tried removing and re-installing the complete software package from Brother as well as ensured that it was the correct entries in the Registration Database.

                                                            Nothing seems to help though...

                                                            Any idea on how to manually install the Twain drivers or any other solutions?

                                                            When opening Acrobat and selecting Create PDF - from scanner - I select the Custom Scan. In the pop-up there is no scanner to be selected. It's driving me nuts!


                                                            I'm running Win 7 64-bit


                                                            • 27. Re: scanintf.dll is missing
                                                              Erol Community Member

                                                              Do a system restore to before the date it stopped working. Will take just a few minutes compared to trouble shooting.

                                                              • 28. Re: scanintf.dll is missing
                                                                tollersdelight Community Member

                                                                Tried that – No success.


                                                                Even tried installing the USB version of the driver – didn’t help either.


                                                                Any other ideas?






                                                                Venlig hilsen / Best Regards


                                                                Lars Møller



                                                                • 29. Re: scanintf.dll is missing
                                                                  abustraan Community Member

                                                                  tollersdelight -


                                                                  Are you receiving the same scanintf.dll error when you try to scan?


                                                                  You mentioned Photoshop in your inital post. Please ensure that you are running the 32-Bit Version of Photoshop, and if using CS5 or 5.5, you'll need to install the optional plugins found here: http://www.adobe.com/support/downloads/detail.jsp?ftpID=4688


                                                                  I am only familiar with Canon Scanners (specifically the Lide600), but I have found that the scanner software/drivers don't include a an entry for the scanner drivers in the path statement.


                                                                  You can either open a command window and type 'path' and enter to list the directories included in the path or you can right-click 'my computer' choose properties, then 'Advanced System Settings', then the 'Advanced Tab', then click the 'Environmental Variables' button. Scroll to the 'Path' entry inthe System Variable list' and click edit. Copy that whole entry and paste it into notepad. Review the contents, add the path to the folder created by the twain drivers for your scanner in my case it's "C:\Windows\twain_32\CNQ4802". When adding paths to the paths statement seaparate them with a ";" (semicolon).

                                                                  • 30. Re: scanintf.dll is missing
                                                                    abustraan Community Member



                                                                    I have done more checking into Twain functionality for 64-Bit and there aren't any true 64-Bit twain drivers for Canon Scanners.


                                                                    Even though the driver that I have downloaded says in the readme file that it is 64-Bit Twain compliant, it only works with 32-bit apps.

                                                                    • 31. Re: scanintf.dll is missing
                                                                      tollersdelight Community Member



                                                                      I think I found the problem. Brother scans to TWAIN by use of PaperPort.


                                                                      That software has disappeared from my PC (don’t know how).


                                                                      I’ll look for the original discs and try to install it again.


                                                                      I’ll let you know the outcome






                                                                      Venlig hilsen / Best Regards


                                                                      Lars Møller



                                                                      • 32. Re: scanintf.dll is missing
                                                                        GeneHumbert Community Member

                                                                        Here's another case of the same thing.  Adobe Acrobat X, gets the scanintf.dll missing with my Canon LiDE 70.  That scanner works perfectly with Acrobat 9.  I'm really getting burned out on this thing.  I NEED to scan in documents to get my home and car insurance set up, and I can't DO it with this POS!!!  Does anyone from Adobe ever read these forums?  Or are we just spinning wheels?  I paid a lot of money to Adobe for all the various stages of the CS3, CS4, CS5, CS5.5, and soon the CS6 web premium suites.  I DON'T seem to be able to get support, though!


                                                                        E. Humbert

                                                                        • 33. Re: scanintf.dll is missing
                                                                          abustraan Community Member

                                                                          You'll want to:Go to C:\Windows\Twain_32

                                                                          Make a note of any subdirectories under this folder. For the Lide 600F my subdirectory is 'CNQ4802'


                                                                          Right-Click Computer

                                                                          Select Properties

                                                                          Select Advanced tab

                                                                          Click the Environment Variables tab

                                                                          Scroll to the 'Path' statement in the System Variables section

                                                                          Edit the 'Path' entry

                                                                          Add: "; C:\Windows\twain_32\<noted subdirectory> (use a ';' semicolon) to separate multiple entries, and exclude the quotes


                                                                          If you have multiple subdirectories under the twain_32 folder they will need to be added individually.


                                                                          As of right now there's no 64-Bit Twain drivers. Only WIA drivers.


                                                                          But I've been able to successfully use this with Acrobat X and Photoshop Rrequires the Optional Photoshop Plug-in for Photoshop C5, 5.5 and CS6 (using version CS5) Download from Adobe to enable the twain functionality.



                                                                          • 34. Re: scanintf.dll is missing
                                                                            doctor-man Community Member

                                                                            I have

                                                                            canoscan lide 600F

                                                                            windows 7 x64 ultimate

                                                                            adobe acrobat 10


                                                                            all programs in my computer recognize the WIA side of this scanner but not the TWAIN

                                                                            I did follow the instructions above for variable

                                                                            I have the following folder C:\windows\twain_32\CNQ4802  which I have added to the variable enviroment Path


                                                                            reboot couple of time

                                                                            installed the newest drivers which are not new at all 2007-2009 date


                                                                            upgraded acrobat from 10 to 10.1.3

                                                                            nothing helps...


                                                                            is there anything I am missing

                                                                            p.s. I have an HP Envy 17 3200 with ivy bridge and  all the ports are USB 3 with newest updates from microsoft , intel and HP

                                                                            • 35. Re: scanintf.dll is missing
                                                                              abustraan Community Member

                                                                              Sorry you're having problems with your new awesome sounding computer.


                                                                              At a command prompt: Type path and "enter" and make sure the entry "C:\Windows\twain_32\CNQ4802" does exist. If there are other entries in the path statement make sure the entry is preceded by a ";" and followed by a ";". I am using Windows 7 Pro x64 with Adobe Acrobat X Pro 10.1.3 and CS5.5 and tried CS6 Trial and it worked with them as a Twain Scanner.

                                                                              • 36. Re: scanintf.dll is missing
                                                                                doctor-man Community Member

                                                                                oh when I type path in a CMD.exe


                                                                                I get bunch of paths but non of them is the one I entered ..



                                                                                how can I force the path in there?


                                                                                detailed response on the steps on that


                                                                                again in windows 7 x64

                                                                                • 37. Re: scanintf.dll is missing
                                                                                  doctor-man Community Member

                                                                                  okay I forced the    C:\Windows\twain_32\CNQ4802   

                                                                                  in there and checked the cmd > path and I see it now but it made no difference 3 more restarts , uninstall , reinstall drivers and adobe...


                                                                                  I am out of ideas as to what to do...

                                                                                  • 38. Re: scanintf.dll is missing
                                                                                    abustraan Community Member

                                                                                    Hummm. I just tried a couple of things


                                                                                    I set up a 2nd computer that has Win 7 Ult x64 and Installed Acrobat X 10.1.3 from scratch. Installed the same 12.1.2 that I had on my other computer and got the same error. Added the 'C:\Windows\twain_32\CNQ4802' to the path statement. Rebooted and It works just fine.


                                                                                    As a 2nd test, I removed the 'C:\Windows\twain_32\CNQ4802' from the path statement and rebooted and the error returned. I re-added it and rebooted and it scanned okay.


                                                                                    Is the file 'SCANINTF.DLL' in the folder 'C:\Windows\twain_32\CNQ4802'?


                                                                                    Also in case you don't have the 64-Bit version of the Canon 600F they can be found here.


                                                                                    http://www.usa.canon.com/cusa/support/consumer/scanners/canoscan_series/canoscan_lide_600f #DriversAndSoftware


                                                                                    I can't think of anything else right-off hand. You can email me at abustraan @ h o t m a i l . c o m  minus the spaces if you'd like to do a webex.

                                                                                    • 39. Re: scanintf.dll is missing
                                                                                      doctor-man Community Member

                                                                                      I think I figured it out


                                                                                      there should be no space after the semicolon   ;

                                                                                      and there should be a \ at the end of the path


                                                                                      like this


                                                                                      PATH                  another_link_here\;C:\Windows\twain_32\CNQ4802\


                                                                                      that fixed the twain drivers... now my options are grayed out in adobe but I think that should go away after couple restarts or a reinstall of adobe acrobat


                                                                                      THANK YOU GUYS...


                                                                                      PS> Canon is fast with email but they have no clue about this issue

                                                                                      1 2 Previous Next