2 Replies Latest reply on Aug 24, 2010 4:49 AM by Flex don

    unable to resolve resource bundle "myResources" locale "en_US" ?

    flex4 Level 2

      Hi All,

       

       

                          I have created two locales one is en_US and Second one is fr_FR. I placed these two files in locale file. These files directory structure is

       

                      ......\src\locale\en_US and .....\src\locale\fr_FR . After  placing these two files in the project i was compile my application and it is showing just like unable to resolve resource bundle "myResources" locale "en_US"...  can any one help me how to configure the resource bundle in my flex application... i dont have exposure to resource bundle earlier. So plese tell me the configurations step by step.. how to configure...

       

       

                             My resource property name is myResource.properties .

       

       

      Thanks

      Ram

        • 1. Re: unable to resolve resource bundle "myResources" locale "en_US" ?
          Flex don

          Hi Friend,

           


               I hope you are following, tour de flex's example for localization. If so then I am afraid that the directory structure should be "..\src\locale\en_US\myResources.properties" and "..\src\locale\fr_FR\myResources.properties"

          • 2. Re: unable to resolve resource bundle "myResources" locale "en_US" ?
            Flex don Level 1

            If you have already followed the correct directory structure. Then please check the following,

             

            1. change the compiler arguments, to "-locale=en_US,fr_FR -source-path=locale/{locale}"

            you can find the compiler arguments, by right-clicking over the project name on the flex builder, properties-> flex compiler->compiler options.

             

            2. please check whether both the locale properties files uses the correct encoding. If not change them to "UTF-8"

            you can find this, by right-clicking over the properties file on the flex builder, properties->resources->text file encoding